summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-01-01 00:39:29 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-01-01 00:39:29 +0000
commit12cc1079b12f37f1fbbf9cbb940d129f3b9fb8bc (patch)
tree80283e2f6a2b14213416fee03982dac9014fa61e /media-libs/sdl-sound
parentnew version (diff)
downloadhistorical-12cc1079b12f37f1fbbf9cbb940d129f3b9fb8bc.tar.gz
historical-12cc1079b12f37f1fbbf9cbb940d129f3b9fb8bc.tar.bz2
historical-12cc1079b12f37f1fbbf9cbb940d129f3b9fb8bc.zip
sdl-sound, a library that handles the decoding of several popular sound file formats
Diffstat (limited to 'media-libs/sdl-sound')
-rw-r--r--media-libs/sdl-sound/files/digest-sdl-sound-0.1.41
-rw-r--r--media-libs/sdl-sound/sdl-sound-0.1.4.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/media-libs/sdl-sound/files/digest-sdl-sound-0.1.4 b/media-libs/sdl-sound/files/digest-sdl-sound-0.1.4
new file mode 100644
index 000000000000..5b869e8abf83
--- /dev/null
+++ b/media-libs/sdl-sound/files/digest-sdl-sound-0.1.4
@@ -0,0 +1 @@
+MD5 d40d64ec615098b29b5156c033385dec SDL_sound-0.1.4.tar.gz 233472
diff --git a/media-libs/sdl-sound/sdl-sound-0.1.4.ebuild b/media-libs/sdl-sound/sdl-sound-0.1.4.ebuild
new file mode 100644
index 000000000000..be510ec104eb
--- /dev/null
+++ b/media-libs/sdl-sound/sdl-sound-0.1.4.ebuild
@@ -0,0 +1,35 @@
+# Copyriht 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: <azarah@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-sound/sdl-sound-0.1.4.ebuild,v 1.1 2002/01/01 00:39:29 azarah Exp $
+
+MY_P="${P/sdl-/SDL_}"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="A library that handles the decoding sound file formats"
+SRC_URI="http://icculus.org/SDL_sound/downloads/${MY_P}.tar.gz"
+HOMEPAGE="http://icculus.org/SDL_sound/"
+
+DEPEND="virtual/glibc
+ >=media-libs/libsdl-1.2.3
+ >=media-libs/smpeg-0.4.4-r1
+ >=media-libs/libmikmod-3.1.9
+ ogg? ( >=media-libs/libvorbis-1.0_beta4 )"
+
+
+src_compile() {
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --enable-midi \
+ --disable-flac || die
+
+ emake || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+
+ dodoc CHANGELOG COPYING CREDITS INSTALL README TODO
+}