summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-04-27 11:51:24 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-04-27 11:51:24 +0000
commit036683903779a7475802f94d96f0807c2dec5aff (patch)
tree9da6314f5675b61435fab87da754449cd0e639a6 /media-libs/smjpeg
parenttypo (diff)
downloadhistorical-036683903779a7475802f94d96f0807c2dec5aff.tar.gz
historical-036683903779a7475802f94d96f0807c2dec5aff.tar.bz2
historical-036683903779a7475802f94d96f0807c2dec5aff.zip
cleanup
Diffstat (limited to 'media-libs/smjpeg')
-rw-r--r--media-libs/smjpeg/smjpeg-0.2.1-r2.ebuild23
1 files changed, 9 insertions, 14 deletions
diff --git a/media-libs/smjpeg/smjpeg-0.2.1-r2.ebuild b/media-libs/smjpeg/smjpeg-0.2.1-r2.ebuild
index c8ad6e2983d3..bdf2b161394f 100644
--- a/media-libs/smjpeg/smjpeg-0.2.1-r2.ebuild
+++ b/media-libs/smjpeg/smjpeg-0.2.1-r2.ebuild
@@ -1,31 +1,26 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-libs/smjpeg/smjpeg-0.2.1-r2.ebuild,v 1.4 2001/08/11 03:44:19 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/smjpeg/smjpeg-0.2.1-r2.ebuild,v 1.5 2002/04/27 11:45:30 seemant Exp $
-P=smjpeg-0.2.1
-A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="SDL Motion JPEG Library"
-SRC_URI="ftp://ftp.linuxgames.com/loki/open-source/smjpeg/${A}"
+SRC_URI="ftp://ftp.linuxgames.com/loki/open-source/smjpeg/${P}.tar.gz"
HOMEPAGE="http://www.lokigames.com/development/smjpeg.php3"
DEPEND=">=media-libs/libsdl-1.1.7"
src_compile() {
- if [ "`use nas`" ] ; then
- LDFLAGS="-L/usr/X11R6/lib -lXt"
- fi
- try LDFLAGS="$LDFLAGS" ./configure --prefix=/usr --host=${CHOST}
- try make
+ use nas && LDFLAGS="-L/usr/X11R6/lib -lXt"
+
+ LDFLAGS="$LDFLAGS" ./configure --prefix=/usr --host=${CHOST}
+ make || die
}
src_install () {
- try make DESTDIR=${D} install
- dodoc CHANGES COPYING README TODO SMJPEG.txt
+ make DESTDIR=${D} install || die
+ dodoc CHANGES COPYING README TODO SMJPEG.txt
}
-
-