summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2008-04-07 21:43:24 +0000
committerBen de Groot <yngwin@gentoo.org>2008-04-07 21:43:24 +0000
commit52f80e123291113cf932030b600582f2d6b283c4 (patch)
tree5f1ed96809845649991c881cc637f8ec3b63b40b /media-libs/x264/files
parentbump to 2.4.1, bugs and regression test fixes. (diff)
downloadhistorical-52f80e123291113cf932030b600582f2d6b283c4.tar.gz
historical-52f80e123291113cf932030b600582f2d6b283c4.tar.bz2
historical-52f80e123291113cf932030b600582f2d6b283c4.zip
Pkgmove from x264-svn to x264, and adding fresh snapshot
Package-Manager: portage-2.1.5_rc2 RepoMan-Options: --force
Diffstat (limited to 'media-libs/x264/files')
-rw-r--r--media-libs/x264/files/x264-nostrip.patch16
-rw-r--r--media-libs/x264/files/x264-onlylib-20080406.patch26
-rw-r--r--media-libs/x264/files/x264-onlylib.patch28
3 files changed, 70 insertions, 0 deletions
diff --git a/media-libs/x264/files/x264-nostrip.patch b/media-libs/x264/files/x264-nostrip.patch
new file mode 100644
index 000000000000..b4e2689a18e6
--- /dev/null
+++ b/media-libs/x264/files/x264-nostrip.patch
@@ -0,0 +1,16 @@
+Index: x264-svn/configure
+===================================================================
+--- x264-svn.orig/configure
++++ x264-svn/configure
+@@ -374,11 +374,6 @@ if [ "$pic" = "yes" ] ; then
+ ASFLAGS="$ASFLAGS -D__PIC__"
+ fi
+
+-if [ "$debug" != "yes" -a "$gprof" != "yes" ]; then
+- CFLAGS="$CFLAGS -s -fomit-frame-pointer"
+- LDFLAGS="$LDFLAGS -s"
+-fi
+-
+ if [ "$debug" = "yes" ]; then
+ CFLAGS="-O1 -g $CFLAGS"
+ else
diff --git a/media-libs/x264/files/x264-onlylib-20080406.patch b/media-libs/x264/files/x264-onlylib-20080406.patch
new file mode 100644
index 000000000000..3585ee675b70
--- /dev/null
+++ b/media-libs/x264/files/x264-onlylib-20080406.patch
@@ -0,0 +1,26 @@
+--- x264.orig/Makefile 2008-04-07 21:55:13.000000000 +0200
++++ x264-snapshot-20080406-2245/Makefile 2008-04-07 21:57:25.000000000 +0200
+@@ -69,7 +69,7 @@
+
+ .PHONY: all default fprofiled clean distclean install install-gtk uninstall dox test testclean
+
+-default: $(DEP) x264$(EXE)
++default: $(DEP)
+
+ libx264.a: .depend $(OBJS) $(OBJASM)
+ ar rc libx264.a $(OBJS) $(OBJASM)
+@@ -148,13 +148,12 @@
+ rm -rf test/
+ $(MAKE) -C gtk distclean
+
+-install: x264$(EXE) $(SONAME)
++install: libx264.a $(SONAME)
+ install -d $(DESTDIR)$(bindir) $(DESTDIR)$(includedir)
+ install -d $(DESTDIR)$(libdir) $(DESTDIR)$(libdir)/pkgconfig
+ install -m 644 x264.h $(DESTDIR)$(includedir)
+ install -m 644 libx264.a $(DESTDIR)$(libdir)
+ install -m 644 x264.pc $(DESTDIR)$(libdir)/pkgconfig
+- install x264$(EXE) $(DESTDIR)$(bindir)
+ ranlib $(DESTDIR)$(libdir)/libx264.a
+ ifeq ($(SYS),MINGW)
+ $(if $(SONAME), install -m 755 $(SONAME) $(DESTDIR)$(bindir))
diff --git a/media-libs/x264/files/x264-onlylib.patch b/media-libs/x264/files/x264-onlylib.patch
new file mode 100644
index 000000000000..d429ac0952f8
--- /dev/null
+++ b/media-libs/x264/files/x264-onlylib.patch
@@ -0,0 +1,28 @@
+Index: x264-svn/Makefile
+===================================================================
+--- x264-svn.orig/Makefile
++++ x264-svn/Makefile
+@@ -66,7 +66,7 @@ DEP = depend
+ .PHONY: all default fprofiled clean distclean install install-gtk uninstall dox test testclean
+ all: default
+
+-default: $(DEP) x264$(EXE)
++default: $(DEP)
+
+ libx264.a: .depend $(OBJS) $(OBJASM)
+ ar rc libx264.a $(OBJS) $(OBJASM)
+@@ -142,13 +142,12 @@ distclean: clean
+ rm -rf test/
+ $(MAKE) -C gtk distclean
+
+-install: x264 $(SONAME)
++install: libx264.a $(SONAME)
+ install -d $(DESTDIR)$(bindir) $(DESTDIR)$(includedir)
+ install -d $(DESTDIR)$(libdir) $(DESTDIR)$(libdir)/pkgconfig
+ install -m 644 x264.h $(DESTDIR)$(includedir)
+ install -m 644 libx264.a $(DESTDIR)$(libdir)
+ install -m 644 x264.pc $(DESTDIR)$(libdir)/pkgconfig
+- install x264 $(DESTDIR)$(bindir)
+ ranlib $(DESTDIR)$(libdir)/libx264.a
+ $(if $(SONAME), ln -sf $(SONAME) $(DESTDIR)$(libdir)/libx264.so)
+ $(if $(SONAME), install -m 755 $(SONAME) $(DESTDIR)$(libdir))