summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-04-27 11:19:51 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-04-27 11:19:51 +0000
commite83b7e3baa38c80a367e4097800a0f98af8af903 (patch)
tree61be3c7bec736d5ba24d806a6a94dce6c30edb8a /media-libs
parentcleanup (diff)
downloadhistorical-e83b7e3baa38c80a367e4097800a0f98af8af903.tar.gz
historical-e83b7e3baa38c80a367e4097800a0f98af8af903.tar.bz2
historical-e83b7e3baa38c80a367e4097800a0f98af8af903.zip
cleanup
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/fnlib/fnlib-0.5-r1.ebuild31
-rw-r--r--media-libs/libcdaudio/libcdaudio-0.99.4.ebuild18
-rw-r--r--media-libs/libcdaudio/libcdaudio-0.99.6.ebuild4
3 files changed, 26 insertions, 27 deletions
diff --git a/media-libs/fnlib/fnlib-0.5-r1.ebuild b/media-libs/fnlib/fnlib-0.5-r1.ebuild
index b4bfce750981..202199e6dedb 100644
--- a/media-libs/fnlib/fnlib-0.5-r1.ebuild
+++ b/media-libs/fnlib/fnlib-0.5-r1.ebuild
@@ -1,30 +1,31 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-libs/fnlib/fnlib-0.5-r1.ebuild,v 1.1 2001/10/06 15:30:16 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/fnlib/fnlib-0.5-r1.ebuild,v 1.2 2002/04/27 11:18:13 seemant Exp $
-P=fnlib-0.5
-A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="Font Library"
-SRC_URI="ftp://ftp.enlightenment.org/pub/enlightenment/enlightenment/libs/"${A}
+SRC_URI="ftp://ftp.enlightenment.org/pub/enlightenment/enlightenment/libs/${P}.tar.gz"
DEPEND="virtual/glibc >=media-libs/imlib-1.9.8.1"
src_compile() {
- try ./configure --host=${CHOST} --prefix=/usr --sysconfdir=/etc/fnlib
- try make
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc/fnlib || die
+ make || die
}
src_install() {
-
- try make prefix=${D}/usr sysconfdir=${D}/etc/fnlib install
- dodoc AUTHORS ChangeLog COPYING* HACKING NEWS README
- dodoc doc/fontinfo.README
-
-}
-
-
+
+ make \
+ prefix=${D}/usr \
+ sysconfdir=${D}/etc/fnlib \
+ install || die
+ dodoc AUTHORS ChangeLog COPYING* HACKING NEWS README
+ dodoc doc/fontinfo.README
+}
diff --git a/media-libs/libcdaudio/libcdaudio-0.99.4.ebuild b/media-libs/libcdaudio/libcdaudio-0.99.4.ebuild
index 6ad2491c8a12..99d2b11cb267 100644
--- a/media-libs/libcdaudio/libcdaudio-0.99.4.ebuild
+++ b/media-libs/libcdaudio/libcdaudio-0.99.4.ebuild
@@ -1,23 +1,21 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Peter Gavin <pete@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libcdaudio/libcdaudio-0.99.4.ebuild,v 1.4 2001/05/09 00:02:48 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libcdaudio/libcdaudio-0.99.4.ebuild,v 1.5 2002/04/27 11:19:51 seemant Exp $
-#P=
-A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="a library of cd audio related routines"
-SRC_URI="ftp://cdcd.undergrid.net/libcdaudio/${A}"
+SRC_URI="ftp://cdcd.undergrid.net/libcdaudio/${P}.tar.gz"
HOMEPAGE="http://cdcd.undergrid.net/"
DEPEND="virtual/glibc"
src_compile() {
- export CFLAGS="`echo $CFLAGS | sed -e 's:-march=[a-z0-9]*::'`"
- try ./configure --prefix=/usr --host=${CHOST} --enable-threads
- try make
+ export CFLAGS="`echo $CFLAGS | sed -e 's:-march=[a-z0-9]*::'`"
+ ./configure --prefix=/usr --host=${CHOST} --enable-threads || die
+ make || die
}
src_install () {
- try make DESTDIR=${D} install
- dodoc AUTHORS COPYING ChangLog NEWS README README.BeOS README.OSF1 TODO
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING ChangLog NEWS README README.BeOS README.OSF1 TODO
}
diff --git a/media-libs/libcdaudio/libcdaudio-0.99.6.ebuild b/media-libs/libcdaudio/libcdaudio-0.99.6.ebuild
index fc1ead285a95..8dbe248b789d 100644
--- a/media-libs/libcdaudio/libcdaudio-0.99.6.ebuild
+++ b/media-libs/libcdaudio/libcdaudio-0.99.6.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Peter Gavin <pete@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libcdaudio/libcdaudio-0.99.6.ebuild,v 1.1 2001/10/26 02:04:18 lordjoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libcdaudio/libcdaudio-0.99.6.ebuild,v 1.2 2002/04/27 11:19:51 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="a library of cd audio related routines"