summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2004-12-19 21:05:53 +0000
committerTony Vroon <chainsaw@gentoo.org>2004-12-19 21:05:53 +0000
commit30358ed9fbe383a48c0e2d0263d342ca98346622 (patch)
tree9ae7168f29bb25b1e9c19e3e77368b64eb254a38 /media-plugins/bmp-crossfade
parentupdate maintainer (diff)
downloadhistorical-30358ed9fbe383a48c0e2d0263d342ca98346622.tar.gz
historical-30358ed9fbe383a48c0e2d0263d342ca98346622.tar.bz2
historical-30358ed9fbe383a48c0e2d0263d342ca98346622.zip
Initial commit. Ebuild based on a forum posting by VoVaN.
Diffstat (limited to 'media-plugins/bmp-crossfade')
-rw-r--r--media-plugins/bmp-crossfade/ChangeLog10
-rw-r--r--media-plugins/bmp-crossfade/Manifest5
-rw-r--r--media-plugins/bmp-crossfade/bmp-crossfade-0.3.8.ebuild39
-rw-r--r--media-plugins/bmp-crossfade/files/0.3.8-bmp.patch77
-rw-r--r--media-plugins/bmp-crossfade/files/digest-bmp-crossfade-0.3.81
-rw-r--r--media-plugins/bmp-crossfade/metadata.xml9
6 files changed, 141 insertions, 0 deletions
diff --git a/media-plugins/bmp-crossfade/ChangeLog b/media-plugins/bmp-crossfade/ChangeLog
new file mode 100644
index 000000000000..e699bcde31f3
--- /dev/null
+++ b/media-plugins/bmp-crossfade/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-plugins/bmp-crossfade
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/bmp-crossfade/ChangeLog,v 1.1 2004/12/19 21:05:53 chainsaw Exp $
+
+*bmp-crossfade-0.3.8 (19 Dec 2004)
+
+ 19 Dec 2004; Tony Vroon <chainsaw@gentoo.org> +metadata.xml,
+ +files/0.3.8-bmp.patch, +bmp-crossfade-0.3.8.ebuild:
+ Initial commit. Ebuild based on a forum posting by VoVaN.
+
diff --git a/media-plugins/bmp-crossfade/Manifest b/media-plugins/bmp-crossfade/Manifest
new file mode 100644
index 000000000000..ddbfd58d9eb2
--- /dev/null
+++ b/media-plugins/bmp-crossfade/Manifest
@@ -0,0 +1,5 @@
+MD5 e13624a7e935743f9ce055b55fb7897d bmp-crossfade-0.3.8.ebuild 920
+MD5 daff468df0ae690f4cbdf7b563b4ee31 ChangeLog 444
+MD5 319fe8f45b51a2d31f8d4e9a4071ca10 metadata.xml 248
+MD5 9bd20128f860dc9821976ce49fd6f70f files/digest-bmp-crossfade-0.3.8 72
+MD5 65b7984b615809f5dbb31cb05601fc12 files/0.3.8-bmp.patch 3434
diff --git a/media-plugins/bmp-crossfade/bmp-crossfade-0.3.8.ebuild b/media-plugins/bmp-crossfade/bmp-crossfade-0.3.8.ebuild
new file mode 100644
index 000000000000..7b59575d8c3f
--- /dev/null
+++ b/media-plugins/bmp-crossfade/bmp-crossfade-0.3.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/bmp-crossfade/bmp-crossfade-0.3.8.ebuild,v 1.1 2004/12/19 21:05:53 chainsaw Exp $
+
+IUSE=""
+inherit eutils
+
+MY_P=${P/bmp-/xmms-}
+MY_PN=${PN/bmp-/xmms-}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="BMP Plugin for crossfading, and continuous output."
+SRC_URI="http://www.eisenlohr.org/${MY_PN}/${MY_P}.tar.gz"
+HOMEPAGE="http://www.eisenlohr.org/xmms-crossfade/index.html"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND="media-sound/beep-media-player
+ media-libs/libsamplerate"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-bmp.patch
+ cp interface.c interface-2.0.c
+ cp support.c support-2.0.c
+}
+
+src_compile() {
+ econf --enable-player=beep || die
+ emake || die
+}
+
+src_install () {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog README TODO
+}
diff --git a/media-plugins/bmp-crossfade/files/0.3.8-bmp.patch b/media-plugins/bmp-crossfade/files/0.3.8-bmp.patch
new file mode 100644
index 000000000000..15ce1fa2d169
--- /dev/null
+++ b/media-plugins/bmp-crossfade/files/0.3.8-bmp.patch
@@ -0,0 +1,77 @@
+diff -Naur xmms-crossfade-0.3.8.orig/crossfade.c xmms-crossfade-0.3.8/crossfade.c
+--- xmms-crossfade-0.3.8.orig/crossfade.c 2004-09-16 09:56:13.000000000 +0200
++++ xmms-crossfade-0.3.8/crossfade.c 2004-12-10 11:20:18.000000000 +0100
+@@ -1501,7 +1501,7 @@
+
+ /* V0.3.0: New timeout detection */
+ if(!opened) {
+- gboolean current = get_input_playing(); /* XMMS */
++ gboolean current = bmp_playback_get_playing(); /* XMMS */
+
+ /* also see fini() */
+ if(last_close.tv_sec || last_close.tv_usec) {
+diff -Naur xmms-crossfade-0.3.8.orig/crossfade.h xmms-crossfade-0.3.8/crossfade.h
+--- xmms-crossfade-0.3.8.orig/crossfade.h 2004-09-16 09:21:35.000000000 +0200
++++ xmms-crossfade-0.3.8/crossfade.h 2004-12-10 11:19:45.000000000 +0100
+@@ -32,10 +32,10 @@
+ #include <gdk/gdk.h>
+ #include <gtk/gtk.h>
+
+-#include <xmms/plugin.h>
+-#include <xmms/xmmsctrl.h>
+-#include <xmms/configfile.h>
+-#include <xmms/util.h>
++#include <bmp/plugin.h>
++#include <bmp/beepctrl.h>
++#include <bmp/configfile.h>
++#include <bmp/util.h>
+
+ #include "debug.h"
+
+@@ -336,7 +336,7 @@
+
+ /* xmms internal prototypes */ /* XMMS */
+ gint ctrlsocket_get_session_id();
+-gboolean get_input_playing();
++gboolean bmp_playback_get_playing();
+ GList *get_output_list();
+ GList *get_effect_list();
+ gint get_playlist_position();
+diff -Naur xmms-crossfade-0.3.8.orig/interface.c xmms-crossfade-0.3.8/interface.c
+--- xmms-crossfade-0.3.8.orig/interface.c 2004-09-24 10:38:51.000000000 +0200
++++ xmms-crossfade-0.3.8/interface.c 2004-12-10 11:24:24.000000000 +0100
+@@ -3218,14 +3218,14 @@
+ gtk_box_pack_start (GTK_BOX (help_vbox), help_scrolledwindow, TRUE, TRUE, 0);
+ gtk_scrolled_window_set_policy (GTK_SCROLLED_WINDOW (help_scrolledwindow), GTK_POLICY_NEVER, GTK_POLICY_ALWAYS);
+
+- help_text = gtk_text_new (NULL, NULL);
+- gtk_widget_ref (help_text);
+- gtk_object_set_data_full (GTK_OBJECT (help_win), "help_text", help_text,
+- (GtkDestroyNotify) gtk_widget_unref);
+- gtk_widget_show (help_text);
+- gtk_container_add (GTK_CONTAINER (help_scrolledwindow), help_text);
+- gtk_text_insert (GTK_TEXT (help_text), NULL, NULL, NULL,
+- "<dummy>\n", -1);
++// help_text = gtk_text_new (NULL, NULL);
++// gtk_widget_ref (help_text);
++// gtk_object_set_data_full (GTK_OBJECT (help_win), "help_text", help_text,
++// (GtkDestroyNotify) gtk_widget_unref);
++// gtk_widget_show (help_text);
++// gtk_container_add (GTK_CONTAINER (help_scrolledwindow), help_text);
++// gtk_text_insert (GTK_TEXT (help_text), NULL, NULL, NULL,
++// "<dummy>\n", -1);
+
+ help_buttonbox = gtk_hbutton_box_new ();
+ gtk_widget_ref (help_buttonbox);
+diff -Naur xmms-crossfade-0.3.8.orig/monitor.c xmms-crossfade-0.3.8/monitor.c
+--- xmms-crossfade-0.3.8.orig/monitor.c 2004-08-05 15:23:46.000000000 +0200
++++ xmms-crossfade-0.3.8/monitor.c 2004-12-10 11:20:06.000000000 +0100
+@@ -234,7 +234,7 @@
+
+ /*** Position ***/
+ if(1 || (monitor_position_label && monitor_total_label && monitor_left_label)) {
+- if(!get_input_playing() || (monitor_closing == CLOSED)) { /* XMMS */
++ if(!bmp_playback_get_playing() || (monitor_closing == CLOSED)) { /* XMMS */
+ gtk_label_set_text(monitor_position_label, default_position_str);
+ gtk_label_set_text(monitor_total_label, default_total_str);
+ gtk_label_set_text(monitor_left_label, default_left_str);
diff --git a/media-plugins/bmp-crossfade/files/digest-bmp-crossfade-0.3.8 b/media-plugins/bmp-crossfade/files/digest-bmp-crossfade-0.3.8
new file mode 100644
index 000000000000..7f31fcf4d8d9
--- /dev/null
+++ b/media-plugins/bmp-crossfade/files/digest-bmp-crossfade-0.3.8
@@ -0,0 +1 @@
+MD5 fbfff1bff29118309b0a02c713b13d50 xmms-crossfade-0.3.8.tar.gz 435761
diff --git a/media-plugins/bmp-crossfade/metadata.xml b/media-plugins/bmp-crossfade/metadata.xml
new file mode 100644
index 000000000000..a025c77c7636
--- /dev/null
+++ b/media-plugins/bmp-crossfade/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+<maintainer>
+ <email>chainsaw@gentoo.org</email>
+ <name>Tony Vroon</name>
+</maintainer>
+</pkgmetadata>