summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2005-03-26 08:33:45 +0000
committerDoug Goldstein <cardoe@gentoo.org>2005-03-26 08:33:45 +0000
commit61ce7320a4f07254b06b64a61db9c545b3f73714 (patch)
treed89db0acea272523764d902a7edcedb8d62d9c31 /media-plugins/mythgallery
parentremove install of depreciated mysql.txt. added msgs for ieee1394 and nvidia U... (diff)
downloadhistorical-61ce7320a4f07254b06b64a61db9c545b3f73714.tar.gz
historical-61ce7320a4f07254b06b64a61db9c545b3f73714.tar.bz2
historical-61ce7320a4f07254b06b64a61db9c545b3f73714.zip
add exif support
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'media-plugins/mythgallery')
-rw-r--r--media-plugins/mythgallery/ChangeLog8
-rw-r--r--media-plugins/mythgallery/Manifest13
-rw-r--r--media-plugins/mythgallery/files/digest-mythgallery-0.17-r11
-rw-r--r--media-plugins/mythgallery/mythgallery-0.17-r1.ebuild32
4 files changed, 47 insertions, 7 deletions
diff --git a/media-plugins/mythgallery/ChangeLog b/media-plugins/mythgallery/ChangeLog
index ca61d07ce556..0edd72867aa4 100644
--- a/media-plugins/mythgallery/ChangeLog
+++ b/media-plugins/mythgallery/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-plugins/mythgallery
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythgallery/ChangeLog,v 1.24 2005/02/11 15:59:16 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythgallery/ChangeLog,v 1.25 2005/03/26 08:33:45 cardoe Exp $
+
+*mythgallery-0.17-r1 (26 Mar 2005)
+
+ 26 Mar 2005; Doug Goldstein <cardoe@gentoo.org>
+ +mythgallery-0.17-r1.ebuild:
+ add exif support
*mythgallery-0.17 (11 Feb 2005)
diff --git a/media-plugins/mythgallery/Manifest b/media-plugins/mythgallery/Manifest
index c164cb7824b6..1c1086c40839 100644
--- a/media-plugins/mythgallery/Manifest
+++ b/media-plugins/mythgallery/Manifest
@@ -4,13 +4,14 @@ Hash: SHA1
MD5 e640b94d35c2228661c6efd1e11da45c mythgallery-0.16.ebuild 686
MD5 f62db0df6ee8ee1d4fe7b9c3d74432a7 metadata.xml 222
MD5 49bfb34ad13888a45db6cfeb7da76514 mythgallery-0.17.ebuild 726
-MD5 9fac0e2f9311aa8943942a14c89faf36 ChangeLog 3875
+MD5 1c703a038ed7fd789b72ad4fe110b955 ChangeLog 4012
+MD5 281d726968403103e83db3b722610071 mythgallery-0.17-r1.ebuild 780
+MD5 95241fda0f7454c8bd6d0f664471ec6b files/digest-mythgallery-0.17-r1 68
MD5 0ca4e7d13c8988f8e2c456d1b4e9c414 files/digest-mythgallery-0.16 68
-MD5 95241fda0f7454c8bd6d0f664471ec6b files/digest-mythgallery-0.17 68
-----BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.0 (GNU/Linux)
+Version: GnuPG v1.4.1 (GNU/Linux)
-iD8DBQFCDNZd5+pdB4IBr0URArGSAJ956gYc5duora+ZL28ZXLeoaWE7SACeNjjP
-4GV3NawZNczPzy1Yyfgry3M=
-=uSdc
+iD8DBQFCRR6j5+pdB4IBr0URArZLAJ9sOtjf0WEepSeZhbYTh2wOjDonrwCgm3Uf
+MSsbFB+JGGDUEjHZ/xBPUvY=
+=N6Wg
-----END PGP SIGNATURE-----
diff --git a/media-plugins/mythgallery/files/digest-mythgallery-0.17-r1 b/media-plugins/mythgallery/files/digest-mythgallery-0.17-r1
new file mode 100644
index 000000000000..d3be96d4dc9d
--- /dev/null
+++ b/media-plugins/mythgallery/files/digest-mythgallery-0.17-r1
@@ -0,0 +1 @@
+MD5 349d6e81d1b53a3650a1a8c30a7f9e11 mythgallery-0.17.tar.bz2 73707
diff --git a/media-plugins/mythgallery/mythgallery-0.17-r1.ebuild b/media-plugins/mythgallery/mythgallery-0.17-r1.ebuild
new file mode 100644
index 000000000000..dc1a42141ad4
--- /dev/null
+++ b/media-plugins/mythgallery/mythgallery-0.17-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythgallery/mythgallery-0.17-r1.ebuild,v 1.1 2005/03/26 08:33:45 cardoe Exp $
+
+inherit myth
+
+DESCRIPTION="Gallery and slideshow module for MythTV."
+HOMEPAGE="http://www.mythtv.org/"
+SRC_URI="http://www.mythtv.org/mc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="opengl exif"
+
+DEPEND=">=sys-apps/sed-4
+ opengl? ( virtual/opengl )
+ exif? ( media-libs/libexif )
+ media-libs/tiff
+ || ( ~media-tv/mythtv-${PV} ~media-tv/mythfrontend-${PV} )"
+
+setup_pro() {
+ return 0
+}
+
+src_compile() {
+ econf \
+ `use_enable exif` \
+ `use_enable opengl` || die "econf failed"
+
+ myth_src_compile || die "compile failed"
+}