summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Mylchreest <johnm@gentoo.org>2003-07-08 23:44:30 +0000
committerJohn Mylchreest <johnm@gentoo.org>2003-07-08 23:44:30 +0000
commita22a242441f1377698101fa727dbcd8dde350187 (patch)
tree08fd0d71710dd261e034cc11e0870dae933adcfb /media-plugins/mythgame
parentinitial check-in (diff)
downloadhistorical-a22a242441f1377698101fa727dbcd8dde350187.tar.gz
historical-a22a242441f1377698101fa727dbcd8dde350187.tar.bz2
historical-a22a242441f1377698101fa727dbcd8dde350187.zip
initial check-in
Diffstat (limited to 'media-plugins/mythgame')
-rw-r--r--media-plugins/mythgame/ChangeLog31
-rw-r--r--media-plugins/mythgame/Manifest2
-rw-r--r--media-plugins/mythgame/mythgame-0.10.ebuild76
3 files changed, 109 insertions, 0 deletions
diff --git a/media-plugins/mythgame/ChangeLog b/media-plugins/mythgame/ChangeLog
new file mode 100644
index 000000000000..50e80d34487e
--- /dev/null
+++ b/media-plugins/mythgame/ChangeLog
@@ -0,0 +1,31 @@
+# ChangeLog for media-plugins/mythgame
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythgame/ChangeLog,v 1.1 2003/07/08 23:44:01 johnm Exp $
+
+ 03 Jul 2003; Max Kalika <max@lsit.ucsb.edu> mythgame-0.8.ebuild:
+ Set KEYWORDS to ~x86.
+
+*mythgame-0.10 (01 Jul 2003)
+
+ 01 Jul 2003; Max Kalika <max@lsit.ucsb.edu> mythgame-0.10.ebuild:
+ Bump version to 0.10. Drop installation of mythgame-settings.txt as it is no
+ longer needed. Add similar note as mythtv regarding the importance of keeping
+ database up to date between upgrades.
+
+ 22 Jun 2003; Max Kalika <max@lsit.ucsb.edu> mythgame-0.9.ebuild:
+ Cleanup and consistancy: depend on sed-4, die if sed fails. Drop unused
+ myconf setting.
+
+ 18 Jun 2003; Max Kalika <max@lsit.ucsb.edu> mythgame-0.9.ebuild:
+ Change depend to media-tv/mythtv.
+
+*mythgame-0.9 (09 Jun 2003)
+
+ 09 Jun 2003; Max Kalika <max@lsit.ucsb.edu> mythgame-0.9.ebuild:
+ Bump to 0.9. Make all sed operations inline. Move config file into
+ /etc/mythtv for consistancy and CONFIG_PROTECT support.
+
+*mythgame-0.8 (26 Mar 2003)
+
+ 26 Mar 2003; Matt Taylor <liverbugg@juno.com> mythgame-0.8.ebuild:
+ Initial import.
diff --git a/media-plugins/mythgame/Manifest b/media-plugins/mythgame/Manifest
new file mode 100644
index 000000000000..ea170f219cb4
--- /dev/null
+++ b/media-plugins/mythgame/Manifest
@@ -0,0 +1,2 @@
+MD5 0b46530a7ad78bfc051975f3cb926cef mythgame-0.10.ebuild 1993
+MD5 15d026e4f7eb58af5f443d266581c1c0 ChangeLog 1221
diff --git a/media-plugins/mythgame/mythgame-0.10.ebuild b/media-plugins/mythgame/mythgame-0.10.ebuild
new file mode 100644
index 000000000000..9b278931f1ea
--- /dev/null
+++ b/media-plugins/mythgame/mythgame-0.10.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythgame/mythgame-0.10.ebuild,v 1.1 2003/07/08 23:44:01 johnm Exp $
+
+inherit flag-o-matic
+
+IUSE=""
+DESCRIPTION="Game emulator module for MythTV."
+HOMEPAGE="http://www.mythtv.org/"
+SRC_URI="http://www.mythtv.org/mc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=media-tv/mythtv-${PV}
+ sys-libs/zlib
+ >=sys-apps/sed-4"
+
+src_unpack() {
+
+ unpack ${A}
+
+ for i in `grep -lr "usr/local" "${S}"` ; do
+ sed -e "s:/usr/local:/usr:" -i "${i}" || die "sed failed"
+ done
+
+}
+
+src_compile() {
+
+ cpu="`get-flag march`"
+ if [ ! -z "${cpu}" ] ; then
+ sed -e "s:pentiumpro:${cpu}:g" -i "${S}/settings.pro" || die "sed failed"
+ fi
+
+ qmake -o "${S}/Makefile" "${S}/${PN}.pro"
+
+ emake || die "compile problem"
+
+}
+
+src_install () {
+
+ make INSTALL_ROOT="${D}" install || die "make install failed"
+
+ insinto "/usr/share/mythtv/database/${PN}"
+ doins gamedb/*.sql
+
+ dodoc README UPGRADING gamelist.xml
+
+}
+
+pkg_postinst() {
+
+ einfo "If this is the first time you install MythGame,"
+ einfo "you need to add /usr/share/mythtv/database/${PN}/metadata.sql"
+ einfo "/usr/share/mythtv/database/${PN}/nesdb.sql and "
+ einfo "/usr/share/mythtv/database/${PN}/snesdata.sql"
+ einfo "to your MythTV database in that order."
+ einfo
+ einfo "You might run in this order:"
+ einfo "'mysql < /usr/share/mythtv/database/${PN}/gamemetadata.sql'"
+ einfo "'mysql < /usr/share/mythtv/database/${PN}/nesdb.sql'"
+ einfo "'mysql < /usr/share/mythtv/database/${PN}/snesdata.sql'"
+ einfo
+ einfo "If you're upgrading from an older version and for more"
+ einfo "setup and usage instructions, please refer to:"
+ einfo " /usr/share/doc/${PF}/README.gz"
+ einfo " /usr/share/doc/${PF}/UPGRADING.gz"
+ ewarn "This part is important as there might be database changes"
+ ewarn "which need to be performed or this package will not work"
+ ewarn "properly."
+ echo
+
+}