summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-08-30 08:35:31 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-08-30 08:35:31 +0000
commit42c1afbe1245597cb0a1fe7baf68680c3a2cafd3 (patch)
tree9ef0818565fe45599454dda5cad22f3e4040c6b4 /media-plugins/xmms-shell/xmms-shell-0.99.0-r1.ebuild
parentmoved x11-misc/ikons to x11-themes/ikons (diff)
downloadhistorical-42c1afbe1245597cb0a1fe7baf68680c3a2cafd3.tar.gz
historical-42c1afbe1245597cb0a1fe7baf68680c3a2cafd3.tar.bz2
historical-42c1afbe1245597cb0a1fe7baf68680c3a2cafd3.zip
moved xmms plugins from media-sound to media-plugins
Diffstat (limited to 'media-plugins/xmms-shell/xmms-shell-0.99.0-r1.ebuild')
-rw-r--r--media-plugins/xmms-shell/xmms-shell-0.99.0-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-plugins/xmms-shell/xmms-shell-0.99.0-r1.ebuild b/media-plugins/xmms-shell/xmms-shell-0.99.0-r1.ebuild
new file mode 100644
index 000000000000..9e13df686999
--- /dev/null
+++ b/media-plugins/xmms-shell/xmms-shell-0.99.0-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-shell/xmms-shell-0.99.0-r1.ebuild,v 1.1 2002/08/30 08:35:31 seemant Exp $
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="XMMS-Shell is a simple utility to control XMMS externally."
+SRC_URI="http://download.sourceforge.net/xmms-shell/${P}.tar.gz"
+HOMEPAGE="http://www.loganh.com/xmms-shell/"
+DEPEND=">=media-sound/xmms-1.2.7
+ readline? ( >=sys-libs/readline-4.1 )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+src_unpack() {
+ unpack ${A}
+ # shall be sent upstream
+ patch -p0 <${FILESDIR}/${PN}-gcc3.patch
+}
+
+src_compile() {
+ local myconf
+
+ use readline \
+ && myconf="${myconf} --with-readline" \
+ || myconf="${myconf} --without-readline"
+
+ econf ${myconf} || die "./configure failed"
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS README
+}