summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-11-12 10:41:43 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-11-12 10:41:43 +0000
commit61f0238ac0359bafaad2336cdd85fa345b9daf41 (patch)
tree696f2a539b8e23176eb277bf3ea94394b197f21d /media-sound/alsa-driver
parent-l (diff)
downloadhistorical-61f0238ac0359bafaad2336cdd85fa345b9daf41.tar.gz
historical-61f0238ac0359bafaad2336cdd85fa345b9daf41.tar.bz2
historical-61f0238ac0359bafaad2336cdd85fa345b9daf41.zip
Version bump.
Diffstat (limited to 'media-sound/alsa-driver')
-rw-r--r--media-sound/alsa-driver/ChangeLog8
-rw-r--r--media-sound/alsa-driver/alsa-driver-1.0.6a.ebuild44
-rw-r--r--media-sound/alsa-driver/alsa-driver-1.0.7.ebuild123
-rw-r--r--media-sound/alsa-driver/files/digest-alsa-driver-1.0.71
4 files changed, 152 insertions, 24 deletions
diff --git a/media-sound/alsa-driver/ChangeLog b/media-sound/alsa-driver/ChangeLog
index c74c3cb0b1ae..d11716351789 100644
--- a/media-sound/alsa-driver/ChangeLog
+++ b/media-sound/alsa-driver/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/alsa-driver
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.98 2004/11/04 01:47:06 geoman Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.99 2004/11/12 10:41:43 eradicator Exp $
+
+*alsa-driver-1.0.7 (12 Nov 2004)
+
+ 12 Nov 2004; Jeremy Huddleston <eradicator@gentoo.org>
+ alsa-driver-1.0.6a.ebuild, +alsa-driver-1.0.7.ebuild:
+ Version bump.
03 Nov 2004; Stephen P. Becker <geoman@gentoo.org>
alsa-driver-1.0.6a.ebuild:
diff --git a/media-sound/alsa-driver/alsa-driver-1.0.6a.ebuild b/media-sound/alsa-driver/alsa-driver-1.0.6a.ebuild
index 0c158c8eff18..67cdfd2c20c6 100644
--- a/media-sound/alsa-driver/alsa-driver-1.0.6a.ebuild
+++ b/media-sound/alsa-driver/alsa-driver-1.0.6a.ebuild
@@ -1,23 +1,21 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-1.0.6a.ebuild,v 1.4 2004/11/04 01:47:06 geoman Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-1.0.6a.ebuild,v 1.5 2004/11/12 10:41:43 eradicator Exp $
+
+IUSE="oss"
inherit kernel-mod flag-o-matic eutils
+MY_P=${P/_rc/rc}
+S=${WORKDIR}/${MY_P}
+
DESCRIPTION="Advanced Linux Sound Architecture kernel modules"
HOMEPAGE="http://www.alsa-project.org/"
-LICENSE="GPL-2 LGPL-2.1"
-
-# By default, drivers for all supported cards will be compiled.
-# If you want to only compile for specific card(s), set ALSA_CARDS
-# environment to a space-separated list of drivers that you want to build.
-# For example:
-#
-# env ALSA_CARDS='emu10k1 intel8x0 ens1370' emerge alsa-driver
-#
-[ -z "${ALSA_CARDS}" ] && ALSA_CARDS=all
+SRC_URI="mirror://alsaproject/driver/${P}.tar.bz2"
-IUSE="oss"
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="${KV}"
+KEYWORDS="~alpha amd64 ~ia64 ~mips ~ppc -sparc x86"
RDEPEND="virtual/modutils
~media-sound/alsa-headers-${PV}"
@@ -29,13 +27,14 @@ DEPEND="${RDEPEND}
PROVIDE="virtual/alsa"
-SLOT="${KV}"
-KEYWORDS="x86 ~ppc -sparc amd64 ~alpha ~ia64 ~mips"
-
-MY_P=${P/_rc/rc}
-SRC_URI="mirror://alsaproject/driver/${P}.tar.bz2"
-# nouserpriv is neccessary for 2.6.x kernels... Hopefully the ALSA guys will figure out another way to do this...
-S=${WORKDIR}/${MY_P}
+# By default, drivers for all supported cards will be compiled.
+# If you want to only compile for specific card(s), set ALSA_CARDS
+# environment to a space-separated list of drivers that you want to build.
+# For example:
+#
+# env ALSA_CARDS='emu10k1 intel8x0 ens1370' emerge alsa-driver
+#
+[ -z "${ALSA_CARDS}" ] && ALSA_CARDS=all
src_unpack() {
unpack ${A}
@@ -43,10 +42,6 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/${PN}-1.0.5-devfix.patch
epatch ${FILESDIR}/${PN}-1.0.5a-cs46xx-passthrough.patch
- epatch ${FILESDIR}/${PN}-1.0.6a-emu10k1-passthrough.patch
-
- # SUBDIRS -> M
- epatch ${FILESDIR}/${P}-kbuild.patch
if [ "${PROFILE_ARCH}" == "xbox" ]; then
epatch ${FILESDIR}/${PN}-1.0.5a-xbox-ac97.patch
@@ -66,6 +61,9 @@ src_unpack() {
# Copy everything over to our tmp dir...
cp -a ${FULL_KERNEL_PATH} ${T}/linux
+ else
+ # SUBDIRS -> M
+ epatch ${FILESDIR}/${PN}-1.0.6a-kbuild.patch
fi
}
diff --git a/media-sound/alsa-driver/alsa-driver-1.0.7.ebuild b/media-sound/alsa-driver/alsa-driver-1.0.7.ebuild
new file mode 100644
index 000000000000..500b4729c15e
--- /dev/null
+++ b/media-sound/alsa-driver/alsa-driver-1.0.7.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-1.0.7.ebuild,v 1.1 2004/11/12 10:41:43 eradicator Exp $
+
+IUSE="oss"
+
+inherit kernel-mod flag-o-matic eutils
+
+MY_P=${P/_rc/rc}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Advanced Linux Sound Architecture kernel modules"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/driver/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="${KV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc -sparc ~x86"
+
+RDEPEND="virtual/modutils
+ ~media-sound/alsa-headers-${PV}"
+
+DEPEND="${RDEPEND}
+ virtual/linux-sources
+ sys-devel/autoconf
+ sys-apps/debianutils"
+
+PROVIDE="virtual/alsa"
+
+# By default, drivers for all supported cards will be compiled.
+# If you want to only compile for specific card(s), set ALSA_CARDS
+# environment to a space-separated list of drivers that you want to build.
+# For example:
+#
+# env ALSA_CARDS='emu10k1 intel8x0 ens1370' emerge alsa-driver
+#
+[ -z "${ALSA_CARDS}" ] && ALSA_CARDS=all
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-1.0.5-devfix.patch
+ epatch ${FILESDIR}/${PN}-1.0.5a-cs46xx-passthrough.patch
+
+ if [ "${PROFILE_ARCH}" == "xbox" ]; then
+ epatch ${FILESDIR}/${PN}-1.0.5a-xbox-ac97.patch
+ fi
+
+ if kernel-mod_is_2_5_kernel || (kernel-mod_is_2_6_kernel && [ ${KV_PATCH} -lt 6 ]); then
+ FULL_KERNEL_PATH="${ROOT}/usr/src/${KV_DIR}"
+
+ if ! [ -d "${FULL_KERNEL_PATH}" ]; then
+ eerror "An error seems to have occurred. We looked in ${FULL_KERNEL_PATH} for your kernel sources, but we didn't see them."
+ die "ALSA driver configuration failure."
+ fi
+
+ einfo "A 2.5 or 2.6 kernel was detected. We are copying the kernel source tree from"
+ einfo "${FULL_KERNEL_PATH} to ${T}/linux"
+ einfo "because the alsa-driver build process overwrites files in the 2.6.x kernel tree."
+
+ # Copy everything over to our tmp dir...
+ cp -a ${FULL_KERNEL_PATH} ${T}/linux
+ else
+ # SUBDIRS -> M
+ epatch ${FILESDIR}/${PN}-1.0.6a-kbuild.patch
+ fi
+}
+
+src_compile() {
+ # Default ARCH & kernel path to set in compilation and make
+ KER_DIR=${KERNEL_DIR}
+
+ # If we're using a 2.5 or 2.6 kernel, use our copied kernel tree.
+ if [ -d "${T}/linux" ]; then
+ KER_DIR="${T}/linux"
+ fi
+
+ econf `use_with oss` \
+ --with-kernel="${KER_DIR}" \
+ --with-isapnp=yes \
+ --with-sequencer=yes \
+ --with-cards="${ALSA_CARDS}" || die "econf failed"
+
+ # Should fix bug #46901
+ is-flag "-malign-double" && filter-flags "-fomit-frame-pointer"
+
+ unset ARCH
+ emake || die "Parallel Make Failed"
+}
+
+
+src_install() {
+ dodir /usr/include/sound
+ make DESTDIR=${D} install || die
+
+ # Provided by alsa-headers now
+ rm -rf ${D}/usr/include/sound
+
+ # We have our own scripts in alsa-utils
+ test -e ${D}/etc/init.d/alsasound && rm ${D}/etc/init.d/alsasound
+ test -e ${D}/etc/rc.d/init.d/alsasound && rm ${D}/etc/rc.d/init.d/alsasound
+
+ rm doc/Makefile
+ dodoc CARDS-STATUS COPYING FAQ INSTALL README WARNING TODO doc/*
+}
+
+pkg_postinst() {
+ if [ "${ROOT}" = / ]
+ then
+ [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
+ fi
+
+ einfo
+ einfo "The alsasound initscript and modules.d/alsa have now moved to alsa-utils"
+ einfo
+ einfo "Also, remember that all mixer channels will be MUTED by default."
+ einfo "Use the 'alsamixer' program to unmute them."
+ einfo
+ einfo "Version 1.0.3 and above should work with version 2.6 kernels."
+ einfo "If you experience problems, please report bugs to http://bugs.gentoo.org."
+ einfo
+}
diff --git a/media-sound/alsa-driver/files/digest-alsa-driver-1.0.7 b/media-sound/alsa-driver/files/digest-alsa-driver-1.0.7
new file mode 100644
index 000000000000..daf5cb7de471
--- /dev/null
+++ b/media-sound/alsa-driver/files/digest-alsa-driver-1.0.7
@@ -0,0 +1 @@
+MD5 30be8b50ab699f917fb20537bc6509ad alsa-driver-1.0.7.tar.bz2 1829053