summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-03-18 16:21:51 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-03-18 16:21:51 +0000
commitda2d791c2962e1d85b3e6993794640c395ef9f46 (patch)
tree2b86d141ef52799f4f3087cc861bd762bc25176b /media-sound/fmdrv/fmdrv-1.0.7.ebuild
parentInherit from eutils (diff)
downloadhistorical-da2d791c2962e1d85b3e6993794640c395ef9f46.tar.gz
historical-da2d791c2962e1d85b3e6993794640c395ef9f46.tar.bz2
historical-da2d791c2962e1d85b3e6993794640c395ef9f46.zip
Console MIDI Player with support for OPL2 hardware. Ebuild submitted by Joel Yliluoma <bisqwit@iki.fi> in bug #28458.
Diffstat (limited to 'media-sound/fmdrv/fmdrv-1.0.7.ebuild')
-rw-r--r--media-sound/fmdrv/fmdrv-1.0.7.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-sound/fmdrv/fmdrv-1.0.7.ebuild b/media-sound/fmdrv/fmdrv-1.0.7.ebuild
new file mode 100644
index 000000000000..32ba01adffeb
--- /dev/null
+++ b/media-sound/fmdrv/fmdrv-1.0.7.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/fmdrv/fmdrv-1.0.7.ebuild,v 1.1 2004/03/18 16:21:50 eradicator Exp $
+
+DESCRIPTION="Console mode MIDI player with builtin userland OPL2 driver"
+HOMEPAGE="http://bisqwit.iki.fi/source/fmdrv.html"
+SRC_URI="http://bisqwit.iki.fi/src/arch/${P}.tar.bz2"
+
+KEYWORDS="~x86"
+SLOT="0"
+
+# See file
+LICENSE="as-is"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i \
+ -e "s:BINDIR=/usr/local/bin:BINDIR=${D}usr/bin:" \
+ Makefile
+
+ echo "" > .depend
+}
+
+
+src_compile() {
+ emake fmdrv || die
+}
+
+src_install() {
+ dobin fmdrv
+ dodoc TINYFREELICENSE README README.html
+}
+
+pkg_postinst() {
+ einfo "If you want to use AdLib (FM OPL2), you need to setuid /usr/bin/fmdv."
+ einfo "chmod 4711 /usr/bin/fmdrv"
+}