summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-07-19 22:25:13 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-07-19 22:25:13 +0000
commitb0d5344f7b55343d287ba1bf9ab0f7fd8c86d497 (patch)
tree5364fb2fb3bf590b866f78d1143eb038c57da66a /media-sound/noteedit
parent~amd64 ~sparc (diff)
downloadhistorical-b0d5344f7b55343d287ba1bf9ab0f7fd8c86d497.tar.gz
historical-b0d5344f7b55343d287ba1bf9ab0f7fd8c86d497.tar.bz2
historical-b0d5344f7b55343d287ba1bf9ab0f7fd8c86d497.zip
Gcc-3.4 fixes. Added to ~amd64.
Diffstat (limited to 'media-sound/noteedit')
-rw-r--r--media-sound/noteedit/ChangeLog6
-rw-r--r--media-sound/noteedit/files/noteedit-2.6.2-gcc34.patch49
-rw-r--r--media-sound/noteedit/noteedit-2.6.2.ebuild20
3 files changed, 70 insertions, 5 deletions
diff --git a/media-sound/noteedit/ChangeLog b/media-sound/noteedit/ChangeLog
index 5d95a58d7eff..558f83a473b3 100644
--- a/media-sound/noteedit/ChangeLog
+++ b/media-sound/noteedit/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/noteedit
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/noteedit/ChangeLog,v 1.9 2004/07/13 06:12:09 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/noteedit/ChangeLog,v 1.10 2004/07/19 22:25:13 eradicator Exp $
+
+ 19 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org>
+ +files/noteedit-2.6.2-gcc34.patch:
+ Gcc-3.4 fixes. Added to ~amd64.
12 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org>
noteedit-2.6.2.ebuild:
diff --git a/media-sound/noteedit/files/noteedit-2.6.2-gcc34.patch b/media-sound/noteedit/files/noteedit-2.6.2-gcc34.patch
new file mode 100644
index 000000000000..a4eb02d850c9
--- /dev/null
+++ b/media-sound/noteedit/files/noteedit-2.6.2-gcc34.patch
@@ -0,0 +1,49 @@
+diff -Naur noteedit-2.6.2.orig/noteedit/mainframewidget.cpp noteedit-2.6.2/noteedit/mainframewidget.cpp
+--- noteedit-2.6.2.orig/noteedit/mainframewidget.cpp 2004-06-18 07:27:32.000000000 -0700
++++ noteedit-2.6.2/noteedit/mainframewidget.cpp 2004-07-19 14:02:18.000000000 -0700
+@@ -3683,9 +3683,9 @@
+ void NMainFrameWidget::exportMusiXTeX() { this->exportManager( MUSIX_PAGE ); }
+ void NMainFrameWidget::exportPMX() { this->exportManager( PMX_PAGE ); }
+ void NMainFrameWidget::exportABC() { this->exportManager( ABC_PAGE ); }
+-void NMainFrameWidget::exportLilyPond() { this->exportManager( LILY_PAGE ); };
+-void NMainFrameWidget::setOutputParam() { this->exportManager( PARAM_PAGE ); };
+-void NMainFrameWidget::exportMusicXML() { this->exportManager( MUSICXML_PAGE ); };
++void NMainFrameWidget::exportLilyPond() { this->exportManager( LILY_PAGE ); }
++void NMainFrameWidget::setOutputParam() { this->exportManager( PARAM_PAGE ); }
++void NMainFrameWidget::exportMusicXML() { this->exportManager( MUSICXML_PAGE ); }
+
+ void NMainFrameWidget::importMidi() {
+ KMessageBox::sorry(this, i18n("MIDI import is performed by the TSE3 library!\nSee MIDI import section in documentation or read\n\
+diff -Naur noteedit-2.6.2.orig/noteedit/noteedit_part.cpp noteedit-2.6.2/noteedit/noteedit_part.cpp
+--- noteedit-2.6.2.orig/noteedit/noteedit_part.cpp 2003-09-21 03:49:47.000000000 -0700
++++ noteedit-2.6.2/noteedit/noteedit_part.cpp 2004-07-19 14:02:36.000000000 -0700
+@@ -20,7 +20,7 @@
+ void *init_libnoteedit() {
+ return new NoteeditFactory;
+ }
+-};
++}
+
+ /**
+ * We need one static instance of the factory for our C 'main'
+diff -Naur noteedit-2.6.2.orig/noteedit/voicedialog.cpp noteedit-2.6.2/noteedit/voicedialog.cpp
+--- noteedit-2.6.2.orig/noteedit/voicedialog.cpp 2004-03-10 08:10:05.000000000 -0800
++++ noteedit-2.6.2/noteedit/voicedialog.cpp 2004-07-19 14:08:17.000000000 -0700
+@@ -90,7 +90,7 @@
+
+ renumber(VoiceNumber);
+
+-};
++}
+
+ VoiceBox::~VoiceBox() {
+ delete stemDirection_;
+@@ -155,7 +155,7 @@
+
+ void VoiceBox::destroy() {
+ if (voiceDialog_->destroyVoice(this, theVoice_)) this->close(true);
+-};
++}
+
+
+ VoiceDialog::VoiceDialog
diff --git a/media-sound/noteedit/noteedit-2.6.2.ebuild b/media-sound/noteedit/noteedit-2.6.2.ebuild
index 2349055acb1e..f244677056d3 100644
--- a/media-sound/noteedit/noteedit-2.6.2.ebuild
+++ b/media-sound/noteedit/noteedit-2.6.2.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/noteedit/noteedit-2.6.2.ebuild,v 1.3 2004/07/13 06:12:09 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/noteedit/noteedit-2.6.2.ebuild,v 1.4 2004/07/19 22:25:13 eradicator Exp $
-inherit kde-functions kde
+IUSE="arts"
+
+inherit kde-functions kde eutils
DESCRIPTION="Musical score editor (for Linux)."
HOMEPAGE="http://rnvs.informatik.tu-chemnitz.de/~jan/noteedit/"
@@ -10,14 +12,24 @@ SRC_URI="http://rnvs.informatik.tu-chemnitz.de/cgi-bin/nph-sendbin.cgi/~jan/${PN
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~sparc"
-IUSE="arts"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64"
DEPEND="arts? ( kde-base/kdemultimedia )
media-libs/tse3"
need-kde 3
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gcc34.patch
+}
+
+src_compile() {
+ kde_src_compile myconf configure || die
+ append-flags -fpermissive
+ emake -j1 || die
+}
src_install() {
kde_src_install