summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2005-02-28 23:20:20 +0000
committerCarsten Lohrke <carlo@gentoo.org>2005-02-28 23:20:20 +0000
commit9cb8cedc8ccf945638f64df344520394c3be2aa7 (patch)
treeb2407cb117b3473828a2e18f45d7ee10a7659a77 /media-sound
parentarm lovin (diff)
downloadhistorical-9cb8cedc8ccf945638f64df344520394c3be2aa7.tar.gz
historical-9cb8cedc8ccf945638f64df344520394c3be2aa7.tar.bz2
historical-9cb8cedc8ccf945638f64df344520394c3be2aa7.zip
version bump
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/amarok/ChangeLog7
-rw-r--r--media-sound/amarok/Manifest12
-rw-r--r--media-sound/amarok/amarok-1.2.1.ebuild55
-rw-r--r--media-sound/amarok/files/digest-amarok-1.2.11
4 files changed, 69 insertions, 6 deletions
diff --git a/media-sound/amarok/ChangeLog b/media-sound/amarok/ChangeLog
index ece44527700e..0cdc2814c27a 100644
--- a/media-sound/amarok/ChangeLog
+++ b/media-sound/amarok/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/amarok
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.47 2005/02/13 22:20:58 greg_g Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.48 2005/02/28 23:20:20 carlo Exp $
+
+*amarok-1.2.1 (01 Mar 2005)
+
+ 01 Mar 2005; Carsten Lohrke <carlo@gentoo.org> +amarok-1.2.1.ebuild:
+ version bump
*amarok-1.2 (13 Feb 2005)
diff --git a/media-sound/amarok/Manifest b/media-sound/amarok/Manifest
index 7ffc81b8d8a6..b3802369a393 100644
--- a/media-sound/amarok/Manifest
+++ b/media-sound/amarok/Manifest
@@ -1,9 +1,11 @@
-MD5 15a028c1f8fff178682119240f0189be metadata.xml 181
+MD5 8ab1d316a1506fe1ecff05ba7f6cf8cb amarok-1.1.1.ebuild 1578
MD5 018c1cd00abeacfdc4f2d648b78efd21 amarok-1.2.ebuild 1681
+MD5 92265aae60960f205fe531225936eb99 amarok-1.2.1.ebuild 1682
MD5 8dec94b33db41952f96628c1948fa301 amarok-1.0.2.ebuild 1199
-MD5 f560e3b4c981c561a7b4a4ebd59f1c41 ChangeLog 7014
-MD5 8ab1d316a1506fe1ecff05ba7f6cf8cb amarok-1.1.1.ebuild 1578
-MD5 33697f318e63c60a1ec8082330eece7f files/digest-amarok-1.1.1 66
-MD5 167a3a9a42477903579be25096b8eaab files/digest-amarok-1.0.2 66
+MD5 537f8e380623bb874b9e40ae9d3d460a ChangeLog 7129
+MD5 15a028c1f8fff178682119240f0189be metadata.xml 181
MD5 29fa546c14f7d1c0498727a37e1468c0 files/digest-amarok-1.2 64
MD5 8af9e3314d69ebb6341e75b5a1ead176 files/amarok-1.0-cjk-a.diff 1532
+MD5 167a3a9a42477903579be25096b8eaab files/digest-amarok-1.0.2 66
+MD5 33697f318e63c60a1ec8082330eece7f files/digest-amarok-1.1.1 66
+MD5 2a078f136cadb54f32bd6531ef66e218 files/digest-amarok-1.2.1 66
diff --git a/media-sound/amarok/amarok-1.2.1.ebuild b/media-sound/amarok/amarok-1.2.1.ebuild
new file mode 100644
index 000000000000..8046205fd45c
--- /dev/null
+++ b/media-sound/amarok/amarok-1.2.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-1.2.1.ebuild,v 1.1 2005/02/28 23:20:20 carlo Exp $
+
+inherit kde eutils
+
+DESCRIPTION="amaroK - the audio player for KDE"
+HOMEPAGE="http://amarok.kde.org/"
+SRC_URI="mirror://sourceforge/amarok/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="noamazon xmms opengl xine kde arts gstreamer mysql"
+# kde: enables compilation of the konqueror sidebar plugin
+
+KEYWORDS="~amd64 ~ppc -sparc ~x86"
+
+# Not yet released:
+# ">=media-libs/libvisual-0.2.0
+RDEPEND="kde? ( || ( kde-base/konqueror kde-base/kdebase ) )
+ arts? ( kde-base/arts
+ || ( kde-base/kdemultimedia-arts kde-base/kdemultimedia )
+ || ( kde-base/akode kde-base/kdemultimedia ) )
+ opengl? ( virtual/opengl )
+ xmms? ( >=media-sound/xmms-1.2 )
+ xine? ( >=media-libs/xine-lib-1_rc4 )
+ >=media-libs/tunepimp-0.3.0
+ >=media-libs/taglib-1.3.1
+ gstreamer? ( >=media-libs/gst-plugins-0.8.6
+ >=media-plugins/gst-plugins-mad-0.8.6 )
+ mysql? ( >=dev-db/mysql-4 )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9.0"
+
+need-kde 3.2
+
+pkg_setup() {
+ if use !xine && use !arts && use !gstreamer
+ then
+ die "You must enable either aRts or Xine or GStreamer"
+ fi
+}
+
+src_compile() {
+ # amarok does not respect kde coding standards, and makes a lot of
+ # assuptions regarding its installation directory. For this reason,
+ # it must be installed in the KDE install directory.
+ PREFIX="`kde-config --prefix`"
+
+ myconf="$(use_with arts) $(use_with xine) $(use_with gstreamer) $(use_enable mysql) \
+ $(use_with opengl) $(use_enable !noamazon amazon)"
+
+ kde_src_compile
+}
diff --git a/media-sound/amarok/files/digest-amarok-1.2.1 b/media-sound/amarok/files/digest-amarok-1.2.1
new file mode 100644
index 000000000000..dc249de598c4
--- /dev/null
+++ b/media-sound/amarok/files/digest-amarok-1.2.1
@@ -0,0 +1 @@
+MD5 90a8cce693a31e4d6ff552508c31aed3 amarok-1.2.1.tar.bz2 5815092