summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-01-10 12:56:29 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-01-10 12:56:29 +0000
commitcfac0936693cd9e70f68112eff1b08e31f894139 (patch)
treec24b3747934eb2556cbbb4ce5d789af2475eb9ce /media-sound
parentDrop ALSA 1.0.11_rc1 packages. (diff)
downloadhistorical-cfac0936693cd9e70f68112eff1b08e31f894139.tar.gz
historical-cfac0936693cd9e70f68112eff1b08e31f894139.tar.bz2
historical-cfac0936693cd9e70f68112eff1b08e31f894139.zip
Drop ALSA 1.0.11_rc1 packages.
Package-Manager: portage-2529-svn
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/alsa-driver/ChangeLog6
-rw-r--r--media-sound/alsa-driver/alsa-driver-1.0.11_rc1.ebuild163
-rw-r--r--media-sound/alsa-driver/files/alsa-driver-1.0.11_rc1-ppc.patch40
-rw-r--r--media-sound/alsa-driver/files/digest-alsa-driver-1.0.11_rc11
-rw-r--r--media-sound/alsa-headers/ChangeLog6
-rw-r--r--media-sound/alsa-headers/alsa-headers-1.0.11_rc1.ebuild45
-rw-r--r--media-sound/alsa-headers/files/digest-alsa-headers-1.0.11_rc11
-rw-r--r--media-sound/alsa-tools/ChangeLog6
-rw-r--r--media-sound/alsa-tools/alsa-tools-1.0.11_rc1.ebuild101
-rw-r--r--media-sound/alsa-tools/files/digest-alsa-tools-1.0.11_rc11
-rw-r--r--media-sound/alsa-utils/ChangeLog7
-rw-r--r--media-sound/alsa-utils/alsa-utils-1.0.11_rc1.ebuild83
-rw-r--r--media-sound/alsa-utils/files/alsa-utils-1.0.11_rc1-bigendian.patch12
-rw-r--r--media-sound/alsa-utils/files/digest-alsa-utils-1.0.11_rc11
14 files changed, 21 insertions, 452 deletions
diff --git a/media-sound/alsa-driver/ChangeLog b/media-sound/alsa-driver/ChangeLog
index d502c6cdda68..27d591ccdb8a 100644
--- a/media-sound/alsa-driver/ChangeLog
+++ b/media-sound/alsa-driver/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/alsa-driver
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.183 2006/01/10 12:45:39 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.184 2006/01/10 12:54:23 flameeyes Exp $
+
+ 10 Jan 2006; Diego Pettenò <flameeyes@gentoo.org>
+ -files/alsa-driver-1.0.11_rc1-ppc.patch, -alsa-driver-1.0.11_rc1.ebuild:
+ Drop ALSA 1.0.11_rc1 packages.
10 Jan 2006; Diego Pettenò <flameeyes@gentoo.org>
alsa-driver-1.0.11_rc2.ebuild:
diff --git a/media-sound/alsa-driver/alsa-driver-1.0.11_rc1.ebuild b/media-sound/alsa-driver/alsa-driver-1.0.11_rc1.ebuild
deleted file mode 100644
index 7afcff50987b..000000000000
--- a/media-sound/alsa-driver/alsa-driver-1.0.11_rc1.ebuild
+++ /dev/null
@@ -1,163 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-1.0.11_rc1.ebuild,v 1.2 2005/12/22 01:15:01 flameeyes Exp $
-
-inherit linux-mod flag-o-matic eutils
-
-MY_P="${P/_rc/rc}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="Advanced Linux Sound Architecture kernel modules"
-HOMEPAGE="http://www.alsa-project.org/"
-SRC_URI="mirror://alsaproject/driver/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-
-KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~x86"
-IUSE="oss doc"
-
-RDEPEND="virtual/modutils
- ~media-sound/alsa-headers-${PV}"
-DEPEND="${RDEPEND}
- virtual/linux-sources
- sparc? ( >=sys-devel/autoconf-2.50 )
- sys-apps/debianutils"
-
-PROVIDE="virtual/alsa"
-
-pkg_setup() {
- # By default, drivers for all supported cards will be compiled.
- # If you want to only compile for specific card(s), set ALSA_CARDS
- # environment to a space-separated list of drivers that you want to build.
- # For example:
- #
- # env ALSA_CARDS='emu10k1 intel8x0 ens1370' emerge alsa-driver
- #
- ALSA_CARDS=${ALSA_CARDS:-all}
-
- # Which drivers need PNP
- local PNP_DRIVERS="interwave interwave-stb"
-
- CONFIG_CHECK="SOUND"
- SND_ERROR="ALSA is already compiled into the kernel."
- SOUND_ERROR="Your kernel doesn't have sound support enabled."
- SOUND_PRIME_ERROR="Your kernel is configured to use the deprecated OSS drivers. Please disable them and re-emerge alsa-driver."
- PNP_ERROR="Some of the drivers you selected require PNP in your kernel (${PNP_DRIVERS}). Either enable PNP in your kernel or trim which drivers get compiled using ALSA_CARDS in /etc/make.conf."
-
- if [[ "${ALSA_CARDS}" == "all" ]]; then
-
- # Ignore PNP checks for ppc architecture, as PNP can't be enabled there.
- if [[ ${ARCH} != "ppc" ]]; then
- CONFIG_CHECK="${CONFIG_CHECK} PNP"
- fi
- else
- for pnpdriver in ${PNP_DRIVERS}; do
- hasq ${pnpdriver} ${ALSA_CARDS} && CONFIG_CHECK="${CONFIG_CHECK} PNP"
- done
- fi
-
- linux-mod_pkg_setup
-
- if [[ ${PROFILE_ARCH} == "sparc64" ]] ; then
- CBUILD=${CBUILD-${CHOST}}
- CHOST="sparc64-unknown-linux-gnu"
- fi
-}
-
-src_unpack() {
- unpack ${A}
-
- cd ${S}
-
- epatch "${FILESDIR}"/${PN}-1.0.10_rc1-include.patch
- epatch "${FILESDIR}/${P}-ppc.patch"
-
- convert_to_m ${S}/Makefile
- sed -i -e 's:\(.*depmod\):#\1:' ${S}/Makefile
-}
-
-src_compile() {
- # Should fix bug #46901
- is-flag "-malign-double" && filter-flags "-fomit-frame-pointer"
- append-flags "-I${KV_DIR}/arch/$(tc-arch-kernel)/include"
-
- econf $(use_with oss) \
- --with-kernel="${KV_DIR}" \
- --with-build="${KV_OUT_DIR}" \
- --with-isapnp=yes \
- --with-sequencer=yes \
- --with-cards="${ALSA_CARDS}" || die "econf failed"
-
- # linux-mod_src_compile doesn't work well with alsa
-
- ARCH=$(tc-arch-kernel)
- # -j1 : see bug #71028
- emake -j1 HOSTCC=$(tc-getBUILD_CC) CC=$(tc-getCC) || die "Make Failed"
- ARCH=$(tc-arch)
-
- if use doc;
- then
- ebegin "Building Documentation"
- cd ${S}/scripts
- emake || die Failed making docs in ${S}/scripts
-
- cd ${S}/doc/DocBook
- emake || die Failed making docs in ${S}/doc/DocBook
- eend $?
- fi
-}
-
-
-src_install() {
- make DESTDIR=${D} install-modules || die "make install failed"
-
- dodoc CARDS-STATUS FAQ README WARNING TODO
-
- if use doc; then
- docinto doc
- dodoc doc/*
- rm ${D}/usr/share/doc/${PF}/doc/Makefile.gz
-
- docinto DocBook
- dodoc doc/DocBook/*
- rm ${D}/usr/share/doc/${PF}/DocBook/Makefile.gz
-
- docinto Documentation
- dodoc sound/Documentation/*
- fi
-
- if kernel_is 2 6; then
- # mv the drivers somewhere they won't be killed by the kernel's make modules_install
- mv ${D}/lib/modules/${KV_FULL}/kernel/sound ${D}/lib/modules/${KV_FULL}/${PN}
- rmdir ${D}/lib/modules/${KV_FULL}/kernel &> /dev/null
- fi
-}
-
-pkg_postinst() {
- einfo
- einfo "The alsasound initscript and modules.d/alsa have now moved to alsa-utils"
- einfo
- einfo "Also, remember that all mixer channels will be MUTED by default."
- einfo "Use the 'alsamixer' program to unmute them."
- einfo
- einfo "Version 1.0.3 and above should work with version 2.6 kernels."
- einfo "If you experience problems, please report bugs to http://bugs.gentoo.org."
- einfo
-
- linux-mod_pkg_postinst
-
- einfo "Check out the ALSA installation guide availible at the following URL:"
- einfo "http://www.gentoo.org/doc/en/alsa-guide.xml"
-
- if kernel_is 2 6 && [ -e ${ROOT}/lib/modules/${KV_FULL}/kernel/sound ]; then
- # Cleanup if they had older alsa installed
- for file in $(find ${ROOT}/lib/modules/${KV_FULL}/${PN} -type f); do
- rm -f ${file//${KV_FULL}\/${PN}/${KV_FULL}\/kernel\/sound}
- done
-
- for dir in $(find ${ROOT}/lib/modules/${KV_FULL}/kernel/sound -type d | tac); do
- rmdir ${dir} &> /dev/null
- done
- fi
-}
diff --git a/media-sound/alsa-driver/files/alsa-driver-1.0.11_rc1-ppc.patch b/media-sound/alsa-driver/files/alsa-driver-1.0.11_rc1-ppc.patch
deleted file mode 100644
index f33f9b1325dc..000000000000
--- a/media-sound/alsa-driver/files/alsa-driver-1.0.11_rc1-ppc.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-Index: alsa-driver-1.0.11rc1/ppc/tumbler.patch
-===================================================================
---- alsa-driver-1.0.11rc1.orig/ppc/tumbler.patch
-+++ alsa-driver-1.0.11rc1/ppc/tumbler.patch
-@@ -15,21 +15,21 @@
- static struct work_struct device_change;
- +#endif
-
-- static void
-- device_change_handler(void *self)
--@@ -895,7 +900,11 @@
--
-- /* finally we need to schedule an update of the mixer values
-- (master and DRC are enough for now) -ReneR */
-+ static void device_change_handler(void *self)
-+ {
-+@@ -1009,7 +1014,11 @@
-+ mix = chip->mixer_data;
-+ snd_assert(mix, return);
-+ mix->auto_mute_notify = do_notify;
- +#if LINUX_VERSION_CODE < KERNEL_VERSION(2,5,0)
- + schedule_task(&device_change);
- +#else
- schedule_work(&device_change);
- +#endif
--
- }
- }
--@@ -1156,7 +1165,11 @@
-+ #endif /* PMAC_SUPPORT_AUTOMUTE */
-+@@ -1416,7 +1425,11 @@
- chip->resume = tumbler_resume;
- #endif
-
-@@ -40,4 +40,4 @@
- +#endif
-
- #ifdef PMAC_SUPPORT_AUTOMUTE
-- if (mix->headphone_irq >=0 && (err = snd_pmac_add_automute(chip)) < 0)
-+ if ((mix->headphone_irq >=0 || mix->lineout_irq >= 0)
diff --git a/media-sound/alsa-driver/files/digest-alsa-driver-1.0.11_rc1 b/media-sound/alsa-driver/files/digest-alsa-driver-1.0.11_rc1
deleted file mode 100644
index 8f5997aa7433..000000000000
--- a/media-sound/alsa-driver/files/digest-alsa-driver-1.0.11_rc1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 3972451d7ae38965e0d03d48daf9f77a alsa-driver-1.0.11rc1.tar.bz2 2275581
diff --git a/media-sound/alsa-headers/ChangeLog b/media-sound/alsa-headers/ChangeLog
index 4092e6dfd8f9..13045b32aa0b 100644
--- a/media-sound/alsa-headers/ChangeLog
+++ b/media-sound/alsa-headers/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/alsa-headers
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-headers/ChangeLog,v 1.57 2006/01/03 02:02:37 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-headers/ChangeLog,v 1.58 2006/01/10 12:56:29 flameeyes Exp $
+
+ 10 Jan 2006; Diego Pettenò <flameeyes@gentoo.org>
+ -alsa-headers-1.0.11_rc1.ebuild:
+ Drop ALSA 1.0.11_rc1 packages.
03 Jan 2006; Mark Loeser <halcy0n@gentoo.org> alsa-headers-1.0.10.ebuild:
Stable on x86; bug #117518
diff --git a/media-sound/alsa-headers/alsa-headers-1.0.11_rc1.ebuild b/media-sound/alsa-headers/alsa-headers-1.0.11_rc1.ebuild
deleted file mode 100644
index d240cdf6e343..000000000000
--- a/media-sound/alsa-headers/alsa-headers-1.0.11_rc1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-headers/alsa-headers-1.0.11_rc1.ebuild,v 1.1 2005/12/21 15:48:01 flameeyes Exp $
-
-inherit eutils
-
-MY_PN=${PN/headers/driver}
-MY_P="${MY_PN}-${PV/_rc/rc}"
-S=${WORKDIR}/${MY_P}
-MY_FILESDIR="${FILESDIR/headers/driver}"
-
-DESCRIPTION="Header files for Advanced Linux Sound Architecture kernel modules"
-HOMEPAGE="http://www.alsa-project.org/"
-SRC_URI="mirror://alsaproject/driver/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
-
-DEPEND=""
-
-# Remove the sound symlink workaround...
-pkg_setup() {
- if [[ -L ${ROOT}/usr/include/sound ]]; then
- rm ${ROOT}/usr/include/sound
- fi
-}
-
-src_unpack() {
- unpack ${A}
-
- cd ${S}
- epatch ${FILESDIR}/${PN}-1.0.6a-user.patch
-}
-
-src_compile() {
- einfo "No compilation neccessary"
-}
-
-src_install() {
- cd ${S}/alsa-kernel/include
- insinto /usr/include/sound
- doins *.h || die "include failed"
-}
diff --git a/media-sound/alsa-headers/files/digest-alsa-headers-1.0.11_rc1 b/media-sound/alsa-headers/files/digest-alsa-headers-1.0.11_rc1
deleted file mode 100644
index 8f5997aa7433..000000000000
--- a/media-sound/alsa-headers/files/digest-alsa-headers-1.0.11_rc1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 3972451d7ae38965e0d03d48daf9f77a alsa-driver-1.0.11rc1.tar.bz2 2275581
diff --git a/media-sound/alsa-tools/ChangeLog b/media-sound/alsa-tools/ChangeLog
index 666b85892cbd..a3ddaef6628c 100644
--- a/media-sound/alsa-tools/ChangeLog
+++ b/media-sound/alsa-tools/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/alsa-tools
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-tools/ChangeLog,v 1.89 2006/01/03 02:35:24 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-tools/ChangeLog,v 1.90 2006/01/10 12:55:48 flameeyes Exp $
+
+ 10 Jan 2006; Diego Pettenò <flameeyes@gentoo.org>
+ -alsa-tools-1.0.11_rc1.ebuild:
+ Drop ALSA 1.0.11_rc1 packages.
03 Jan 2006; Jeremy Huddleston <eradicator@gentoo.org>
-alsa-tools-1.0.7.ebuild, -alsa-tools-1.0.9.ebuild,
diff --git a/media-sound/alsa-tools/alsa-tools-1.0.11_rc1.ebuild b/media-sound/alsa-tools/alsa-tools-1.0.11_rc1.ebuild
deleted file mode 100644
index ec1597ceb677..000000000000
--- a/media-sound/alsa-tools/alsa-tools-1.0.11_rc1.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-tools/alsa-tools-1.0.11_rc1.ebuild,v 1.1 2005/12/21 15:48:40 flameeyes Exp $
-
-inherit gnuconfig eutils flag-o-matic
-
-MY_P="${P/_rc/rc}"
-
-DESCRIPTION="Advanced Linux Sound Architecture tools"
-HOMEPAGE="http://www.alsa-project.org"
-SRC_URI="mirror://alsaproject/tools/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0.9"
-KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE="fltk gtk"
-
-DEPEND=">=media-libs/alsa-lib-1.0.0
- virtual/alsa
- fltk? ( =x11-libs/fltk-1.1* )
- gtk? ( =x11-libs/gtk+-1.2* )"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- # This is a list of the tools in the package.
- # Some of the tools don't make proper use of CFLAGS, even though
- # all of them seem to use autoconf. This needs to be fixed.
- #
- # By default, all the supported tools will be compiled.
- # If you want to only compile for specific tool(s), set ALSA_TOOLS
- # environment to a space-separated list of tools that you want to build.
- # For example:
- #
- # env ALSA_TOOLS='as10k1 ac3dec' emerge alsa-tools
- #
- if [ -z "${ALSA_TOOLS}" ]; then
- ALSA_TOOLS="ac3dec as10k1 hdsploader mixartloader seq/sbiload \
- sscape_ctl us428control usx2yloader vxloader"
-
- if use fltk; then
- ALSA_TOOLS="${ALSA_TOOLS} hdspconf hdspmixer"
- fi
-
- if use gtk; then
- ALSA_TOOLS="${ALSA_TOOLS} echomixer envy24control rmedigicontrol"
- fi
-
- # sb16_csp won't build on ppc64 _AND_ ppc (and is not needed)
- if use !ppc64 && use !ppc; then
- ALSA_TOOLS="${ALSA_TOOLS} sb16_csp"
- fi
-
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- gnuconfig_update
-}
-
-src_compile() {
- if use fltk; then
- # hdspmixer requires fltk
- append-ldflags "-L/usr/$(get_libdir)/fltk-1.1"
- append-flags "-I/usr/include/fltk-1.1"
- fi
-
- # hdspmixer is missing depconf - copy from the hdsploader directory
- cp ${S}/hdsploader/depcomp ${S}/hdspmixer/
-
- local f
- for f in ${ALSA_TOOLS}
- do
- cd "${S}/${f}"
- econf || die "econf failed"
- make || die "make failed"
- done
-}
-
-src_install() {
- local f
- for f in ${ALSA_TOOLS}
- do
- # Install the main stuff
- cd "${S}/${f}"
- make DESTDIR="${D}" install || die
-
- # Install the text documentation
- local doc
- for doc in README TODO ChangeLog AUTHORS
- do
- if [ -f "${doc}" ]
- then
- mv "${doc}" "${doc}.`basename ${f}`"
- dodoc "${doc}.`basename ${f}`"
- fi
- done
- done
-}
diff --git a/media-sound/alsa-tools/files/digest-alsa-tools-1.0.11_rc1 b/media-sound/alsa-tools/files/digest-alsa-tools-1.0.11_rc1
deleted file mode 100644
index b32976f975b7..000000000000
--- a/media-sound/alsa-tools/files/digest-alsa-tools-1.0.11_rc1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 5b3eb4f7a3ec1b8f296fbe4bbd281812 alsa-tools-1.0.11rc1.tar.bz2 1441919
diff --git a/media-sound/alsa-utils/ChangeLog b/media-sound/alsa-utils/ChangeLog
index 658b81d2cf26..69d1003e40ab 100644
--- a/media-sound/alsa-utils/ChangeLog
+++ b/media-sound/alsa-utils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/alsa-utils
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.129 2006/01/03 02:02:11 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.130 2006/01/10 12:55:06 flameeyes Exp $
+
+ 10 Jan 2006; Diego Pettenò <flameeyes@gentoo.org>
+ -files/alsa-utils-1.0.11_rc1-bigendian.patch,
+ -alsa-utils-1.0.11_rc1.ebuild:
+ Drop ALSA 1.0.11_rc1 packages.
03 Jan 2006; Mark Loeser <halcy0n@gentoo.org> alsa-utils-1.0.10.ebuild:
Stable on x86; bug #117518
diff --git a/media-sound/alsa-utils/alsa-utils-1.0.11_rc1.ebuild b/media-sound/alsa-utils/alsa-utils-1.0.11_rc1.ebuild
deleted file mode 100644
index 38662fe3cc03..000000000000
--- a/media-sound/alsa-utils/alsa-utils-1.0.11_rc1.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/alsa-utils-1.0.11_rc1.ebuild,v 1.4 2006/01/02 20:52:57 gustavoz Exp $
-
-inherit eutils flag-o-matic autotools
-
-MY_P="${P/_rc/rc}"
-
-DESCRIPTION="Advanced Linux Sound Architecture Utils (alsactl, alsamixer, etc.)"
-HOMEPAGE="http://www.alsa-project.org/"
-SRC_URI="mirror://alsaproject/utils/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0.9"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE="nls"
-
-DEPEND=">=sys-libs/ncurses-5.1
- dev-util/dialog
- >=media-libs/alsa-lib-1.0.10_rc1"
-RDEPEND="${DEPEND}
- sys-apps/pciutils"
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-
- epatch "${FILESDIR}/${P}-bigendian.patch"
-}
-
-src_compile() {
- econf \
- $(use_enable nls) \
- || die "configure failed"
-
- emake || die "make failed"
-}
-
-src_install() {
- local ALSA_UTILS_DOCS="ChangeLog README TODO
- seq/aconnect/README.aconnect
- seq/aseqnet/README.aseqnet"
-
- make DESTDIR="${D}" install || die "Installation Failed"
-
- dodoc ${ALSA_UTILS_DOCS}
- newdoc alsamixer/README README.alsamixer
-
- newconfd ${FILESDIR}/alsasound.confd alsasound
- insinto /etc/modules.d
- newins ${FILESDIR}/alsa-modules.conf-rc alsa
- newinitd ${FILESDIR}/alsasound-1.0.10_rc2 alsasound
-}
-
-pkg_postinst() {
- echo
- einfo "The alsasound initscript is now provided by alsa-utils"
- einfo "instead of alsa-driver for compatibility with kernel-sources"
- einfo "which provide ALSA internally."
- echo
- einfo "To take advantage of this, and automate the process of"
- einfo "loading and unloading the ALSA sound drivers as well as"
- einfo "storing and restoring sound-card mixer levels you should"
- einfo "add alsasound to the boot runlevel. You can do this as"
- einfo "root like so:"
- einfo " # rc-update add alsasound boot"
- echo
- einfo "You will also need to edit the file /etc/modules.d/alsa"
- einfo "and run modules-update. You can do this like so:"
- einfo " # nano -w /etc/modules.d/alsa && modules-update"
- echo
-
- if use sparc; then
- ewarn "Old versions of alsa-drivers had a broken snd-ioctl32 module"
- ewarn "which causes sparc64 machines to lockup on such tasks as"
- ewarn "changing the volume. Because of this, it is VERY important"
- ewarn "that you do not use the snd-ioctl32 modules contained in"
- ewarn "development-sources or <=gentoo-dev-sources-2.6.7-r14. Doing so"
- ewarn "may result in an unbootable system if you start alsasound at boot."
- fi
-}
diff --git a/media-sound/alsa-utils/files/alsa-utils-1.0.11_rc1-bigendian.patch b/media-sound/alsa-utils/files/alsa-utils-1.0.11_rc1-bigendian.patch
deleted file mode 100644
index 83a2e315aa12..000000000000
--- a/media-sound/alsa-utils/files/alsa-utils-1.0.11_rc1-bigendian.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-Index: alsa-utils-1.0.11rc1/speaker-test/speaker-test.c
-===================================================================
---- alsa-utils-1.0.11rc1.orig/speaker-test/speaker-test.c
-+++ alsa-utils-1.0.11rc1/speaker-test/speaker-test.c
-@@ -482,6 +482,7 @@ struct wave_header {
- #define LE_SHORT(v) (v)
- #define LE_INT(v) (v)
- #else
-+#include <byteswap.h>
- #define COMPOSE_ID(a,b,c,d) ((d) | ((c)<<8) | ((b)<<16) | ((a)<<24))
- #define LE_SHORT(v) bswap_16(v)
- #define LE_INT(v) bswap_32(v)
diff --git a/media-sound/alsa-utils/files/digest-alsa-utils-1.0.11_rc1 b/media-sound/alsa-utils/files/digest-alsa-utils-1.0.11_rc1
deleted file mode 100644
index eebcd0c75b07..000000000000
--- a/media-sound/alsa-utils/files/digest-alsa-utils-1.0.11_rc1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 cba710f926f5bd3fdac6091d456890ac alsa-utils-1.0.11rc1.tar.bz2 996111