summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2004-03-07 21:30:12 +0000
committerMartin Holzer <mholzer@gentoo.org>2004-03-07 21:30:12 +0000
commitf5e13735391c392fd42376fa483733b2acf25d51 (patch)
treed690224c0d5ac0e38161320eb6367d3c443c7c59 /media-tv/xmltv/xmltv-0.5.29.ebuild
parentVersion bumped. (diff)
downloadhistorical-f5e13735391c392fd42376fa483733b2acf25d51.tar.gz
historical-f5e13735391c392fd42376fa483733b2acf25d51.tar.bz2
historical-f5e13735391c392fd42376fa483733b2acf25d51.zip
VErsion bumped.
Diffstat (limited to 'media-tv/xmltv/xmltv-0.5.29.ebuild')
-rw-r--r--media-tv/xmltv/xmltv-0.5.29.ebuild144
1 files changed, 144 insertions, 0 deletions
diff --git a/media-tv/xmltv/xmltv-0.5.29.ebuild b/media-tv/xmltv/xmltv-0.5.29.ebuild
new file mode 100644
index 000000000000..e3036872fe53
--- /dev/null
+++ b/media-tv/xmltv/xmltv-0.5.29.ebuild
@@ -0,0 +1,144 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/xmltv/xmltv-0.5.29.ebuild,v 1.1 2004/03/07 21:30:12 mholzer Exp $
+
+inherit perl-module
+
+DESCRIPTION="Set of utilities to manage TV listings stored in the XMLTV format."
+HOMEPAGE="http://membled.com/work/apps/xmltv/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+RESTRICT="nomirror"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+# NOTE: you can customize the xmltv installation by
+# defining a XMLTV_OPTS variable which contains
+# a space-separated list of optional features.
+# If this variable is unspecified or has an
+# empty value, everything will be *enabled*.
+#
+# none: Don't enable any of the features below
+# tv_grab_uk_rt: Alternate Britain listings grabber
+# tv_grab_it: Italy listings grabber
+# tv_grab_na: North America listings grabber
+# tv_grab_nz: New Zealand listings grabber
+# tv_grab_fi: Finland listings grabber
+# tv_grab_es: Spain listings grabber
+# tv_grab_nl: Netherlands listings grabber
+# tv_grab_nl_wolf: Alternate Netherlands listings grabber
+# tv_grab_hu: Hungary listings grabber
+# tv_grab_dk: Denmark listings grabber
+# tv_check: Graphical front-end for listings data
+# tv_pick_cgi: CGI front-end for listings data
+
+# EXAMPLES:
+# enable just North American grabber
+# XMLTV_OPTS="tv_grab_na"
+#
+# enable graphical front-end, New Zealand and Italy grabbers
+# XMLTV_OPTS="tv_check tv_grab_nz tv_grab_it"
+
+DEPEND=">=sys-apps/sed-4
+ >=dev-perl/libwww-perl-5.65
+ >=dev-perl/XML-Parser-2.34
+ >=dev-perl/XML-Twig-3.09
+ >=dev-perl/XML-Writer-0.4.1
+ >=dev-perl/DateManip-5.42
+ dev-perl/Memoize
+ >=dev-perl/Term-ProgressBar-2.03
+ dev-perl/Compress-Zlib
+ dev-perl/Lingua-EN-Numbers-Ordinate
+ dev-perl/Lingua-Preferred
+ >=dev-perl/Storable-2.04
+ dev-perl/Unicode-String"
+
+# for tv_check
+DEPEND="${DEPEND} dev-perl/perl-tk dev-perl/Tk-TableMatrix dev-perl/XML-Simple"
+# for tv_grab_na
+DEPEND="${DEPEND} >=dev-perl/HTML-Parser-3.34"
+# for tv_grab_nz
+DEPEND="${DEPEND} >=dev-lang/python-1.5.2"
+# for tv_grab_fi tv_grab_es tv_grab_nl tv_grab_nl_wolf tv_grab_hu tv_grab_dk
+DEPEND="${DEPEND} dev-perl/HTML-Tree"
+
+### disabled until portage dependecy checker has notions of things
+### other then incrementals that are in /etc/make.conf
+### 6/13/2003 Max Kalika <max@gentoo.org>
+#[ -z "${XMLTV_OPTS}" -o "`has tv_grab_na ${XMLTV_OPTS}`" ] \
+# && DEPEND="${DEPEND} dev-perl/HTML-Parser"
+#[ -z "${XMLTV_OPTS}" -o "`has tv_grab_sn ${XMLTV_OPTS}`" ] \
+# && DEPEND="${DEPEND} >=dev-perl/HTML-TableExtract-1.0.8"
+#[ -z "${XMLTV_OPTS}" -o "`has tv_grab_nz ${XMLTV_OPTS}`" ] \
+# && DEPEND="${DEPEND} >=dev-lang/python-1.5.1"
+#[ -z "${XMLTV_OPTS}" -o "`has tv_grab_fi ${XMLTV_OPTS}`" ] \
+# && DEPEND="${DEPEND} dev-perl/HTML-Tree"
+#[ -z "${XMLTV_OPTS}" -o "`has tv_grab_es ${XMLTV_OPTS}`" ] \
+# && DEPEND="${DEPEND} dev-perl/HTML-Tree"
+#[ -z "${XMLTV_OPTS}" -o "`has tv_grab_nl ${XMLTV_OPTS}`" ] \
+# && DEPEND="${DEPEND} dev-perl/HTML-Tree"
+#[ -z "${XMLTV_OPTS}" -o "`has tv_grab_nl_wolf ${XMLTV_OPTS}`" ] \
+# && DEPEND="${DEPEND} dev-perl/HTML-Tree"
+#[ -z "${XMLTV_OPTS}" -o "`has tv_grab_hu ${XMLTV_OPTS}`" ] \
+# && DEPEND="${DEPEND} dev-perl/HTML-Tree"
+#[ -z "${XMLTV_OPTS}" -o "`has tv_grab_dk ${XMLTV_OPTS}`" ] \
+# && DEPEND="${DEPEND} dev-perl/HTML-Tree"
+#[ -z "${XMLTV_OPTS}" -o "`has tv_check ${XMLTV_OPTS}`" ] \
+# && DEPEND="${DEPEND} dev-perl/perl-tk dev-perl/Tk-TableMatrix dev-perl/XML-Simple"
+
+make_config() {
+ if [ -z "${XMLTV_OPTS}" ] ; then
+ # No customization needed, build everything (default)
+ echo "yes"
+ return
+ else
+ # Need to specify custom settings, do not accept defaults
+ echo "no"
+ fi
+
+ # Enable Alternate Brittain
+ [ "`has tv_grab_uk_rt ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
+ # Enable Italy
+ [ "`has tv_grab_it ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
+ # Enable North America
+ [ "`has tv_grab_na ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
+ # Enable New Zealand
+ [ "`has tv_grab_nz ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
+ # Enable Finland
+ [ "`has tv_grab_fi ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
+ # Enable Spain
+ [ "`has tv_grab_es ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
+ # Enable Netherlands
+ [ "`has tv_grab_nl ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
+ # Enable Alternate Netherlands
+ [ "`has tv_grab_nl_wolf ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
+ # Enable Hungary
+ [ "`has tv_grab_hu ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
+ # Enable Denmark
+ [ "`has tv_grab_dk ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
+ # Enable GUI checking.
+ [ "`has tv_check ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
+ # Enable CGI support
+ [ "`has tv_pick_cgi ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
+}
+
+src_compile() {
+ make_config | perl-module_src_compile
+}
+
+src_install() {
+ perl-module_src_install
+
+ for i in `grep -rl "${D}" "${D}"` ; do
+ sed -e "s:${D}::g" -i "${i}"
+ done
+
+ if [ -z "${XMLTV_OPTS}" -o "`has tv_pick_cgi ${XMLTV_OPTS}`" ] ; then
+ dobin choose/tv_pick/tv_pick_cgi
+ einfo
+ einfo "To use tv_pick_cgi, please link it from /usr/bin/tv_pick_cgi"
+ einfo "to where the ScriptAlias directive is configured."
+ einfo
+ fi
+}