summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZaheer Abbas Merali <zaheerm@gentoo.org>2005-04-07 12:23:20 +0000
committerZaheer Abbas Merali <zaheerm@gentoo.org>2005-04-07 12:23:20 +0000
commit98bc41d04ab366e20333b1c5c6fac28621eb442f (patch)
treee77b3786b55fb759123b18c26cbceb3e892e3253 /media-video/flumotion
parentMarked ppc stable. (diff)
downloadhistorical-98bc41d04ab366e20333b1c5c6fac28621eb442f.tar.gz
historical-98bc41d04ab366e20333b1c5c6fac28621eb442f.tar.bz2
historical-98bc41d04ab366e20333b1c5c6fac28621eb442f.zip
version bump
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'media-video/flumotion')
-rw-r--r--media-video/flumotion/ChangeLog5
-rw-r--r--media-video/flumotion/Manifest4
-rw-r--r--media-video/flumotion/files/digest-flumotion-0.1.71
-rw-r--r--media-video/flumotion/flumotion-0.1.7.ebuild86
4 files changed, 94 insertions, 2 deletions
diff --git a/media-video/flumotion/ChangeLog b/media-video/flumotion/ChangeLog
index 8e357252c5ca..16c2e479e45c 100644
--- a/media-video/flumotion/ChangeLog
+++ b/media-video/flumotion/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-video/flumotion
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/flumotion/ChangeLog,v 1.2 2005/03/26 23:39:07 zaheerm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/flumotion/ChangeLog,v 1.3 2005/04/07 12:23:20 zaheerm Exp $
+
+ 07 Apr 2005; <zaheerm@gentoo.org> :
+ Version bump
26 Mar 2005; <zaheerm@gentoo.org> files/flumotion-init:
fixed typo
diff --git a/media-video/flumotion/Manifest b/media-video/flumotion/Manifest
index 378c62629ec4..490ba0855b86 100644
--- a/media-video/flumotion/Manifest
+++ b/media-video/flumotion/Manifest
@@ -1,5 +1,7 @@
MD5 e0396cb7bc686120df16f64f94746f11 flumotion-0.1.6.ebuild 2351
-MD5 480c500274a27e0e0ff6d25305c36af2 ChangeLog 468
+MD5 7a996e8c909a5c50999d49ed3b753eb8 flumotion-0.1.7.ebuild 2277
+MD5 996a01d90d906d9446ba188188b67c13 ChangeLog 522
MD5 6050196ef420c3e4025029ebee5a813f metadata.xml 162
MD5 580aa0b30c3ddad180dcf614364f9dbb files/flumotion-init 1019
MD5 f421d5bbf35e1bda4cde73c86517fbd3 files/digest-flumotion-0.1.6 68
+MD5 423fb37f9e1c267e6d5836e73b651d73 files/digest-flumotion-0.1.7 68
diff --git a/media-video/flumotion/files/digest-flumotion-0.1.7 b/media-video/flumotion/files/digest-flumotion-0.1.7
new file mode 100644
index 000000000000..575aede66715
--- /dev/null
+++ b/media-video/flumotion/files/digest-flumotion-0.1.7
@@ -0,0 +1 @@
+MD5 badba6b3c35a62b42920f5c35964017e flumotion-0.1.7.tar.bz2 600684
diff --git a/media-video/flumotion/flumotion-0.1.7.ebuild b/media-video/flumotion/flumotion-0.1.7.ebuild
new file mode 100644
index 000000000000..63cd30f317b1
--- /dev/null
+++ b/media-video/flumotion/flumotion-0.1.7.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/flumotion/flumotion-0.1.7.ebuild,v 1.1 2005/04/07 12:23:20 zaheerm Exp $
+
+inherit eutils
+
+DESCRIPTION="Flumotion Streaming server"
+HOMEPAGE="http://www.fluendo.com"
+SRC_URI="http://www.flumotion.net/src/flumotion/${P}.tar.bz2"
+LICENSE="GPL-2"
+
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="v4l speex jpeg dv"
+SLOT="0"
+
+RDEPEND=">=x11-libs/gtk+-2.4
+ >=dev-libs/glib-2.4
+ >=gnome-base/libglade-2
+ >=media-libs/gstreamer-0.8.9-r2
+ >=media-libs/gst-plugins-0.8.8
+ >=media-plugins/gst-plugins-gnomevfs-0.8.8
+ v4l? ( >=media-plugins/gst-plugins-v4l-0.8.8 )
+ >=media-plugins/gst-plugins-ogg-0.8.8
+ >=media-plugins/gst-plugins-theora-0.8.8
+ >=media-plugins/gst-plugins-vorbis-0.8.8
+ >=media-plugins/gst-plugins-libpng-0.8.8
+ speex? ( >=media-plugins/gst-plugins-speex-0.8.8 )
+ dv? ( >=media-plugins/gst-plugins-dv-0.8.8
+ >=media-plugins/gst-plugins-raw1394-0.8.8 )
+ >=dev-python/pygtk-2.4.0
+ >=dev-python/gst-python-0.8.1
+ >=dev-python/twisted-1.3.0
+ dev-python/imaging
+ "
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ "
+
+DOCS="AUTHORS COPYING ChangeLog INSTALL \
+ LICENCE.Flumotion LICENCE.GPL \
+ NEWS README TODO"
+
+src_compile() {
+ econf --localstatedir=/var || die
+
+ emake || die
+
+}
+
+src_install() {
+ einstall
+
+ dodir /etc/flumotion
+ dodir /etc/flumotion/managers
+ dodir /etc/flumotion/managers/default
+ dodir /etc/flumotion/managers/default/flows
+ dodir /etc/flumotion/workers
+
+ insinto /etc/flumotion/managers/default/flows
+ cd ${S}/conf
+ doins managers/default/flows/ogg-test-theora.xml
+ insinto /etc/flumotion/managers/default
+ doins managers/default/planet.xml
+ insinto /etc/flumotion/workers
+ doins workers/default.xml
+
+ insinto /etc/flumotion
+ doins default.pem
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/flumotion-init flumotion
+
+ keepdir /var/run/flumotion
+ keepdir /var/log/flumotion
+}
+
+pkg_postinst() {
+ if ! enewgroup flumotion || ! enewuser flumotion -1 /bin/false /usr/share/flumotion flumotion,audio,video,sys; then
+ die "Unable to add flumotion user and flumotion group."
+ fi
+
+ for dir in /usr/share/flumotion /var/log/flumotion /var/run/flumotion; do
+ chown -R flumotion:flumotion ${dir}
+ chmod -R 755 ${dir}
+ done
+}