summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2003-05-02 00:00:54 +0000
committerDaniel Robbins <drobbins@gentoo.org>2003-05-02 00:00:54 +0000
commit72652e8796fc45bfd70bda0264f266ef291e0284 (patch)
treef0497f386d9590217e41f7ee3fc81f5a07a575df /media-video
parentmany fixes, but no rev bump. (diff)
downloadhistorical-72652e8796fc45bfd70bda0264f266ef291e0284.tar.gz
historical-72652e8796fc45bfd70bda0264f266ef291e0284.tar.bz2
historical-72652e8796fc45bfd70bda0264f266ef291e0284.zip
many fixes, but no rev bump.
Diffstat (limited to 'media-video')
-rw-r--r--media-video/ati-drivers/Manifest4
-rw-r--r--media-video/ati-drivers/ati-drivers-2.9.8.ebuild89
-rw-r--r--media-video/ati-drivers/files/digest-ati-drivers-2.9.81
3 files changed, 42 insertions, 52 deletions
diff --git a/media-video/ati-drivers/Manifest b/media-video/ati-drivers/Manifest
index dbca30c4aa2e..cc490868bab3 100644
--- a/media-video/ati-drivers/Manifest
+++ b/media-video/ati-drivers/Manifest
@@ -1,8 +1,8 @@
MD5 3ad88f17e7799066b5366eafedd86d43 ati-drivers-2.5.1-r1.ebuild 3552
MD5 2a7891c630babfa3aa53bd1346a0e555 ati-drivers-2.9.6.ebuild 3730
MD5 1526fb1161daa618507dc4a2e2cb6699 ati-drivers-2.5.1.ebuild 3230
-MD5 2f3d3570a9fdb5d7583d9713abe955b5 ati-drivers-2.9.8.ebuild 3766
-MD5 a0a6b94c25177769884faa285e5e4a0d ChangeLog 2009
+MD5 761d98193e63da5e1fa1c265acad0229 ati-drivers-2.9.8.ebuild 3767
+MD5 5ef616cb5eb5748b81b0a426ec1976a5 ChangeLog 2010
MD5 e61309d064f12cc623e4d6e78aa82b36 files/09ati 39
MD5 bbaa57c2af6fb97bc2d8c9e149932f74 files/digest-ati-drivers-2.5.1 78
MD5 8c91ab37f1350b59a4a7c21a4e8c3acb files/digest-ati-drivers-2.9.6 65
diff --git a/media-video/ati-drivers/ati-drivers-2.9.8.ebuild b/media-video/ati-drivers/ati-drivers-2.9.8.ebuild
index 1fcdb20812fb..b5943c11141f 100644
--- a/media-video/ati-drivers/ati-drivers-2.9.8.ebuild
+++ b/media-video/ati-drivers/ati-drivers-2.9.8.ebuild
@@ -1,47 +1,58 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ati-drivers/ati-drivers-2.9.8.ebuild,v 1.1 2003/04/26 00:59:00 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ati-drivers/ati-drivers-2.9.8.ebuild,v 1.2 2003/05/02 00:00:48 drobbins Exp $
IUSE="qt kde gnome"
DESCRIPTION="Ati precompiled drivers for r300, r250 and r200 chipsets"
HOMEPAGE="http://www.ati.com"
-##SRC_URI="http://pdownload.mii.instacontent.net/ati/drivers/fglrx-glc22-4.3.0-${PV}.i586.rpm"
-##SRC_URI="http://www.schneider-digital.de/download/ati/glx1_linux_X4.3.zip"
-A="fglrx-glc22-4.3.0-${PV}.i586.rpm"
+SRC_URI="http://www.schneider-digital.de/download/ati/glx1_linux_X4.3.zip"
+A2="fglrx-glc22-4.3.0-${PV}.i586.rpm"
SLOT="${KV}"
LICENSE="ATI GPL-2 QPL-1.0"
-KEYWORDS="-* ~x86"
+KEYWORDS="-* x86"
DEPEND=">=virtual/linux-sources-2.4
- >=sys-libs/glibc-2.2.2
app-arch/rpm2targz
+ app-arch/unzip
>=x11-base/xfree-4.3.0
qt? ( >=x11-libs/qt-3.0 )"
+RDEPEND="qt? ( >=x11-libs/qt-3.0 )"
+
ATIBIN="${D}/opt/ati/bin"
RESTRICT="nostrip"
src_unpack() {
- if [ ! -f ${DISTDIR}/${A} ] ; then
- die "Please download ${A} from ${HOMEPAGE} or http://www.schneider-digital.de/html/body_download_ati.html (fetch glx1_linux_X4.3.zip and unpack it)"
- fi
cd ${WORKDIR}
- #unpack ${A}
- #mv "./XFree 4.3.0-2.9.6/fglrx-glc22-4.3.0-${PV}.i586.rpm" .
- rpm2targz ${DISTDIR}/${A}
- tar zxf fglrx-glc22-4.3.0-${PV}.i586.tar.gz
+ unzip -j ${DISTDIR}/${A} || die
+ rpm2targz ${DISTDIR}/${A2} || die
+ tar zxf fglrx-glc22-4.3.0-${PV}.i586.tar.gz || die
+ mkdir ${WORKDIR}/fglrxgears
+ cd ${WORKDIR}/fglrxgears
+ tar zxf ${WORKDIR}/usr/src/fglrx_sample_source.tgz || die
+ mv xc/programs/fgl_glxgears/* .
+ cp Makefile.Linux Makefile.Linux.orig || die
+ #defining USE_GLU allows this to compile with NVIDIA headers just fine
+ sed -e "s:-I/usr/X11R6/include:-D USE_GLU -I/usr/X11R6/include:" Makefile.Linux.orig > Makefile.Linux || die
+ cd ${WORKDIR}
+ local OLDBIN="/usr/X11R6/bin"
+ local ATIBIN="${D}/opt/ati/bin"
+ mkdir fglrx_panel
+ cd fglrx_panel
+ tar zxf ${WORKDIR}/usr/src/fglrx_panel_sources.tgz || die
+ sed -e "s:"${OLDBIN}":"${ATIBIN}":"\
+ Makefile >Makefile.new
+ mv Makefile.new Makefile
}
pkg_setup(){
- opengl-update xfree
+ check_KV || die "please ensure /usr/src/linux points to your kernel symlink"
}
src_compile() {
-
einfo "building the glx module"
- check_KV
cd ${WORKDIR}/lib/modules/fglrx/build_mod
#that is the dirty way to avoid the id -u check
sed -e 's:`id -u`:0:' make.sh >make.sh.new
@@ -50,25 +61,14 @@ src_compile() {
./make.sh || ewarn "glx module not built"
einfo "building the fgl_glxgears sample"
- mkdir ${WORKDIR}/fglrxgears
cd ${WORKDIR}/fglrxgears
- tar -xzvf ${WORKDIR}/usr/src/fglrx_sample_source.tgz
- mv xc/programs/fgl_glxgears/* .
make -f Makefile.Linux || die
if [ "`use qt`" ]
then
einfo "building the qt fglx panel"
- cd ${WORKDIR}
- local OLDBIN="/usr/X11R6/bin"
- local ATIBIN="${D}/opt/ati/bin"
- mkdir fglrx_panel
- cd fglrx_panel
- tar -xzvf ${WORKDIR}/usr/src/fglrx_panel_sources.tgz
- sed -e "s:"${OLDBIN}":"${ATIBIN}":"\
- Makefile >Makefile.new
- mv Makefile.new Makefile
- emake || die
+ cd ${WORKDIR}/fglrx_panel
+ emake || die
fi
#removing stuff
einfo "cleaning"
@@ -115,39 +115,28 @@ src_install() {
doins ${FILESDIR}/09ati
exeinto /opt/ati/bin
doexe fglrxgears/fgl_glxgears
- doexe usr/X11R6/bin/*
+ doexe usr/X11R6/bin/*
rm usr/X11R6/bin/*
if [ "`use qt`" ]
then
doexe fglrx_panel/fireglcontrol
fi
-
- #if ["`use kde`"] then
-
-
- #if ["`use gnome`"]
+ rm -f usr/src/*
cp -R usr ${D}
}
pkg_postinst() {
-#switch to the ati implementation
- if [ "${ROOT}" = "/" ]
- then
- /usr/sbin/opengl-update ati
- fi
-
- einfo
- einfo "To use the xfree GLX, run \"opengl-update xfree\""
- einfo
- einfo
+ #Ebuild shouldn't do this automatically, just tell the user to do it: (drobbins, 1 May 2003)
+ #otherwise it messes up livecd/gamecd stuff
+ #if [ "${ROOT}" = "/" ]
+ #then
+ # /usr/sbin/opengl-update ati
+ #fi
+
+ einfo "To switch to ATI OpenGL, run \"opengl-update ati\""
einfo "To chance your XF86Config you can use the bundled \"fglrxconfig\""
- einfo
#drm-module
update-modules
}
-
-pkg_postrm() {
- opengl-update xfree
-}
diff --git a/media-video/ati-drivers/files/digest-ati-drivers-2.9.8 b/media-video/ati-drivers/files/digest-ati-drivers-2.9.8
index e69de29bb2d1..3ea7bf3d9bfe 100644
--- a/media-video/ati-drivers/files/digest-ati-drivers-2.9.8
+++ b/media-video/ati-drivers/files/digest-ati-drivers-2.9.8
@@ -0,0 +1 @@
+MD5 e09ec30988f3dca8d89822c024e73c1f glx1_linux_X4.3.zip 3874671