summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-07-04 02:18:56 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-07-04 02:18:56 +0000
commit755004752b0ed318b91902c0f4298e374158f295 (patch)
tree754c2ac83e7b3ff61e419f5549a6ab368d01530d /media-video
parentgah, forgot a patch (diff)
downloadhistorical-755004752b0ed318b91902c0f4298e374158f295.tar.gz
historical-755004752b0ed318b91902c0f4298e374158f295.tar.bz2
historical-755004752b0ed318b91902c0f4298e374158f295.zip
small fix0rs
Diffstat (limited to 'media-video')
-rw-r--r--media-video/ogle/ogle-0.8.4.ebuild16
1 files changed, 12 insertions, 4 deletions
diff --git a/media-video/ogle/ogle-0.8.4.ebuild b/media-video/ogle/ogle-0.8.4.ebuild
index 5453d5977cd5..517b5a720cf5 100644
--- a/media-video/ogle/ogle-0.8.4.ebuild
+++ b/media-video/ogle/ogle-0.8.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/media-video/ogle/ogle-0.8.4.ebuild,v 1.1 2002/07/01 08:10:27 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ogle/ogle-0.8.4.ebuild,v 1.2 2002/07/04 02:18:56 seemant Exp $
inherit libtool
@@ -29,9 +29,17 @@ src_compile() {
local myconf
- use mmx || myconf="--disable-mmx"
- use oss || myconf="${myconf} --disable-oss"
- use alsa || myconf="${myconf} --disable-alsa"
+ use mmx \
+ && myconf="--enable-mmx" \
+ || myconf="--disable-mmx"
+
+ use oss \
+ && myconf="${myconf} --enable-oss" \
+ || myconf="${myconf} --disable-oss"
+
+ use alsa \
+ && myconf="${myconf} --enable-alsa" \
+ || myconf="${myconf} --disable-alsa"
elibtoolize