summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Lauwers <blauwers@gentoo.org>2002-12-11 15:56:19 +0000
committerBart Lauwers <blauwers@gentoo.org>2002-12-11 15:56:19 +0000
commit9a9bd86d0382b9654ca89ba19af0102dc33ed504 (patch)
treece9ae1ef65be90cb5bd364bf47da4bd77e3a768d /media-video
parentchanged KEYWORD (diff)
downloadhistorical-9a9bd86d0382b9654ca89ba19af0102dc33ed504.tar.gz
historical-9a9bd86d0382b9654ca89ba19af0102dc33ed504.tar.bz2
historical-9a9bd86d0382b9654ca89ba19af0102dc33ed504.zip
Update per Bug#11114
Diffstat (limited to 'media-video')
-rw-r--r--media-video/transcode/ChangeLog12
-rw-r--r--media-video/transcode/files/digest-transcode-0.6.21
-rw-r--r--media-video/transcode/files/digest-transcode-0.6.3.200212051
-rw-r--r--media-video/transcode/transcode-0.6.2.ebuild110
-rw-r--r--media-video/transcode/transcode-0.6.3.20021205.ebuild110
5 files changed, 233 insertions, 1 deletions
diff --git a/media-video/transcode/ChangeLog b/media-video/transcode/ChangeLog
index 2e20276477f7..98c67ff02c06 100644
--- a/media-video/transcode/ChangeLog
+++ b/media-video/transcode/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for media-video/transcode
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-video/transcode/ChangeLog,v 1.17 2002/11/17 09:42:11 phoenix Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/transcode/ChangeLog,v 1.18 2002/12/11 15:56:19 blauwers Exp $
+
+*transcode-0.6.3.20021205 (11 Dec 2002)
+
+ 11 Dec 2002; B.Lauwers <blauwers@gentoo.org> Changelog, transcode-0.6.3.20021205.ebuild :
+ Bumped to new version per Bug#11114
+
+*transcode-0.6.2 (11 Dec 2002)
+
+ 11 Dec 2002; B.Lauwers <blauwers@gentoo.org> Changelog, transcode-0.6.2.ebuild :
+ Bumped to new version per Bug#11114
*transcode-0.6.2.20021114 (17 Nov 2002)
diff --git a/media-video/transcode/files/digest-transcode-0.6.2 b/media-video/transcode/files/digest-transcode-0.6.2
new file mode 100644
index 000000000000..de25375c98b3
--- /dev/null
+++ b/media-video/transcode/files/digest-transcode-0.6.2
@@ -0,0 +1 @@
+MD5 8b26a0ac883f7ed0c34abaaf1eaca412 transcode-0.6.2.tar.gz 2388302
diff --git a/media-video/transcode/files/digest-transcode-0.6.3.20021205 b/media-video/transcode/files/digest-transcode-0.6.3.20021205
new file mode 100644
index 000000000000..38b68f2e5051
--- /dev/null
+++ b/media-video/transcode/files/digest-transcode-0.6.3.20021205
@@ -0,0 +1 @@
+MD5 22eebbfad4e3be5d473430f89d3e274b transcode-0.6.3.20021205.tar.gz 2408124
diff --git a/media-video/transcode/transcode-0.6.2.ebuild b/media-video/transcode/transcode-0.6.2.ebuild
new file mode 100644
index 000000000000..305dabee31b4
--- /dev/null
+++ b/media-video/transcode/transcode-0.6.2.ebuild
@@ -0,0 +1,110 @@
+ Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/transcode/transcode-0.6.2.ebuild,v 1.1 2002/12/11 15:56:19 blauwers Exp $
+
+IUSE="sdl mmx mpeg sse dvd encode X quicktime avi"
+
+inherit libtool
+
+MY_P=${P/_/}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="video stream processing tool"
+SRC_URI="http://www.theorie.physik.uni-goettingen.de/~ostreich/transcode/pre/${MY_P}.tar.gz"
+HOMEPAGE="http://www.theorie.physik.uni-goettingen.de/~ostreich/transcode"
+
+# Note: transcode can use pretty much any media-related package ever written as
+# a plugin. An exhaustive dep list would make me add about 20-30 packages to
+# portage. perhaps another time :-)
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND=">=media-libs/a52dec-0.7.3
+ >=media-libs/libdv-0.9.5
+ >=dev-lang/nasm-0.98.34
+ X? ( virtual/x11 )
+ avi? ( >=media-video/avifile-0.7.4 )
+ dvd? ( media-libs/libdvdread )
+ mpeg? ( media-libs/libmpeg3 )
+ encode? ( >=media-sound/lame-3.89 )
+ sdl? ( media-libs/libsdl )
+ quicktime? ( media-libs/quicktime4linux )
+ >=media-video/avifile-0.7.4
+ media-libs/libdvdread
+ >=media-video/mplayer-0.90_pre10"
+
+# >=media-video/mplayer-0.90_pre10
+# Most people will want to view their video so
+# I have made mplayer the default as that is what
+# many will use anyway. Due to API changes transcode will
+# now fail to build if an earlier version of mplayer is
+# installed.
+# 2002-11-22 Transcode now requires nasm.
+
+# Dont want to build without these currently
+# avi? ( >=media-video/avifile-0.7.4 )
+# dvd? ( media-libs/libdvdread )"
+
+src_compile() {
+
+ # fix invalid paths in .la files of plugins
+ elibtoolize
+
+ local myconf=""
+
+ use mmx \
+ && myconf="${myconf} --enable-mmx"
+ use mmx || ( use 3dnow || use sse ) \
+ || myconf="${myconf} --disable-mmx"
+ # Dont disable mmx if 3dnow or sse are requested.
+
+ use sse \
+ && myconf="${myconf} --enable-sse" \
+ || myconf="${myconf} --disable-sse"
+
+# use avi \
+# && myconf="${myconf} --with-avifile-mods --enable-avifile6" \
+# || myconf="${myconf} --without-avifile-mods --disable-avifile6"
+#
+# use dvd \
+# && myconf="${myconf} --with-dvdread" \
+# || myconf="${myconf} --without-dvdread"
+#
+# Dont currently want to build without these
+ myconf="${myconf} --with-dvdread --with-avifile-mods --enable-avifile6"
+
+ use encode \
+ && myconf="${myconf} --with-lame" \
+ || myconf="${myconf} --without-lame"
+
+ use mpeg \
+ && myconf="${myconf} --with-libmpeg3" \
+ || myconf="${myconf} --without-libmpeg3"
+
+ use quicktime \
+ || myconf="${myconf} --without-qt --without-openqt"
+
+ use X \
+ && myconf="${myconf} --enable-x" \
+ || myconf="${myconf} --disable-x"
+
+ # Use the MPlayer libpostproc if present
+ [ -f ${ROOT}/usr/lib/libpostproc.a ] && \
+ [ -f ${ROOT}/usr/include/postprocess.h ] && \
+ myconf="${myconf} --with-libpostproc-builddir=${ROOT}/usr/lib"
+
+ econf ${myconf} || die
+
+ # Do not use emake !!
+ make all || die
+}
+
+src_install () {
+
+ make \
+ DESTDIR=${D} \
+ install || die
+
+ dodoc AUTHORS COPYING ChangeLog README TODO
+}
diff --git a/media-video/transcode/transcode-0.6.3.20021205.ebuild b/media-video/transcode/transcode-0.6.3.20021205.ebuild
new file mode 100644
index 000000000000..f04c92b995f4
--- /dev/null
+++ b/media-video/transcode/transcode-0.6.3.20021205.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/transcode/transcode-0.6.3.20021205.ebuild,v 1.1 2002/12/11 15:56:19 blauwers Exp $
+
+IUSE="sdl mmx mpeg sse dvd encode X quicktime avi"
+
+inherit libtool
+
+MY_P=${P/_/}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="video stream processing tool"
+SRC_URI="http://www.theorie.physik.uni-goettingen.de/~ostreich/transcode/pre/${MY_P}.tar.gz"
+HOMEPAGE="http://www.theorie.physik.uni-goettingen.de/~ostreich/transcode"
+
+# Note: transcode can use pretty much any media-related package ever written as
+# a plugin. An exhaustive dep list would make me add about 20-30 packages to
+# portage. perhaps another time :-)
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND=">=media-libs/a52dec-0.7.3
+ >=media-libs/libdv-0.9.5
+ >=dev-lang/nasm-0.98.34
+ X? ( virtual/x11 )
+ avi? ( >=media-video/avifile-0.7.4 )
+ dvd? ( media-libs/libdvdread )
+ mpeg? ( media-libs/libmpeg3 )
+ encode? ( >=media-sound/lame-3.89 )
+ sdl? ( media-libs/libsdl )
+ quicktime? ( media-libs/quicktime4linux )
+ >=media-video/avifile-0.7.4
+ media-libs/libdvdread
+ >=media-video/mplayer-0.90_pre10"
+
+# >=media-video/mplayer-0.90_pre10
+# Most people will want to view their video so
+# I have made mplayer the default as that is what
+# many will use anyway. Due to API changes transcode will
+# now fail to build if an earlier version of mplayer is
+# installed.
+# 2002-11-22 Transcode now requires nasm.
+
+# Dont want to build without these currently
+# avi? ( >=media-video/avifile-0.7.4 )
+# dvd? ( media-libs/libdvdread )"
+
+src_compile() {
+
+ # fix invalid paths in .la files of plugins
+ elibtoolize
+
+ local myconf=""
+
+ use mmx \
+ && myconf="${myconf} --enable-mmx"
+ use mmx || ( use 3dnow || use sse ) \
+ || myconf="${myconf} --disable-mmx"
+ # Dont disable mmx if 3dnow or sse are requested.
+
+ use sse \
+ && myconf="${myconf} --enable-sse" \
+ || myconf="${myconf} --disable-sse"
+
+# use avi \
+# && myconf="${myconf} --with-avifile-mods --enable-avifile6" \
+# || myconf="${myconf} --without-avifile-mods --disable-avifile6"
+#
+# use dvd \
+# && myconf="${myconf} --with-dvdread" \
+# || myconf="${myconf} --without-dvdread"
+#
+# Dont currently want to build without these
+ myconf="${myconf} --with-dvdread --with-avifile-mods --enable-avifile6"
+
+ use encode \
+ && myconf="${myconf} --with-lame" \
+ || myconf="${myconf} --without-lame"
+
+ use mpeg \
+ && myconf="${myconf} --with-libmpeg3" \
+ || myconf="${myconf} --without-libmpeg3"
+
+ use quicktime \
+ || myconf="${myconf} --without-qt --without-openqt"
+
+ use X \
+ && myconf="${myconf} --enable-x" \
+ || myconf="${myconf} --disable-x"
+
+ # Use the MPlayer libpostproc if present
+ [ -f ${ROOT}/usr/lib/libpostproc.a ] && \
+ [ -f ${ROOT}/usr/include/postprocess.h ] && \
+ myconf="${myconf} --with-libpostproc-builddir=${ROOT}/usr/lib"
+
+ econf ${myconf} || die
+
+ # Do not use emake !!
+ make all || die
+}
+
+src_install () {
+
+ make \
+ DESTDIR=${D} \
+ install || die
+
+ dodoc AUTHORS COPYING ChangeLog README TODO
+}