summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabriele Giorgetti <stroke@gentoo.org>2002-06-09 10:57:48 +0000
committerGabriele Giorgetti <stroke@gentoo.org>2002-06-09 10:57:48 +0000
commite5ae9231dac43183612da3079c4357a5d41cf854 (patch)
treeeba0b1f9c5d183a1300546b1e1c634587f55c375 /media-video
parentnew version (diff)
downloadhistorical-e5ae9231dac43183612da3079c4357a5d41cf854.tar.gz
historical-e5ae9231dac43183612da3079c4357a5d41cf854.tar.bz2
historical-e5ae9231dac43183612da3079c4357a5d41cf854.zip
Version 0.1.0 added, 0.1.0.6 removed. (bug #3495)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/mgavideo/ChangeLog9
-rw-r--r--media-video/mgavideo/files/digest-mgavideo-0.1.01
-rw-r--r--media-video/mgavideo/files/digest-mgavideo-0.1.0.61
-rw-r--r--media-video/mgavideo/mgavideo-0.1.0.ebuild63
4 files changed, 72 insertions, 2 deletions
diff --git a/media-video/mgavideo/ChangeLog b/media-video/mgavideo/ChangeLog
index e18f70fcf768..50a35861f308 100644
--- a/media-video/mgavideo/ChangeLog
+++ b/media-video/mgavideo/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-video/mgavideo
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-video/mgavideo/ChangeLog,v 1.2 2002/05/08 06:01:08 jnelson Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mgavideo/ChangeLog,v 1.3 2002/06/09 10:57:48 stroke Exp $
+
+*mgavideo-0.1.0 (08 Jun 2002)
+
+ 08 Jun 2002; Gabriele Giorgetti <stroke@gentoo.org> mgavideo-0.1.0.ebuild :
+
+ New version. (0.6 was a test version). See bug #3495
+
*mgavideo-0.1.0.6 (1 Feb 2002)
diff --git a/media-video/mgavideo/files/digest-mgavideo-0.1.0 b/media-video/mgavideo/files/digest-mgavideo-0.1.0
new file mode 100644
index 000000000000..9fb470d1979a
--- /dev/null
+++ b/media-video/mgavideo/files/digest-mgavideo-0.1.0
@@ -0,0 +1 @@
+MD5 d160205affd6393f09cf6f8fc7ffbb3a mgavideo-0.1.0.tar.gz 258219
diff --git a/media-video/mgavideo/files/digest-mgavideo-0.1.0.6 b/media-video/mgavideo/files/digest-mgavideo-0.1.0.6
deleted file mode 100644
index d82bb4cfdfc3..000000000000
--- a/media-video/mgavideo/files/digest-mgavideo-0.1.0.6
+++ /dev/null
@@ -1 +0,0 @@
-MD5 b2b21cb4de4084b4c64d109ad217e011 mgavideo-0.1.0-test6.tar.gz 244775
diff --git a/media-video/mgavideo/mgavideo-0.1.0.ebuild b/media-video/mgavideo/mgavideo-0.1.0.ebuild
new file mode 100644
index 000000000000..89e062e976a2
--- /dev/null
+++ b/media-video/mgavideo/mgavideo-0.1.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+
+A=${PN}-0.1.0.tar.gz
+S=${WORKDIR}/${PN}-0.1.0/driver
+SRC_URI="http://telia.dl.sourceforge.net/marvel/${A}"
+DESCRIPTION="Matrox Marvel G200/G400/Rainbow Runner G-series V4L I and II
+drivers"
+HOMEPAGE="http://marvel.sourceforge.net"
+
+DEPEND="virtual/glibc
+ virtual/kernel"
+
+RDEPEND="virtual/kernel"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # This allows us to compile the i2c-algo-ks.o module even if the user doesn't have
+ # the i2c-core.o module, incase they want to compile that later. At the end of this
+ # script we warn them if that is the case
+
+ cp Makefile Makefile.orig
+ sed -e '/i2c-algo-ks\.o\:/,+3c\
+i2c-algo-ks.o:\
+ \$(CC) \$(CFLAGS) -c i2c-algo-ks.c' Makefile.orig > Makefile
+}
+
+src_compile() {
+ make mjpeg
+}
+
+src_install() {
+ local install_dir=/lib/modules/${KVERS}/kernel/drivers/mgavideo
+
+ dodir ${install_dir}
+ dodoc README CHANGELOG
+ cp i2c-algo-ks.o ${D}/${install_dir}
+ cp tuner.o ${D}/${install_dir}
+ cp ks0127.o ${D}/${install_dir}
+ cp msp3400.o ${D}/${install_dir}
+ cp maven.o ${D}/${install_dir}
+ cp mga_core.o ${D}/${install_dir}
+ cp mgavideo.o ${D}/${install_dir}
+ cp mgacap.o ${D}/${install_dir}
+ cp zr36060.o ${D}/${install_dir}
+ cp i33.o ${D}/${install_dir}
+ cp mgajpg.o ${D}/${install_dir}
+ cp mgagrab.o ${D}/${install_dir}
+}
+
+pkg_postinst() {
+ depmod -a
+ if [ ! -f /lib/modules/${KVERS}/kernel/drivers/i2c/i2c-core.o ] ; then
+ echo
+ echo '###############################################################'
+ echo '## WARNING: i2c support must be compiled into your kernel ##'
+ echo '## as a module for these drivers to work. ##'
+ echo '###############################################################'
+ echo
+ fi
+}