summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-03-10 08:53:46 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-03-10 08:53:46 +0000
commitdb9295f5c9b61a4658301c8a3165788cc2263986 (patch)
tree7699f7894108639ef5bf5ce5d517f545b6eff82c /net-analyzer/honeyd
parenttweak uid adding (diff)
downloadhistorical-db9295f5c9b61a4658301c8a3165788cc2263986.tar.gz
historical-db9295f5c9b61a4658301c8a3165788cc2263986.tar.bz2
historical-db9295f5c9b61a4658301c8a3165788cc2263986.zip
Version bump
Diffstat (limited to 'net-analyzer/honeyd')
-rw-r--r--net-analyzer/honeyd/ChangeLog7
-rw-r--r--net-analyzer/honeyd/files/digest-honeyd-0.53
-rw-r--r--net-analyzer/honeyd/honeyd-0.5.ebuild53
3 files changed, 62 insertions, 1 deletions
diff --git a/net-analyzer/honeyd/ChangeLog b/net-analyzer/honeyd/ChangeLog
index ca3a13837d2e..b26ee75635c4 100644
--- a/net-analyzer/honeyd/ChangeLog
+++ b/net-analyzer/honeyd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/honeyd
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/honeyd/ChangeLog,v 1.1 2003/02/12 10:45:18 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/honeyd/ChangeLog,v 1.2 2003/03/10 08:53:46 aliz Exp $
+
+*honeyd-0.5 (10 Mar 2003)
+
+ 10 Mar 2003; Daniel Ahlberg <aliz@gentoo.org> :
+ Version bump. Ebuild contributed by Daniel Mannarino <thesnark@operamail.com> in #16601.
*honeyd-0.4b (12 Feb 2003)
diff --git a/net-analyzer/honeyd/files/digest-honeyd-0.5 b/net-analyzer/honeyd/files/digest-honeyd-0.5
new file mode 100644
index 000000000000..5927d64b0ed4
--- /dev/null
+++ b/net-analyzer/honeyd/files/digest-honeyd-0.5
@@ -0,0 +1,3 @@
+MD5 3aec5101f44ef21b29c213496d92c1c1 honeyd-0.5.tar.gz 272149
+MD5 31994ea5a5a68bcf5af1317c32cf63d7 001-ipfrag.patch 769
+MD5 88a928af9a12570cad7af139684fed03 002-proxy.patch 457
diff --git a/net-analyzer/honeyd/honeyd-0.5.ebuild b/net-analyzer/honeyd/honeyd-0.5.ebuild
new file mode 100644
index 000000000000..8be5bf5a4970
--- /dev/null
+++ b/net-analyzer/honeyd/honeyd-0.5.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/honeyd/honeyd-0.5.ebuild,v 1.1 2003/03/10 08:53:46 aliz Exp $
+
+inherit eutils
+
+DESCRIPTION="Honeyd is a small daemon that creates virtual hosts on a network"
+HOMEPAGE="http://www.citi.umich.edu/u/provos/honeyd/"
+SRC_URI="http://www.citi.umich.edu/u/provos/honeyd/${P}.tar.gz
+ http://www.citi.umich.edu/u/provos/honeyd/patches/${PV}/001-ipfrag.patch
+ http://www.citi.umich.edu/u/provos/honeyd/patches/${PV}/002-proxy.patch"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE=""
+DEPEND=">=libdnet-1.4
+ >=libevent-0.6
+ >=libpcap-0.7.1"
+RDEPEND=${DEPEND}
+
+S="${WORKDIR}/${P}"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S}
+ epatch ${DISTDIR}/001-ipfrag.patch
+ epatch ${DISTDIR}/002-proxy.patch
+}
+
+src_compile() {
+ econf --with-libdnet=/usr || die "econf failed"
+ emake CFLAGS="${CFLAGS} -Wall -g \
+ -DPATH_HONEYDDATA=${honeyddatadir} \
+ -DPATH_HONEYDLIB=${honeydlibdir} " \
+ || die "emake failed"
+}
+
+src_install() {
+ dodoc README
+ dosbin honeyd
+
+ einstall
+
+ rm ${D}/usr/bin/honeyd
+ rm ${D}/usr/share/honeyd/README
+
+ dodir /usr/share/honeyd/scripts
+ exeinto /usr/share/honeyd/scripts
+ doexe scripts/web.sh scripts/router-telnet.pl scripts/test.sh
+}
+