summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEldad Zack <eldad@gentoo.org>2004-06-30 23:12:31 +0000
committerEldad Zack <eldad@gentoo.org>2004-06-30 23:12:31 +0000
commita31585767e0a13dcb66af5fa7f42725f51a169dc (patch)
tree93722d0a3095e8f3ba9e2fb4a84776cb340042eb /net-analyzer/netselect/netselect-0.3-r1.ebuild
parentamd64 (diff)
downloadhistorical-a31585767e0a13dcb66af5fa7f42725f51a169dc.tar.gz
historical-a31585767e0a13dcb66af5fa7f42725f51a169dc.tar.bz2
historical-a31585767e0a13dcb66af5fa7f42725f51a169dc.zip
fixed sudo permissions, closes #47209 ; sed cleanup ; added metadata
Diffstat (limited to 'net-analyzer/netselect/netselect-0.3-r1.ebuild')
-rw-r--r--net-analyzer/netselect/netselect-0.3-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-analyzer/netselect/netselect-0.3-r1.ebuild b/net-analyzer/netselect/netselect-0.3-r1.ebuild
new file mode 100644
index 000000000000..d4bd28e22eda
--- /dev/null
+++ b/net-analyzer/netselect/netselect-0.3-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netselect/netselect-0.3-r1.ebuild,v 1.1 2004/06/30 23:12:31 eldad Exp $
+
+S=${WORKDIR}/${PN}
+DESCRIPTION="Ultrafast implementation of ping."
+HOMEPAGE="http://www.worldvisions.ca/~apenwarr/netselect/"
+SRC_URI="http://www.worldvisions.ca/~apenwarr/netselect/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64 ~ppc64 ~s390"
+
+src_compile() {
+ mv Makefile Makefile.orig
+ sed -e "s:PREFIX =.*:PREFIX = ${D}usr:" \
+ -e "s:CFLAGS =.*:CFLAGS = -Wall -I. -g ${CFLAGS}:" \
+ -e '23,27d' \
+ -e '34d' \
+ -i Makefile
+
+ make || die
+}
+
+src_install () {
+ make install || die
+ fowners root:wheel /usr/bin/netselect
+ fperms 4710 /usr/bin/netselect
+
+ dodoc ChangeLog HISTORY README*
+}