summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2004-09-01 11:37:07 +0000
committerMichael Januszewski <spock@gentoo.org>2004-09-01 11:37:07 +0000
commit3487f73eea1aa1b4e4070c178716794b5d1bd074 (patch)
tree0b2bb4ae439a292abd68482115129303adf54ab4 /net-analyzer/nmap
parentinitial version of corkscrew (diff)
downloadhistorical-3487f73eea1aa1b4e4070c178716794b5d1bd074.tar.gz
historical-3487f73eea1aa1b4e4070c178716794b5d1bd074.tar.bz2
historical-3487f73eea1aa1b4e4070c178716794b5d1bd074.zip
Version bump.
Diffstat (limited to 'net-analyzer/nmap')
-rw-r--r--net-analyzer/nmap/ChangeLog8
-rw-r--r--net-analyzer/nmap/Manifest14
-rw-r--r--net-analyzer/nmap/files/digest-nmap-3.702
-rw-r--r--net-analyzer/nmap/nmap-3.70.ebuild31
4 files changed, 53 insertions, 2 deletions
diff --git a/net-analyzer/nmap/ChangeLog b/net-analyzer/nmap/ChangeLog
index dae005c9957d..01884f110956 100644
--- a/net-analyzer/nmap/ChangeLog
+++ b/net-analyzer/nmap/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/nmap
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.63 2004/08/22 20:42:29 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.64 2004/09/01 11:37:07 spock Exp $
+
+*nmap-3.70 (01 Sep 2004)
+
+ 01 Sep 2004; Michal Januszewski <spock@gentoo.org> +nmap-3.70.ebuild:
+ Version bump. Dropped the statistics patch as it does not apply to 3.70 and
+ doesn't seem to be maintained upstream.
22 Aug 2004; Bryan Østergaard <kloeri@gentoo.org> nmap-3.55.ebuild:
Stable on alpha.
diff --git a/net-analyzer/nmap/Manifest b/net-analyzer/nmap/Manifest
index 99fd38818c1f..4966e97c1fb1 100644
--- a/net-analyzer/nmap/Manifest
+++ b/net-analyzer/nmap/Manifest
@@ -1,10 +1,22 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 519ce60fb556bb594385954bf8461bd2 nmap-3.50-r1.ebuild 1006
MD5 dc37e1a679d5cbbb3d5c7e8542642708 nmap-3.55.ebuild 1041
MD5 dd8e704f8af8f654006ad7425e4810d1 nmap-3.50.ebuild 979
+MD5 a6f6f59fc1242c82871366e8f725edd3 nmap-3.70.ebuild 842
MD5 9992ac1d8edaeaf8d63b3fe941ff96ff nmap-3.48.ebuild 979
-MD5 018062bb86f45c4f1b1b72a9b36444d4 ChangeLog 8143
+MD5 fd34f1be295d512a75728d8bd3c70a21 ChangeLog 8361
MD5 cfe1b5f88cc51ac6ffc42809178d2a06 metadata.xml 221
MD5 d46477d7825ac476a9c5f557fd0a7272 files/digest-nmap-3.48 133
MD5 3df9d80cb8c3933dffd20af89a82957b files/digest-nmap-3.50 133
MD5 1037b8fc75e77ab2c1e2687d5d3a88cc files/digest-nmap-3.55 133
+MD5 3ee2ad5a02f8d315146f7407d1a8cde5 files/digest-nmap-3.70 137
MD5 3df9d80cb8c3933dffd20af89a82957b files/digest-nmap-3.50-r1 133
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.2.6 (GNU/Linux)
+
+iD8DBQFBNbR0chej4aZK9/cRAjY1AJ0Yz0ddNcE3SsPLjgH5INCFEiZAGwCfSwbv
+hxVDM5fE/MnvDJWjXhw3hxc=
+=A71Q
+-----END PGP SIGNATURE-----
diff --git a/net-analyzer/nmap/files/digest-nmap-3.70 b/net-analyzer/nmap/files/digest-nmap-3.70
new file mode 100644
index 000000000000..b23312e72eae
--- /dev/null
+++ b/net-analyzer/nmap/files/digest-nmap-3.70
@@ -0,0 +1,2 @@
+MD5 b9a92e48324cd393edaef773b294f36b nmap-3.70.tar.bz2 1435675
+MD5 0dcc4a23dc8b71036363f8e417600eeb nmap-3.48_statistics_patch.diff 6408
diff --git a/net-analyzer/nmap/nmap-3.70.ebuild b/net-analyzer/nmap/nmap-3.70.ebuild
new file mode 100644
index 000000000000..83b639d29560
--- /dev/null
+++ b/net-analyzer/nmap/nmap-3.70.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-3.70.ebuild,v 1.1 2004/09/01 11:37:07 spock Exp $
+
+inherit eutils
+
+DESCRIPTION="A utility for network exploration or security auditing"
+HOMEPAGE="http://www.insecure.org/nmap/"
+SRC_URI="http://www.insecure.org/nmap/dist/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~arm ~hppa ~amd64 ~ppc64"
+IUSE="gtk gnome"
+
+DEPEND="virtual/libc
+ dev-libs/libpcre
+ gtk? ( =x11-libs/gtk+-1.2* )"
+
+src_compile() {
+ econf `use_with gtk nmapfe` || die
+ emake -j1 || die
+}
+
+src_install() {
+ einstall nmapdatadir=${D}/usr/share/nmap install || die
+ use gnome || rm -rf ${D}/usr/share/gnome/
+
+ dodoc CHANGELOG HACKING INSTALL docs/README docs/*.txt
+ dohtml docs/*.html
+}