summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2005-01-08 10:46:54 +0000
committerDaniel Black <dragonheart@gentoo.org>2005-01-08 10:46:54 +0000
commitcbc9321e351d045a277de1411cbb4a1ada67e059 (patch)
tree9cc26acf0391c697e678d3a37438f109f6a3477e /net-analyzer/trafshow
parenttail -1 problem fixed from bug #69775 (diff)
downloadhistorical-cbc9321e351d045a277de1411cbb4a1ada67e059.tar.gz
historical-cbc9321e351d045a277de1411cbb4a1ada67e059.tar.bz2
historical-cbc9321e351d045a277de1411cbb4a1ada67e059.zip
patch fix
Diffstat (limited to 'net-analyzer/trafshow')
-rw-r--r--net-analyzer/trafshow/files/trafshow-4.0-gentoo.patch14
-rw-r--r--net-analyzer/trafshow/trafshow-4.0.ebuild3
2 files changed, 11 insertions, 6 deletions
diff --git a/net-analyzer/trafshow/files/trafshow-4.0-gentoo.patch b/net-analyzer/trafshow/files/trafshow-4.0-gentoo.patch
index af8454c07618..b41083becb89 100644
--- a/net-analyzer/trafshow/files/trafshow-4.0-gentoo.patch
+++ b/net-analyzer/trafshow/files/trafshow-4.0-gentoo.patch
@@ -1,10 +1,14 @@
---- Makefile.in.old 2003-12-19 22:25:28.000000000 +0900
-+++ Makefile.in 2004-08-22 19:10:32.854396336 +0900
-@@ -70,7 +70,7 @@
+--- Makefile.in.orig 2005-01-08 20:10:16.535337512 +0930
++++ Makefile.in 2005-01-08 20:11:12.594815176 +0930
+@@ -68,9 +68,9 @@
+ @echo 'char libpcap[] = "@V_PCAPVER@";' >> $@
+
install: force
- ./install-sh -c -s -m 550 -o bin -g @V_GROUP@ $(PROG) $(DESTDIR)$(BINDEST)/$(PROG)
- ./install-sh -c -m 444 -o bin -g bin $(PROG).1 $(DESTDIR)$(MANDEST)/man1/$(PROG).1
+- ./install-sh -c -s -m 550 -o bin -g @V_GROUP@ $(PROG) $(DESTDIR)$(BINDEST)/$(PROG)
+- ./install-sh -c -m 444 -o bin -g bin $(PROG).1 $(DESTDIR)$(MANDEST)/man1/$(PROG).1
- [ -f /etc/$(PROG) ] || ./install-sh -c -o root -m 644 .trafshow /etc/$(PROG)
++ ./install-sh -c -s -m 550 -o root -g @V_GROUP@ $(PROG) $(DESTDIR)$(BINDEST)/$(PROG)
++ ./install-sh -c -m 444 -o root -g bin $(PROG).1 $(DESTDIR)$(MANDEST)/man1/$(PROG).1
+ [ -f $(DESTDIR)/etc/$(PROG) ] || ./install-sh -c -o root -m 644 .trafshow $(DESTDIR)/etc/$(PROG)
clean:
diff --git a/net-analyzer/trafshow/trafshow-4.0.ebuild b/net-analyzer/trafshow/trafshow-4.0.ebuild
index 252ed46b1241..652b05d57c9b 100644
--- a/net-analyzer/trafshow/trafshow-4.0.ebuild
+++ b/net-analyzer/trafshow/trafshow-4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/trafshow/trafshow-4.0.ebuild,v 1.1 2005/01/08 10:37:31 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/trafshow/trafshow-4.0.ebuild,v 1.2 2005/01/08 10:46:54 dragonheart Exp $
inherit eutils gnuconfig
@@ -21,6 +21,7 @@ DEPEND=">=net-libs/libpcap-0.8.3
src_unpack() {
unpack ${A}
+ chown -R root:root ${S}
cd ${S}
epatch ${FILESDIR}/${P}-gentoo.patch
use ppc64 && gnuconfig_update