summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2007-12-26 17:28:52 +0000
committerPeter Volkov <pva@gentoo.org>2007-12-26 17:28:52 +0000
commit352b862961a1fdc903ec1e0e1631586bea015178 (patch)
tree6231d35da680b48491212a9dae8a7e2a9d3e32ca /net-analyzer/vnstat/vnstat-1.5.ebuild
parentamd64 stable wrt bug#202891 (diff)
downloadhistorical-352b862961a1fdc903ec1e0e1631586bea015178.tar.gz
historical-352b862961a1fdc903ec1e0e1631586bea015178.tar.bz2
historical-352b862961a1fdc903ec1e0e1631586bea015178.zip
Version bump. Thank armin76 for report. --dbdir is droped as you can do the same in configuration file.
Package-Manager: portage-2.1.3.19
Diffstat (limited to 'net-analyzer/vnstat/vnstat-1.5.ebuild')
-rw-r--r--net-analyzer/vnstat/vnstat-1.5.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/net-analyzer/vnstat/vnstat-1.5.ebuild b/net-analyzer/vnstat/vnstat-1.5.ebuild
new file mode 100644
index 000000000000..1c38773a6da7
--- /dev/null
+++ b/net-analyzer/vnstat/vnstat-1.5.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/vnstat/vnstat-1.5.ebuild,v 1.1 2007/12/26 17:28:51 pva Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Console-based network traffic monitor that keeps statistics of network usage"
+HOMEPAGE="http://humdi.net/vnstat/"
+SRC_URI="http://humdi.net/vnstat/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="virtual/cron"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "Compilation failed"
+}
+
+src_install() {
+ dobin src/vnstat || die
+ exeinto /etc/cron.hourly
+ newexe "${FILESDIR}"/vnstat.cron vnstat
+
+ insinto /etc
+ doins cfg/vnstat.conf
+
+ doman man/vnstat.1
+
+ keepdir /var/lib/vnstat
+
+ newdoc pppd/vnstat_ip-up ip-up.example
+ newdoc pppd/vnstat_ip-down ip-down.example
+ dodoc CHANGES README UPGRADE FAQ
+ newdoc INSTALL README.setup
+}
+
+pkg_postinst() {
+ # compatibility for 1.1 ebuild
+ if [[ -d ${ROOT}/var/spool/vnstat ]] ; then
+ mv -f "${ROOT}"/var/spool/vnstat/* "${ROOT}"/var/lib/vnstat/ \
+ && rmdir "${ROOT}"/var/spool/vnstat
+ elog "vnStat db files moved from /var/spool/vnstat to /var/lib/vnstat"
+ elog
+ fi
+
+ elog "Repeat the following command for every interface you"
+ elog "wish to monitor (replace eth0):"
+ elog " vnstat -u -i eth0"
+ elog
+ elog "Note: if an interface transfers more than ~4GB in"
+ elog "the time between cron runs, you may miss traffic"
+ elog
+
+ if [[ -e ${ROOT}/etc/cron.d/vnstat ]] ; then
+ elog "vnstat's cron script is now installed as /etc/cron.hourly/vnstat."
+ elog "Please remove /etc/cron.d/vnstat."
+ elog
+ else
+ elog "A cron script has been installed to /etc/cron.hourly/vnstat."
+ elog
+ fi
+ elog "To update your interface database automatically with"
+ elog "cron, uncomment the lines in /etc/cron.hourly/vnstat."
+ elog
+ elog "Starting with version 1.5 --dbdir option is droped. You can do the same"
+ elog "with DatabaseDir directive in configuration file (/etc/vnstat.conf)."
+}