summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-03-09 12:23:35 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-03-09 12:23:35 +0000
commit26e4d40ce9e54bf1bf3a5c7e3b68d42873468f33 (patch)
treef59037154019412bc07cac020aed4f3d2d80efba /net-analyzer
parentadded rules needed by >=dante-1.1.15-r1 (diff)
downloadhistorical-26e4d40ce9e54bf1bf3a5c7e3b68d42873468f33.tar.gz
historical-26e4d40ce9e54bf1bf3a5c7e3b68d42873468f33.tar.bz2
historical-26e4d40ce9e54bf1bf3a5c7e3b68d42873468f33.zip
Update postinst-en.txt for bug 83673; updated both ebuilds to use built_with_use instead of the homegrown check_with_use() function. Also fixed the dodir ${D}... tidbit which caused obvious unwanted side effects.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/cacti/ChangeLog8
-rw-r--r--net-analyzer/cacti/Manifest18
-rw-r--r--net-analyzer/cacti/cacti-0.8.6b.ebuild27
-rw-r--r--net-analyzer/cacti/cacti-0.8.6c.ebuild27
-rw-r--r--net-analyzer/cacti/files/postinstall-en.txt30
5 files changed, 33 insertions, 77 deletions
diff --git a/net-analyzer/cacti/ChangeLog b/net-analyzer/cacti/ChangeLog
index 44d48c6f066d..37725ba9abe9 100644
--- a/net-analyzer/cacti/ChangeLog
+++ b/net-analyzer/cacti/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/cacti
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.39 2005/03/05 00:13:17 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.40 2005/03/09 12:23:35 ka0ttic Exp $
+
+ 09 Mar 2005; Aaron Walker <ka0ttic@gentoo.org> files/postinstall-en.txt,
+ cacti-0.8.6b.ebuild, cacti-0.8.6c.ebuild:
+ Update postinst-en.txt for bug 83673; updated both ebuilds to use
+ built_with_use instead of the homegrown check_with_use() function. Also
+ fixed the dodir ${D}... tidbit which caused obvious unwanted side effects.
04 Mar 2005; Jason Wever <weeve@gentoo.org> cacti-0.8.6c.ebuild:
Stable on sparc.
diff --git a/net-analyzer/cacti/Manifest b/net-analyzer/cacti/Manifest
index 0be032525152..f30bef442257 100644
--- a/net-analyzer/cacti/Manifest
+++ b/net-analyzer/cacti/Manifest
@@ -1,7 +1,17 @@
-MD5 32093ec48705f136c7a7e4cff98ecc0e ChangeLog 5028
-MD5 da22e4b0386d4843dd548fcc3c9e5552 cacti-0.8.6b.ebuild 1584
-MD5 52d6e7ea7d8506b829190d5f620c0846 cacti-0.8.6c.ebuild 1578
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 f336eb6ba3c459b9b17078d8a317871a cacti-0.8.6c.ebuild 1358
+MD5 2c655694731b7e285fed83e0f3a7d069 cacti-0.8.6b.ebuild 1358
+MD5 8e598d47cdb8ef04bb623824ed32f923 ChangeLog 5369
MD5 9683bb7323c40d69b48d54ad0eb169ed metadata.xml 221
+MD5 25166aaea15b1a7bf1f6b0e212240b91 files/postinstall-en.txt 1364
MD5 5415dc0df13fd1528eb90acce7f44989 files/digest-cacti-0.8.6b 65
MD5 92214d64b7a546022d81ca37cb137262 files/digest-cacti-0.8.6c 65
-MD5 d7fa94819e0b14e84ee410d4afa7bb8f files/postinstall-en.txt 2359
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.0 (GNU/Linux)
+
+iD8DBQFCLurTEZCkKN40op4RAjTmAKCwplMtKq3JXBZQh4RfG0OUU/Y4OgCgmcBC
+MAs0gC36d8LbwaZ/fflKc20=
+=O+I7
+-----END PGP SIGNATURE-----
diff --git a/net-analyzer/cacti/cacti-0.8.6b.ebuild b/net-analyzer/cacti/cacti-0.8.6b.ebuild
index f4bb144ccfdc..9c991577a408 100644
--- a/net-analyzer/cacti/cacti-0.8.6b.ebuild
+++ b/net-analyzer/cacti/cacti-0.8.6b.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.6b.ebuild,v 1.6 2005/02/21 03:15:45 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.6b.ebuild,v 1.7 2005/03/09 12:23:35 ka0ttic Exp $
inherit eutils webapp
@@ -24,27 +24,12 @@ RDEPEND="net-www/apache
dev-php/php
dev-php/mod_php"
-check_useflag() {
- local my_pkg=$(best_version ${1})
- local my_flag=${2}
-
- if [[ $(grep -wo ${my_flag} /var/db/pkg/${my_pkg}/USE) ]]
- then
- return 0
- fi
-
- eerror "${my_pkg} was compiled without ${my_flag}. Please re-emerge it with USE=${my_flag}"
- die "check_useflag failed"
-
-}
-
pkg_setup() {
webapp_pkg_setup
-
- # Check if php, mod_php was emerged with mysql useflag
-
- check_useflag dev-php/php mysql
- check_useflag dev-php/mod_php mysql
+ built_with_use dev-php/php mysql || \
+ die "dev-php/php must be compiled with USE=mysql"
+ built_with_use dev-php/mod_php mysql || \
+ die "dev-php/mod_php must be compiled with USE=mysql"
}
src_compile() {
@@ -64,7 +49,7 @@ src_install() {
edos2unix `find -type f -name '*.php'`
- dodir ${D}${MY_HTDOCSDIR}
+ dodir ${MY_HTDOCSDIR}
cp -r . ${D}${MY_HTDOCSDIR}
webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
diff --git a/net-analyzer/cacti/cacti-0.8.6c.ebuild b/net-analyzer/cacti/cacti-0.8.6c.ebuild
index aeb921815fd3..1b6a7a06d61d 100644
--- a/net-analyzer/cacti/cacti-0.8.6c.ebuild
+++ b/net-analyzer/cacti/cacti-0.8.6c.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.6c.ebuild,v 1.4 2005/03/05 00:13:17 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.6c.ebuild,v 1.5 2005/03/09 12:23:35 ka0ttic Exp $
inherit eutils webapp
@@ -24,27 +24,12 @@ RDEPEND="net-www/apache
dev-php/php
dev-php/mod_php"
-check_useflag() {
- local my_pkg=$(best_version ${1})
- local my_flag=${2}
-
- if [[ $(grep -wo ${my_flag} /var/db/pkg/${my_pkg}/USE) ]]
- then
- return 0
- fi
-
- eerror "${my_pkg} was compiled without ${my_flag}. Please re-emerge it with USE=${my_flag}"
- die "check_useflag failed"
-
-}
-
pkg_setup() {
webapp_pkg_setup
-
- # Check if php, mod_php was emerged with mysql useflag
-
- check_useflag dev-php/php mysql
- check_useflag dev-php/mod_php mysql
+ built_with_use dev-php/php mysql || \
+ die "dev-php/php must be compiled with USE=mysql"
+ built_with_use dev-php/mod_php mysql || \
+ die "dev-php/mod_php must be compiled with USE=mysql"
}
src_compile() {
@@ -64,7 +49,7 @@ src_install() {
edos2unix `find -type f -name '*.php'`
- dodir ${D}${MY_HTDOCSDIR}
+ dodir ${MY_HTDOCSDIR}
cp -r . ${D}${MY_HTDOCSDIR}
webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
diff --git a/net-analyzer/cacti/files/postinstall-en.txt b/net-analyzer/cacti/files/postinstall-en.txt
index fb40cc298b50..787ede337029 100644
--- a/net-analyzer/cacti/files/postinstall-en.txt
+++ b/net-analyzer/cacti/files/postinstall-en.txt
@@ -22,36 +22,6 @@ New Install
Make sure to fill in all of the path variables carefully and
correctly on the following screen.
-
-Upgrading
-
-Before cacti works you must upgrade the cacti database:
-1. Backup the old cacti database:
- shell> mysqlhotcopy --suffix=_old cacti
-2. Drop the old cacti database:
- shell> mysqladmin -p drop cacti
-3. Create the new cacti database
- shell> mysqladmin --user=root create cacti
-4. Import the default cacti database:
- shell> mysql cacti < ${MY_INSTALLDIR}/cacti.sql
-5. Edit ${MY_INSTALLDIR}/include/config.php, and confirm that the MySQL user,
- password and database is correct for your cacti configuration.
-
- Example:
- \$database_default = "cacti";
- \$database_hostname = "localhost";
- \$database_username = "cactiuser";
- \$database_password = "cacti";
-
-6. Point your web browser to: http://your-server/cacti/
- Select "Upgrade".
- Make sure to fill in all of the path variables carefully and
- correctly on the following screen.
-7. Test your upgraded installation. When all is fine you can
- drop the cacti_old database like so:
- shell> mysqladmin -p drop cacti_old
-
-
Cronjob
Either new or upgrading, make sure you have a cron job - Add this line to