summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2005-09-19 21:14:25 +0000
committerAlin Năstac <mrness@gentoo.org>2005-09-19 21:14:25 +0000
commita3b4f57ffc9804f9741b02945147e63585fc15b2 (patch)
tree41accf8be78bb976af520932b7510d1e6ff4ee55 /net-dialup/diald/diald-1.0-r1.ebuild
parentversion bump to newest upstream release. wfm, and luckyduck is missing. Clos... (diff)
downloadhistorical-a3b4f57ffc9804f9741b02945147e63585fc15b2.tar.gz
historical-a3b4f57ffc9804f9741b02945147e63585fc15b2.tar.bz2
historical-a3b4f57ffc9804f9741b02945147e63585fc15b2.zip
apply patches using epatch from eutils
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'net-dialup/diald/diald-1.0-r1.ebuild')
-rw-r--r--net-dialup/diald/diald-1.0-r1.ebuild19
1 files changed, 11 insertions, 8 deletions
diff --git a/net-dialup/diald/diald-1.0-r1.ebuild b/net-dialup/diald/diald-1.0-r1.ebuild
index 73ef88b8ea8f..9f0e48005200 100644
--- a/net-dialup/diald/diald-1.0-r1.ebuild
+++ b/net-dialup/diald/diald-1.0-r1.ebuild
@@ -1,26 +1,29 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/diald/diald-1.0-r1.ebuild,v 1.8 2005/08/29 05:35:48 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/diald/diald-1.0-r1.ebuild,v 1.9 2005/09/19 21:14:25 mrness Exp $
# You need SLIP in your kernel to run diald.
+inherit eutils
+
DESCRIPTION="Daemon that provides on demand IP links via SLIP or PPP"
HOMEPAGE="http://diald.sourceforge.net"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-DEPEND="sys-libs/pam
- sys-apps/tcp-wrappers"
-RDEPEND="net-dialup/ppp"
-
SLOT="0"
LICENSE="as-is"
KEYWORDS="x86"
IUSE=""
+DEPEND="sys-libs/pam
+ sys-apps/tcp-wrappers"
+RDEPEND="net-dialup/ppp"
+
src_unpack() {
- unpack ${A} ; cd ${S}
- patch -p0 < ${FILESDIR}/${P}-c-files.patch || die
- patch -p0 < ${FILESDIR}/${P}-gentoo.patch || die
+ unpack ${A}
+
+ epatch ${FILESDIR}/${P}-c-files.patch
+ epatch ${FILESDIR}/${P}-gentoo.patch
}
src_compile() {