summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-04-06 22:49:45 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-04-06 22:49:45 +0000
commit5119f05712e1705fda83a9bf9afc0868afc27f94 (patch)
tree6312f21a0e35b7a78adeac629ee34528f4396dbb /net-dialup/mgetty
parentfix distcc/cross-compile builds; fix return bug in gcc-config script (diff)
downloadhistorical-5119f05712e1705fda83a9bf9afc0868afc27f94.tar.gz
historical-5119f05712e1705fda83a9bf9afc0868afc27f94.tar.bz2
historical-5119f05712e1705fda83a9bf9afc0868afc27f94.zip
emake->make failthrough + small ebuild syntax fixes
Diffstat (limited to 'net-dialup/mgetty')
-rw-r--r--net-dialup/mgetty/ChangeLog6
-rw-r--r--net-dialup/mgetty/files/digest-mgetty-1.1.283
-rw-r--r--net-dialup/mgetty/mgetty-1.1.28.ebuild32
3 files changed, 27 insertions, 14 deletions
diff --git a/net-dialup/mgetty/ChangeLog b/net-dialup/mgetty/ChangeLog
index 5279f63f556b..25ebb493657f 100644
--- a/net-dialup/mgetty/ChangeLog
+++ b/net-dialup/mgetty/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for net-dialup/mgetty
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/mgetty/ChangeLog,v 1.9 2003/02/12 07:53:02 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/mgetty/ChangeLog,v 1.10 2003/04/06 22:49:42 seemant Exp $
*mgetty-1.1.28 (10 Jul 2002)
+ 06 Apr 2003; Seemant Kulleen <seemant@gentoo.org> mgetty-1.1.28.ebuild:
+ emake->make failthrough, closing bug #14753 by John Sutherland
+ <garion@garion.mnbsyr.com>
+
20 Nov 2002; Daniel Ahlberg <aliz@gentoo.org> mgetty-1.1.28.ebuild :
Closes #10722.
diff --git a/net-dialup/mgetty/files/digest-mgetty-1.1.28 b/net-dialup/mgetty/files/digest-mgetty-1.1.28
index fb26853e5a50..917377f3aa47 100644
--- a/net-dialup/mgetty/files/digest-mgetty-1.1.28
+++ b/net-dialup/mgetty/files/digest-mgetty-1.1.28
@@ -1 +1,4 @@
+MD5 a1e05459ce2d5ff673bad552f355be4f /files/mgetty-1.1.28-gentoo.diff 2308
+MD5 bb8c42460c5aa951f0ac657c26d63bf9 /files/mgetty-1.1.26-gentoo.diff 324
+MD5 85278c6f6e27f5f55bad797029663c07 /mgetty-1.1.28.ebuild 2579
MD5 dc5de3eb1cf75f37e60fb94e321cdcd7 mgetty1.1.28-Jan10.tar.gz 964610
diff --git a/net-dialup/mgetty/mgetty-1.1.28.ebuild b/net-dialup/mgetty/mgetty-1.1.28.ebuild
index 85057e884f4a..90e0ef0cfab3 100644
--- a/net-dialup/mgetty/mgetty-1.1.28.ebuild
+++ b/net-dialup/mgetty/mgetty-1.1.28.ebuild
@@ -1,13 +1,17 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/mgetty/mgetty-1.1.28.ebuild,v 1.9 2003/03/11 21:11:46 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/mgetty/mgetty-1.1.28.ebuild,v 1.10 2003/04/06 22:49:42 seemant Exp $
+
+inherit flag-o-matic
S=${WORKDIR}/${P}
DESCRIPTION="Fax and Voice modem programs."
SRC_URI="ftp://alpha.greenie.net/pub/mgetty/source/1.1/${PN}${PV}-Jan10.tar.gz"
HOMEPAGE="http://alpha.greenie.net/mgetty/"
-DEPEND="app-text/tetex
+DEPEND=">=sys-apps/portage-2.0.47-r10
+ >=sys-apps/sed-4.0.5
+ app-text/tetex
sys-apps/gawk
dev-lang/perl"
@@ -15,35 +19,37 @@ SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86"
+append-flags "-DAUTO_PPP"
+
src_unpack() {
unpack ${A}
- patch -p0 < ${FILESDIR}/mgetty-${PV}-gentoo.diff || die
+ epatch ${FILESDIR}/mgetty-${PV}-gentoo.diff
cd ${S}/doc
- cp Makefile Makefile.orig
- sed -e "s:dvips -o mgetty.ps:dvips -M -o mgetty.ps:" \
- Makefile.orig >Makefile
+ sed -i "s:dvips -o mgetty.ps:dvips -M -o mgetty.ps:" Makefile
cd ${S}
sed -e 's:var/log/mgetty:var/log/mgetty/mgetty:' \
-e 's:var/log/sendfax:var/log/mgetty/sendfax:' \
- -e 's:\/\* \#define CNDFILE "dialin.config" \*\/:\#define CNDFILE "dialin.config":' \
+ -e 's:\/\* \(\#define CNDFILE "dialin.config"\) \*\/:\1:' \
-e 's:\(\#define FAX_NOTIFY_PROGRAM\).*:\1 "/etc/mgetty+sendfax/new_fax":' \
policy.h-dist > policy.h
}
src_compile() {
- mycflags="${CFLAGS} -DAUTO_PPP"
- unset CFLAGS
emake prefix=/usr \
CONFDIR=/etc/mgetty+sendfax \
- CFLAGS="${mycflags}" \
- || die
+ CFLAGS="${CFLAGS}" \
+ || make prefix=/usr \
+ CONFDIR=/etc/mgetty+sendfax \
+ CFLAGS="${CFLAGS}" \
+ || die
+
cd voice
emake CONFDIR=/etc/mgetty+sendfax \
- CFLAGS="${mycflags}" \
- || die
+ || make CONFDIR=/etc/mgetty+sendfax \
+ || die
cd ${S}
}