summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChuck Brewer <killian@gentoo.org>2003-05-23 05:55:02 +0000
committerChuck Brewer <killian@gentoo.org>2003-05-23 05:55:02 +0000
commit8cce1ac3584f1bc328d614432ee78311affdf46d (patch)
tree5d6bf9fbb73ef530fc98609a351fe7b9d8f9f460 /net-dialup
parentbaselayout takeover (diff)
downloadhistorical-8cce1ac3584f1bc328d614432ee78311affdf46d.tar.gz
historical-8cce1ac3584f1bc328d614432ee78311affdf46d.tar.bz2
historical-8cce1ac3584f1bc328d614432ee78311affdf46d.zip
new testing ebuild
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/ppp/ChangeLog7
-rw-r--r--net-dialup/ppp/Manifest4
-rw-r--r--net-dialup/ppp/files/digest-ppp-2.4.1-r141
-rw-r--r--net-dialup/ppp/ppp-2.4.1-r14.ebuild163
4 files changed, 173 insertions, 2 deletions
diff --git a/net-dialup/ppp/ChangeLog b/net-dialup/ppp/ChangeLog
index 3851017d9511..02d6503b0e0d 100644
--- a/net-dialup/ppp/ChangeLog
+++ b/net-dialup/ppp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dialup/ppp
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/ppp/ChangeLog,v 1.22 2003/05/23 05:39:17 killian Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/ppp/ChangeLog,v 1.23 2003/05/23 05:54:49 killian Exp $
+
+*ppp-2.4.1-r14 (22 May 2003)
+
+ 22 May 2003; Chuck Brewer <killian@gentoo.org> ppp-2.4.1-r14.ebuild:
+ new testing ebuild, adds pppoatm.so that should work with this build
*ppp-2.4.1-r12 (22 May 2003)
diff --git a/net-dialup/ppp/Manifest b/net-dialup/ppp/Manifest
index 7fe516fa8025..91044fd3d127 100644
--- a/net-dialup/ppp/Manifest
+++ b/net-dialup/ppp/Manifest
@@ -1,8 +1,10 @@
-MD5 14582298a71322b15e6181e37def287b ChangeLog 3829
+MD5 82b040b74127399320c4305aae497a51 ChangeLog 4004
+MD5 ae2d6b49149fbbcd69f324fff708b7da ppp-2.4.1-r14.ebuild 4424
MD5 0ed8d8e9cf25b5a4816b39a086f727f4 ppp-2.4.1-r11.ebuild 3126
MD5 e82e7badfed3b07e43e9e24350ac27f1 ppp-2.4.1-r12.ebuild 3914
MD5 303dde8eb9f6cba4ceec5bae7981869a ppp-2.4.1-r13.ebuild 4519
MD5 5f6f3203688bc5a2eceef8301f482c9f files/chat-default 344
+MD5 4fda43c2f3f8b5b58a58e5d238991c0b files/digest-ppp-2.4.1-r14 65
MD5 4fda43c2f3f8b5b58a58e5d238991c0b files/digest-ppp-2.4.1-r11 65
MD5 4fda43c2f3f8b5b58a58e5d238991c0b files/digest-ppp-2.4.1-r12 65
MD5 4fda43c2f3f8b5b58a58e5d238991c0b files/digest-ppp-2.4.1-r13 65
diff --git a/net-dialup/ppp/files/digest-ppp-2.4.1-r14 b/net-dialup/ppp/files/digest-ppp-2.4.1-r14
new file mode 100644
index 000000000000..b3c7b1676065
--- /dev/null
+++ b/net-dialup/ppp/files/digest-ppp-2.4.1-r14
@@ -0,0 +1 @@
+MD5 7f655448fbb6bebcede7a515fbcd481e ppp-2.4.1-pppoe4.tgz 556218
diff --git a/net-dialup/ppp/ppp-2.4.1-r14.ebuild b/net-dialup/ppp/ppp-2.4.1-r14.ebuild
new file mode 100644
index 000000000000..84842d2fffde
--- /dev/null
+++ b/net-dialup/ppp/ppp-2.4.1-r14.ebuild
@@ -0,0 +1,163 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+
+
+IUSE="crypt ipv6 activefilter"
+S=${WORKDIR}/${P}.pppoe4
+DESCRIPTION="Point-to-point protocol - patched for pppoe"
+SRC_URI="mirror://gentoo/${P}-pppoe4.tgz"
+HOMEPAGE="http://www.samba.org/ppp"
+
+DEPEND="virtual/glibc
+ activefilter? ( net-libs/libpcap )"
+
+PROVIDE="virtual/pppd"
+
+SLOT="0"
+LICENSE="BSD GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~hppa"
+
+src_compile() {
+
+ use crypt && {
+ #I took the liberty of combining the two crypto patches
+ einfo "Applying ppp-crypto-fix.patch..."
+ bzcat ${FILESDIR}/ppp-crypto-fix.patch.bz2 | patch -p1
+
+ }
+
+ epatch ${FILESDIR}/${P}-r10.patch
+
+ use activefilter && {
+ # enable option active-filter
+ mv pppd/Makefile.linux pppd/Makefile.linux.orig
+ sed -e 's/^#FILTER=y/FILTER=y/' <pppd/Makefile.linux.orig >pppd/Makefile.linux
+ }
+
+ ./configure --prefix=/usr || die
+
+ #fix Makefiles to compile optimized
+ cd ${S}/pppd
+ mv Makefile Makefile.orig
+ if([ `use ipv6` ]) then
+ sed -e "s:COPTS = -O2 -pipe -Wall -g:COPTS = ${CFLAGS}:" \
+ -e "s/LIBS =/LIBS = -lcrypt/" \
+ -e "s/#HAVE_INET6/HAVE_INET6/" \
+ -e "s/# CBCP_SUPPORT/CBCP_SUPPORT/" Makefile.orig > Makefile
+ else
+ sed -e "s:COPTS = -O2 -pipe -Wall -g:COPTS = ${CFLAGS}:" \
+ -e "s/LIBS =/LIBS = -lcrypt/" \
+ -e "s/# CBCP_SUPPORT/CBCP_SUPPORT/" Makefile.orig > Makefile
+ fi
+
+ cd plugins
+ mv Makefile Makefile.orig
+ sed -e "s:CFLAGS\t= -g -O2:CFLAGS = ${CFLAGS}:" \
+ Makefile.orig > Makefile
+ cd pppoe
+ mv Makefile Makefile.orig
+ sed -e "s:CFLAGS\t= -g :CFLAGS = ${CFLAGS}:" \
+ Makefile.orig > Makefile
+ cd ${S}/pppstats
+ mv Makefile Makefile.orig
+ sed -e "s:COPTS= -O:COPTS = ${CFLAGS}:" \
+ Makefile.orig > Makefile
+ cd ${S}/chat
+ mv Makefile Makefile.orig
+ sed -e "s:-O2:${CFLAGS}:" Makefile.orig > Makefile
+ cd ${S}/pppdump
+ mv Makefile Makefile.orig
+ sed -e "s:CFLAGS= -O:CFLAGS= ${CFLAGS}:" Makefile.orig > Makefile
+ cd ..
+
+ export CC=gcc
+
+ emake || die
+}
+
+src_install() {
+ for y in chat pppd pppdump pppstats
+ do
+ doman ${y}/${y}.8
+ dosbin ${y}/${y}
+ done
+
+ chmod u+s-w ${D}/usr/sbin/pppd
+ dodir /etc/ppp/peers
+ insinto /etc/ppp
+ insopts -m0600
+ doins etc.ppp/pap-secrets etc.ppp/chap-secrets
+ insopts -m0644
+ doins etc.ppp/options
+ doins ${FILESDIR}/chat-default
+ insopts -m0755
+ doins ${FILESDIR}/ip-up
+ doins ${FILESDIR}/ip-down
+ exeinto /etc/init.d/
+ doexe ${FILESDIR}/net.ppp0
+ insinto /etc/conf.d
+ insopts -m0600
+ newins ${FILESDIR}/confd.ppp0 net.ppp0
+
+ dolib.so pppd/plugins/minconn.so
+ dolib.so pppd/plugins/passprompt.so
+ dolib.so pppd/plugins/pppoe/pppoe.so
+ newlib.so ${FILESDIR}/pppoatm.so pppoatm.so
+ dodir /usr/lib/pppd/$(awk -F '"' '/VERSION/ {print $2}' pppd/patchlevel.h)
+ mv ${D}/usr/lib/*.so ${D}/usr/lib/pppd/$(awk -F '"' '/VERSION/ {print $2}' pppd/patchlevel.h)
+ insinto /etc/modules.d
+ insopts -m0644
+ newins ${FILESDIR}/modules.ppp ppp
+
+ dodoc PLUGINS README* SETUP Changes-2.3 FAQ
+ dohtml ${FILESDIR}/pppoe.html
+
+# This has nothing to do with net.ppp0 now as net.ppp0 calls pppd
+# from the command line with the parameters.
+ #New scripts acquired from cvs (cvs.samba.org)
+ #Changed $PATH back
+ dosbin ${FILESDIR}/pon
+ dosbin ${FILESDIR}/poff
+ dosbin ${FILESDIR}/plog
+ doman ${FILESDIR}/pon.1
+
+ #Adding misc. specialized scripts to doc dir
+ dodir /usr/share/doc/${PF}/scripts
+ dodir /usr/share/doc/${PF}/scripts/chatchat
+ insinto /usr/share/doc/${PF}/scripts/chatchat
+ doins scripts/chatchat/*
+ insinto /usr/share/doc/${PF}/scripts
+ doins scripts/*
+}
+
+
+pkg_postinst() {
+ if [ ! -e ${ROOT}dev/.devfsd ]
+ then
+ if [ ! -e ${ROOT}dev/ppp ]; then
+ mknod ${ROOT}dev/ppp c 108 0
+ fi
+ fi
+ if [ "$ROOT" = "/" ]
+ then
+ /sbin/update-modules
+ fi
+ ewarn "To enable kernel-pppoe read html/pppoe.html in the doc-directory."
+ ewarn "Pon, poff and plog scripts have been supplied for experienced users."
+ ewarn "New users or those requiring something more should have a look at"
+ ewarn "the /etc/init.d/net.ppp0 script."
+ ewarn "Users needing particular scripts (ssh,rsh,etc.)should check out the"
+ ewarn "/usr/share/doc/ppp*/scripts directory."
+}
+
+pkg_preinst() {
+ # Fix those broken flags (755 -> 644)
+ # This is needed for updates from ppp-2.4.1-r11 to ppp-2.4.1-r12
+ if [ -e ${ROOT}/etc/modules.d/ppp ] ; then
+ FLAGS="`stat -c %a /etc/modules.d/ppp`"
+ echo ${FLAGS}
+ if [ ${FLAGS} == "755" ] ; then
+ chmod 644 ${ROOT}/etc/modules.d/ppp
+ fi
+ fi
+}