summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2006-12-01 09:59:27 +0000
committerAlin Năstac <mrness@gentoo.org>2006-12-01 09:59:27 +0000
commitaf13eba52b7e54ac68f8c00cdf46d3d84dc553c3 (patch)
tree332327bd49f581e502b7fbd5b2b17ddc359c5d90 /net-dialup
parentPDEPEND on relevant dictionaries according to LINGUAS (diff)
downloadhistorical-af13eba52b7e54ac68f8c00cdf46d3d84dc553c3.tar.gz
historical-af13eba52b7e54ac68f8c00cdf46d3d84dc553c3.tar.bz2
historical-af13eba52b7e54ac68f8c00cdf46d3d84dc553c3.zip
Add extra slmodemd options (#156457).
Package-Manager: portage-2.1.1-r1
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/slmodem/ChangeLog9
-rw-r--r--net-dialup/slmodem/files/digest-slmodem-2.9.11_pre20051101-r36
-rw-r--r--net-dialup/slmodem/files/slmodem-confd5
-rw-r--r--net-dialup/slmodem/files/slmodem-initd7
-rw-r--r--net-dialup/slmodem/slmodem-2.9.11_pre20051101-r3.ebuild155
5 files changed, 177 insertions, 5 deletions
diff --git a/net-dialup/slmodem/ChangeLog b/net-dialup/slmodem/ChangeLog
index 7faed5096024..20e8188860aa 100644
--- a/net-dialup/slmodem/ChangeLog
+++ b/net-dialup/slmodem/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-dialup/slmodem
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/slmodem/ChangeLog,v 1.73 2006/11/18 13:57:48 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/slmodem/ChangeLog,v 1.74 2006/12/01 09:59:27 mrness Exp $
+
+*slmodem-2.9.11_pre20051101-r3 (01 Dec 2006)
+
+ 01 Dec 2006; Alin Năstac <mrness@gentoo.org> files/slmodem-confd,
+ files/slmodem-initd, -slmodem-2.9.11_pre20051101-r2.ebuild,
+ +slmodem-2.9.11_pre20051101-r3.ebuild:
+ Add extra slmodemd options (#156457).
18 Nov 2006; Alin Nastac <mrness@gentoo.org>
-files/slmodem-2.9.11-modem-cc-makefile.patch,
diff --git a/net-dialup/slmodem/files/digest-slmodem-2.9.11_pre20051101-r3 b/net-dialup/slmodem/files/digest-slmodem-2.9.11_pre20051101-r3
new file mode 100644
index 000000000000..047a97ea184a
--- /dev/null
+++ b/net-dialup/slmodem/files/digest-slmodem-2.9.11_pre20051101-r3
@@ -0,0 +1,6 @@
+MD5 56bb1ddf621b2fe26caf746aed0ac26f slmodem-2.9.11-20051101.tar.gz 833644
+RMD160 044dd97f763c68ff5c5609cb925146c5302bfb61 slmodem-2.9.11-20051101.tar.gz 833644
+SHA256 d5c456b1bab05a1606f7deaf4d5f1b9151d23377e7eb421b81082f9285de5172 slmodem-2.9.11-20051101.tar.gz 833644
+MD5 a23326976632fe7774e110cbc0636f70 ungrab-winmodem.tar.gz 1872
+RMD160 c7058f884ddf6345ddcd15c984364f4741464fbf ungrab-winmodem.tar.gz 1872
+SHA256 b9d966fa13b05876c2921f4bd030dfb151e6810958202010fab661d1689e4e11 ungrab-winmodem.tar.gz 1872
diff --git a/net-dialup/slmodem/files/slmodem-confd b/net-dialup/slmodem/files/slmodem-confd
index 873dd33871c9..a4f3bd1d692b 100644
--- a/net-dialup/slmodem/files/slmodem-confd
+++ b/net-dialup/slmodem/files/slmodem-confd
@@ -30,3 +30,8 @@ NICE=-6
# MODULE=slamr
# or
# MODULE=slusb
+
+# Include extra slmodemd options here:
+# -r = enables ring detection (needed for Hylafax faxgetty to answer)
+# -l 5 = Logging Level
+SLMODEM_OPTS=""
diff --git a/net-dialup/slmodem/files/slmodem-initd b/net-dialup/slmodem/files/slmodem-initd
index 203af28b989d..81c6eb7993a0 100644
--- a/net-dialup/slmodem/files/slmodem-initd
+++ b/net-dialup/slmodem/files/slmodem-initd
@@ -2,8 +2,7 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License, v2 or later
-if [ "${MODULE}" = "alsa" ];
-then
+if [ "${MODULE}" = "alsa" ]; then
needalsasound="alsasound"
fi
depend() {
@@ -22,7 +21,7 @@ function loadsalsa {
ebegin "Starting slmodemd for ${DEV}"
start-stop-daemon --start --background --nicelevel=${NICE} --make-pidfile \
--pidfile /var/run/slmodemd.pid --startas /usr/sbin/slmodemd \
- -- -country=${COUNTRY} -g=${GROUP} --alsa ${HW_SLOT}
+ -- -country=${COUNTRY} -g=${GROUP} ${SLMODEM_OPTS} --alsa ${HW_SLOT}
return ${?}
}
@@ -49,7 +48,7 @@ function loadsmodule {
ebegin "Starting slmodemd for ${DEV}"
start-stop-daemon --start --background --nicelevel=${NICE} --make-pidfile \
--pidfile /var/run/slmodemd.pid --startas /usr/sbin/slmodemd \
- -- -country=${COUNTRY} -g=${GROUP} ${MDEV}
+ -- -country=${COUNTRY} -g=${GROUP} ${SLMODEM_OPTS} ${MDEV}
return ${?}
}
diff --git a/net-dialup/slmodem/slmodem-2.9.11_pre20051101-r3.ebuild b/net-dialup/slmodem/slmodem-2.9.11_pre20051101-r3.ebuild
new file mode 100644
index 000000000000..fa8a7c81731a
--- /dev/null
+++ b/net-dialup/slmodem/slmodem-2.9.11_pre20051101-r3.ebuild
@@ -0,0 +1,155 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/slmodem/slmodem-2.9.11_pre20051101-r3.ebuild,v 1.1 2006/12/01 09:59:27 mrness Exp $
+
+inherit eutils linux-mod multilib
+
+DESCRIPTION="Driver for Smart Link modem"
+HOMEPAGE="http://linmodems.technion.ac.il/packages/smartlink/"
+SRC_URI="http://linmodems.technion.ac.il/packages/smartlink/${P/_pre/-}.tar.gz
+ http://linmodems.technion.ac.il/packages/smartlink/ungrab-winmodem.tar.gz"
+
+LICENSE="Smart-Link"
+SLOT="0"
+KEYWORDS="-* ~amd64 x86"
+IUSE="alsa usb"
+
+DEPEND="alsa? ( media-libs/alsa-lib )
+ amd64? ( app-emulation/emul-linux-x86-soundlibs )"
+
+QA_EXECSTACK="usr/sbin/slmodem_test usr/sbin/slmodemd"
+
+S=${WORKDIR}/${P/_pre/-}
+
+pkg_setup() {
+ use amd64 && multilib_toolchain_setup x86
+
+ MODULE_NAMES="ungrab-winmodem(:${WORKDIR}/ungrab-winmodem)"
+ if ! use amd64; then
+ MODULE_NAMES="${MODULE_NAMES} slamr(net:${S}/drivers)"
+ if use usb; then
+ MODULE_NAMES="${MODULE_NAMES} slusb(net:${S}/drivers)"
+ CONFIG_CHECK="USB"
+ fi
+ fi
+ BUILD_TARGETS="all"
+ linux-mod_pkg_setup
+ BUILD_PARAMS="KERNEL_DIR=${KV_DIR}"
+}
+
+src_unpack() {
+ unpack ${A}
+ sed -i "s:SUBDIRS=\$(shell pwd):SUBDIRS=${WORKDIR}/ungrab-winmodem:" \
+ "${WORKDIR}/ungrab-winmodem/Makefile"
+ convert_to_m "${WORKDIR}/ungrab-winmodem/Makefile"
+
+ cd "${S}"
+ epatch "${FILESDIR}/${P%%_*}-makefile.patch"
+ epatch "${FILESDIR}/${P%%_*}-kernel-2.6.18.patch"
+ cd drivers
+ sed -i "s:SUBDIRS=\$(shell pwd):SUBDIRS=${S}/drivers:" Makefile
+ convert_to_m Makefile
+ sed -i "s:.*=[ \t]*THIS_MODULE.*::" st7554.c amrmo_init.c old_st7554.c
+ sed -i 's:MODULE_PARM(\([^,]*\),"i");:module_param(\1, int, 0);:' st7554.c \
+ amrmo_init.c old_st7554.c
+}
+
+src_compile() {
+ local MAKE_PARAMS=""
+ if use alsa || use amd64; then
+ MAKE_PARAMS="SUPPORT_ALSA=1"
+ fi
+ emake ${MAKE_PARAMS} modem || die "failed to build modem"
+
+ use amd64 && multilib_toolchain_setup amd64
+ linux-mod_src_compile
+}
+
+src_install() {
+ linux-mod_src_install
+
+ cd "${S}"
+ newsbin modem/modem_test slmodem_test
+ dosbin modem/slmodemd
+ dodir /var/lib/slmodem
+ fowners root:dialout /var/lib/slmodem
+ keepdir /var/lib/slmodem
+
+ newconfd "${FILESDIR}/slmodem-confd" ${PN}
+ newinitd "${FILESDIR}/slmodem-initd" ${PN}
+
+ # configure for alsa - or not for alsa
+ if use alsa; then
+ sed -i -e "s/# MODULE=alsa/MODULE=alsa/" \
+ -e "s/# HW_SLOT=modem:1/HW_SLOT=modem:1/" "${D}/etc/conf.d/slmodem"
+ else
+ sed -i "s/# MODULE=slamr/MODULE=slamr/" "${D}/etc/conf.d/slmodem"
+ fi
+
+
+ # Add module aliases and install hotplug script
+ insinto /etc/modules.d/; newins "${FILESDIR}/slmodem-modules" ${PN}
+ if use usb; then
+ exeinto /etc/hotplug/usb; newexe "${FILESDIR}/slusb.hotplug" slusb
+ fi
+
+ dodir /etc/hotplug/blacklist.d
+ echo -e "slusb\nslamr\nsnd-intel8x0m" >> "${D}/etc/hotplug/blacklist.d/${PN}"
+
+ # Add configuration for devfs, udev
+ if [ -e "${ROOT}/dev/.devfsd" ] ; then
+ insinto /etc/devfs.d/; newins "${FILESDIR}/${PN}-2.9.devfs" ${PN}
+ elif [ -e "${ROOT}/dev/.udev" ] ; then
+ dodir /etc/udev/rules.d/
+ echo 'KERNEL=="slamr", NAME="slamr0" GROUP="dialout"' > \
+ "${D}/etc/udev/rules.d/55-${PN}.rules"
+ if use usb; then
+ echo 'KERNEL=="slusb", NAME="slusb0" GROUP="dialout"' >> \
+ "${D}/etc/udev/rules.d/55-${PN}.rules"
+ fi
+ fi
+
+ dodoc Changes README "${WORKDIR}/ungrab-winmodem/Readme.txt"
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+
+ # Make some devices if we aren't using devfs or udev
+ if [ -e "${ROOT}/dev/.devfsd" ]; then
+ ebegin "Restarting devfsd to reread devfs rules"
+ killall -HUP devfsd
+ eend $?
+
+ elif [ -e "${ROOT}/dev/.udev" ]; then
+ ebegin "Restarting udev to reread udev rules"
+ udevstart
+ eend $?
+ else
+ cd "${S}/drivers"
+ make DESTDIR="${ROOT}" install-devices
+ fi
+
+ if [ ! -e "${ROOT}/dev/ppp" ]; then
+ mknod "${ROOT}/dev/ppp" c 108 0
+ fi
+
+ ewarn "To avoid problems, slusb/slamr have been added to /etc/hotplug/blacklist"
+ einfo "You must edit /etc/conf.d/${PN} for your configuration"
+ einfo "To add slmodem to your startup - type : rc-update add slmodem default"
+
+ if use alsa; then
+ einfo "I hope you have already added alsa to your startup: "
+ einfo "otherwise type: rc-update add alsasound boot"
+ einfo
+ einfo "If you need to use snd-intel8x0m from the kernel"
+ einfo "compile it as a module and edit /etc/modules.d/alsa"
+ einfo 'to: "alias snd-card-(number) snd-intel8x0m"'
+ fi
+
+ einfo "You need to be in the uucp AND dialout group to make calls as a user."
+ einfo
+ einfo "If you see the following in dmesg:"
+ echo slamr: device 10b9:5457 is grabbed by driver serial
+ einfo "you need to modprobe ungrab-winmodem before slamr"
+}