summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2004-12-14 19:45:39 +0000
committerAlin Năstac <mrness@gentoo.org>2004-12-14 19:45:39 +0000
commitfd6ae086abf19a1deedb09ac43911de1d42f1821 (patch)
tree2273167375c2e366bfd96fe923f2c6d0c24f353f /net-dialup
parent~amd64 (diff)
downloadhistorical-fd6ae086abf19a1deedb09ac43911de1d42f1821.tar.gz
historical-fd6ae086abf19a1deedb09ac43911de1d42f1821.tar.bz2
historical-fd6ae086abf19a1deedb09ac43911de1d42f1821.zip
kernel-mod -> linux-mod
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/gigaset-isdn/ChangeLog5
-rw-r--r--net-dialup/gigaset-isdn/Manifest10
-rw-r--r--net-dialup/gigaset-isdn/gigaset-isdn-0.4.0.ebuild45
3 files changed, 36 insertions, 24 deletions
diff --git a/net-dialup/gigaset-isdn/ChangeLog b/net-dialup/gigaset-isdn/ChangeLog
index d9e179bf9ef0..e36388dbe372 100644
--- a/net-dialup/gigaset-isdn/ChangeLog
+++ b/net-dialup/gigaset-isdn/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-dialup/gigaset-isdn
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/gigaset-isdn/ChangeLog,v 1.2 2004/12/05 21:40:11 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/gigaset-isdn/ChangeLog,v 1.3 2004/12/14 19:45:39 mrness Exp $
+
+ 14 Dec 2004; Alin Nastac <mrness@gentoo.org> gigaset-isdn-0.4.0.ebuild:
+ Replaced kernel-mod eclass with linux-mod. See #74399.
05 Dec 2004; Alin Nastac <mrness@gentoo.org> gigaset-isdn-0.4.0.ebuild:
Remove inherit kernel-mod and mark stable on x86.
diff --git a/net-dialup/gigaset-isdn/Manifest b/net-dialup/gigaset-isdn/Manifest
index 052dd287a56a..186fe84c1e70 100644
--- a/net-dialup/gigaset-isdn/Manifest
+++ b/net-dialup/gigaset-isdn/Manifest
@@ -1,14 +1,14 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 e3339bb11df8c658f21cd17d2575cbc2 gigaset-isdn-0.4.0.ebuild 969
MD5 bcb8da102fb210674bba37f6ae00d38f metadata.xml 271
-MD5 059a14930a0973e0bce16c15054d8b48 ChangeLog 617
+MD5 17e591742b4e08415f6a357a3c554416 ChangeLog 749
+MD5 0962d8aad27fda9453910f01b7c8ad9c gigaset-isdn-0.4.0.ebuild 1416
MD5 a283ea44b003b4bf0c6fd0dfcb336b22 files/digest-gigaset-isdn-0.4.0 66
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.6 (GNU/Linux)
-iD8DBQFBs4BPjtv59x0+BrURAiAWAKC61xBM3Q4s48eJ7E/8iiCo8ctA2wCg0Ij6
-2Pa9odCT81AoOb+d7fgMApE=
-=n2NE
+iD8DBQFBv0MPjtv59x0+BrURApTBAKCVRJfy4cOfh9hH0FxAf17n4RKNKwCfcEnt
+B8lT4OtxF+cHBq3uSpkl+kc=
+=IbhR
-----END PGP SIGNATURE-----
diff --git a/net-dialup/gigaset-isdn/gigaset-isdn-0.4.0.ebuild b/net-dialup/gigaset-isdn/gigaset-isdn-0.4.0.ebuild
index 529a101b8a93..a20044b15ee5 100644
--- a/net-dialup/gigaset-isdn/gigaset-isdn-0.4.0.ebuild
+++ b/net-dialup/gigaset-isdn/gigaset-isdn-0.4.0.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/gigaset-isdn/gigaset-isdn-0.4.0.ebuild,v 1.2 2004/12/05 21:40:11 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/gigaset-isdn/gigaset-isdn-0.4.0.ebuild,v 1.3 2004/12/14 19:45:39 mrness Exp $
+
+inherit linux-mod
MY_P=${P/-isdn/}
S=${WORKDIR}/${MY_P}
@@ -14,26 +16,33 @@ SLOT="0"
KEYWORDS="x86"
IUSE="debug"
-src_compile() {
- cd "${S}"
- ./configure --kernel=${KV} --root=${D} --prefix=/usr \
- --with-ring `use_with debug`
-
- (
- unset ARCH
- emake || die "Compilation failed"
- )
+MODULE_NAMES="bas_gigaset(drivers/isdn:) ser_gigaset(drivers/isdn:) usb_gigaset(drivers/isdn:)"
+BUILD_TARGETS="all"
+CONFIG_CHECK="ISDN_I4L"
+ISDN_I4L_ERROR="This driver requires that your kernel is compiled with support for ISDN4Linux (I4L)"
+
+src_unpack() {
+ unpack ${A}
+
+ # Fix broken makefile
+ convert_to_m ${S}/Makefile.26.in
+
+ # We will take care of installing modules, not you
+ sed -i "s:if \[ \$\# -ne 0 \]:if \[ 0 -ne 0 \]:g" ${S}/generic/installfiles
+
+ # We will run depmod, not you
+ sed -i "s:.*generic/post.*::g" ${S}/generic/install
}
-src_install () {
- cd "${S}"
- #Disable depmod while in sandbox
- sed -i -e 's:.*depmod :#&:' generic/post
- einstall ROOT=${D} || die "Failed to install drivers"
+src_compile() {
+ ./configure --kernel=${KV_FULL} --kerneldir=${KV_DIR} --root=${D} --prefix=/usr \
+ --with-ring $(use_with debug)
- dodoc README Release.notes TODO known_bugs.txt
+ linux-mod_src_compile
}
-pkg_postinst () {
- depmod -ae ${KV}
+src_install () {
+ linux-mod_src_install
+ einstall ROOT=${D} || die "Failed to install frontend"
+ dodoc README Release.notes TODO known_bugs.txt
}