summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Portnoy <avenj@gentoo.org>2006-01-22 14:30:53 +0000
committerJon Portnoy <avenj@gentoo.org>2006-01-22 14:30:53 +0000
commit66d276615ff90a43cf84b8fdca3fd407b208c28f (patch)
treed6b8f4a84c34b22da4aabd452d5177e6698c5c27 /net-dns/dnsmasq/dnsmasq-2.26.ebuild
parentMarked ppc stable for bug #119634; Stabilize Gnome-2.12.2 (diff)
downloadhistorical-66d276615ff90a43cf84b8fdca3fd407b208c28f.tar.gz
historical-66d276615ff90a43cf84b8fdca3fd407b208c28f.tar.bz2
historical-66d276615ff90a43cf84b8fdca3fd407b208c28f.zip
Version bump to fix crash in 2.25
Package-Manager: portage-2.0.53
Diffstat (limited to 'net-dns/dnsmasq/dnsmasq-2.26.ebuild')
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.26.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-dns/dnsmasq/dnsmasq-2.26.ebuild b/net-dns/dnsmasq/dnsmasq-2.26.ebuild
new file mode 100644
index 000000000000..a12dcd22b6f3
--- /dev/null
+++ b/net-dns/dnsmasq/dnsmasq-2.26.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/dnsmasq-2.26.ebuild,v 1.1 2006/01/22 14:30:53 avenj Exp $
+
+inherit eutils toolchain-funcs
+
+MY_P="${P/_/}"
+MY_PV="${PV/_rc*/}"
+DESCRIPTION="Small forwarding DNS server"
+HOMEPAGE="http://www.thekelleys.org.uk/dnsmasq/"
+SRC_URI="http://www.thekelleys.org.uk/dnsmasq/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~s390 ~sh ~sparc ~x86 ~alpha"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-apps/portage-2.0.51"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ make \
+ PREFIX=/usr \
+ MANDIR=/usr/share/man \
+ DESTDIR="${D}" \
+ install || die
+ dodoc CHANGELOG FAQ
+ dohtml *.html
+
+ newinitd "${FILESDIR}"/dnsmasq-init dnsmasq
+ newconfd "${FILESDIR}"/dnsmasq.confd dnsmasq
+ insinto /etc
+ newins dnsmasq.conf.example dnsmasq.conf
+}