summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2005-04-25 20:25:25 +0000
committerAlin Năstac <mrness@gentoo.org>2005-04-25 20:25:25 +0000
commit790e113ab94087fe663dc87acbce23f0f851cb64 (patch)
tree2be45a424c590007d5a0fdd80dc91f10f1b13d00 /net-dns/totd
parentStable on sparc (diff)
downloadhistorical-790e113ab94087fe663dc87acbce23f0f851cb64.tar.gz
historical-790e113ab94087fe663dc87acbce23f0f851cb64.tar.bz2
historical-790e113ab94087fe663dc87acbce23f0f851cb64.zip
net-misc/totd -> net-dns/totd; version bump
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'net-dns/totd')
-rw-r--r--net-dns/totd/ChangeLog17
-rw-r--r--net-dns/totd/Manifest17
-rw-r--r--net-dns/totd/files/digest-totd-1.31
-rw-r--r--net-dns/totd/files/digest-totd-1.51
-rwxr-xr-xnet-dns/totd/files/totd39
-rw-r--r--net-dns/totd/metadata.xml9
-rw-r--r--net-dns/totd/totd-1.3.ebuild33
-rw-r--r--net-dns/totd/totd-1.5.ebuild34
8 files changed, 151 insertions, 0 deletions
diff --git a/net-dns/totd/ChangeLog b/net-dns/totd/ChangeLog
new file mode 100644
index 000000000000..b60eb33c65d1
--- /dev/null
+++ b/net-dns/totd/ChangeLog
@@ -0,0 +1,17 @@
+# ChangeLog for net-misc/totd
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/totd/ChangeLog,v 1.1 2005/04/25 20:25:25 mrness Exp $
+
+*totd-1.5 (25 Apr 2005)
+
+ 25 Apr 2005; Alin Nastac <mrness@gentoo.org> +metadata.xml,
+ +totd-1.5.ebuild:
+ Move from net-misc/totd to net-dns/totd. Version bump.
+
+*totd-1.3 (25 Jun 2003)
+
+ 25 Jun 2003; Peter Johanson <latexer@gentoo.org> totd-1.3.ebuild,
+ files/totd:
+ Initial import. Combined with net-misc/ptrtd, you can now do fun 6to4 stuff
+ easily
+
diff --git a/net-dns/totd/Manifest b/net-dns/totd/Manifest
new file mode 100644
index 000000000000..cec7856d68e0
--- /dev/null
+++ b/net-dns/totd/Manifest
@@ -0,0 +1,17 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 f2bb5b1f68316818020089ca47e51a6d totd-1.3.ebuild 839
+MD5 bcaf4d60a6429f5399a45a0974590165 ChangeLog 558
+MD5 560009d7d46941f6b7aa666ad01e37ff totd-1.5.ebuild 963
+MD5 3461f8e3858a3f7fcd05779a2a6b8f5a metadata.xml 371
+MD5 0215b0724a772565162a39729c941e8e files/totd 800
+MD5 b5d7da146bba4e657fc30595eab333b5 files/digest-totd-1.3 59
+MD5 0b7a6acb077c76ba59bac49d491dfe71 files/digest-totd-1.5 60
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.1 (GNU/Linux)
+
+iD8DBQFCbVJQjiC39V7gKu0RAnkjAKCQbrLL6PTCaP17LJetfNlhX93jigCbB+4n
+1eY57Y+0SkauLqebF+6Ap7M=
+=WlVk
+-----END PGP SIGNATURE-----
diff --git a/net-dns/totd/files/digest-totd-1.3 b/net-dns/totd/files/digest-totd-1.3
new file mode 100644
index 000000000000..ceaf3a1b4092
--- /dev/null
+++ b/net-dns/totd/files/digest-totd-1.3
@@ -0,0 +1 @@
+MD5 bc6b85a5bddb72fc3fb20fa9fe50d3a0 totd-1.3.tar.gz 82133
diff --git a/net-dns/totd/files/digest-totd-1.5 b/net-dns/totd/files/digest-totd-1.5
new file mode 100644
index 000000000000..6fd513b3aaef
--- /dev/null
+++ b/net-dns/totd/files/digest-totd-1.5
@@ -0,0 +1 @@
+MD5 b7da63fc1ea1b2e2ce959732826bc146 totd-1.5.tar.gz 237043
diff --git a/net-dns/totd/files/totd b/net-dns/totd/files/totd
new file mode 100755
index 000000000000..3cc976388883
--- /dev/null
+++ b/net-dns/totd/files/totd
@@ -0,0 +1,39 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/totd/files/totd,v 1.1 2005/04/25 20:25:25 mrness Exp $
+
+depend() {
+ need net
+}
+
+checkconfig() {
+ if [ ! -f /etc/totd.conf ]
+ then
+ eerror "The config file /etc/totd.conf does not exist."
+ return 1
+ else
+ return 0
+ fi
+}
+
+start() {
+ checkconfig || return 1
+
+ ebegin "Starting totd"
+ start-stop-daemon --start --quiet --exec /usr/sbin/totd
+ eend $?
+}
+
+stop() {
+ local pid_file
+ pid_file="`grep ^pidfile /etc/totd.conf | cut -f2 -d ' '`"
+ ebegin "Stopping totd"
+ if [ -n "$pid_file" ]
+ then
+ start-stop-daemon --stop --quiet --pidfile $pid_file
+ else
+ start-stop-daemon --stop --quiet --pidfile /var/run/totd.pid
+ fi
+ eend $?
+}
diff --git a/net-dns/totd/metadata.xml b/net-dns/totd/metadata.xml
new file mode 100644
index 000000000000..55dd82f1a5fe
--- /dev/null
+++ b/net-dns/totd/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<longdescription>
+Totd ( Trick Or Treat Daemon ) is a small DNS proxy nameserver that supports IPv6 only hosts/networks that
+communicate with the IPv4 world using some translation mechanism.
+</longdescription>
+</pkgmetadata>
diff --git a/net-dns/totd/totd-1.3.ebuild b/net-dns/totd/totd-1.3.ebuild
new file mode 100644
index 000000000000..175dbed6047c
--- /dev/null
+++ b/net-dns/totd/totd-1.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/totd/totd-1.3.ebuild,v 1.1 2005/04/25 20:25:25 mrness Exp $
+
+DESCRIPTION="Trick Or Treat Daemon, a DNS proxy for 6to4"
+HOMEPAGE="http://www.vermicelli.pasta.cs.uit.no/ipv6/software.html"
+SRC_URI="ftp://ftp.pasta.cs.uit.no/pub/Vermicelli/${P}.tar.gz"
+LICENSE="BSD as-is"
+
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=""
+
+src_compile() {
+ econf || die
+ emake || die
+}
+
+src_install() {
+ dosbin totd
+ doman totd.8
+ dodoc totd.conf.sample README INSTALL
+
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/totd
+}
+
+pkg_postinst() {
+ einfo "/usr/share/doc/${P}/totd.conf.sample.gz contains"
+ einfo "a sample config file for totd. Make sure you create"
+ einfo "/etc/totd.conf with the necessary configurations"
+}
diff --git a/net-dns/totd/totd-1.5.ebuild b/net-dns/totd/totd-1.5.ebuild
new file mode 100644
index 000000000000..5ac962f9b5e4
--- /dev/null
+++ b/net-dns/totd/totd-1.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/totd/totd-1.5.ebuild,v 1.1 2005/04/25 20:25:25 mrness Exp $
+
+DESCRIPTION="Trick Or Treat Daemon, a DNS proxy for 6to4"
+HOMEPAGE="http://www.vermicelli.pasta.cs.uit.no/ipv6/software.html"
+SRC_URI="ftp://ftp.pasta.cs.uit.no/pub/Vermicelli/${P}.tar.gz"
+LICENSE="BSD as-is"
+
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=""
+
+src_compile() {
+ econf --enable-ipv4 --enable-ipv6 --enable-stf \
+ --enable-scoped-rewrite --disable-http-server || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ dosbin totd
+ doman totd.8
+ dodoc totd.conf.sample README INSTALL
+
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/totd
+}
+
+pkg_postinst() {
+ einfo "/usr/share/doc/${P}/totd.conf.sample.gz contains"
+ einfo "a sample config file for totd. Make sure you create"
+ einfo "/etc/totd.conf with the necessary configurations"
+}