summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-02-24 07:46:50 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-02-24 07:46:50 +0000
commit2d1a1b217550418e9c8600acc854baa8f7f659fa (patch)
tree62e6c8873acaf8d051ac6efade042bc7fd315675 /net-dns
parentCompile problem fixed, see bug #13244 (diff)
downloadhistorical-2d1a1b217550418e9c8600acc854baa8f7f659fa.tar.gz
historical-2d1a1b217550418e9c8600acc854baa8f7f659fa.tar.bz2
historical-2d1a1b217550418e9c8600acc854baa8f7f659fa.zip
filter-flags in src_unpack; header fix
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/hesiod/Manifest12
-rw-r--r--net-dns/hesiod/hesiod-3.0.2-r1.ebuild5
-rw-r--r--net-dns/hesiod/hesiod-3.0.2.ebuild8
3 files changed, 14 insertions, 11 deletions
diff --git a/net-dns/hesiod/Manifest b/net-dns/hesiod/Manifest
index 1a2829fb28f2..3456590dd036 100644
--- a/net-dns/hesiod/Manifest
+++ b/net-dns/hesiod/Manifest
@@ -1,9 +1,9 @@
-MD5 dcb9c048fd9e5f4b3a5bdaf6cfee0801 hesiod-3.0.2.ebuild 1582
-MD5 30c1105fc1f037d97d0dfae4f4f0e065 files/hesiod-3.0.2-str.patch 2039
-MD5 6730c597da6926a28d780afaf5c0109d files/digest-hesiod-3.0.2-r1 63
+MD5 76825e98357376c426f8ca591759d900 ChangeLog 1842
+MD5 d7febcaee10606a5c03a28193f16b325 hesiod-3.0.2.ebuild 1590
+MD5 ebe50e207feb3f648c41eafbfc2774ac hesiod-3.0.2-r1.ebuild 1297
MD5 6730c597da6926a28d780afaf5c0109d files/digest-hesiod-3.0.2 63
+MD5 f7cf5631651df4137ae6d25e3641160e files/hesiod-3.0.2-env.patch 896
MD5 ab2c3c431e03ef4d4fb4582e5f8579a2 files/hesiod-3.0.2-shlib.patch 1767
+MD5 30c1105fc1f037d97d0dfae4f4f0e065 files/hesiod-3.0.2-str.patch 2039
+MD5 6730c597da6926a28d780afaf5c0109d files/digest-hesiod-3.0.2-r1 63
MD5 e8b9918c46f98913bbc59dff6e942552 files/hesiod-3.0.2-redhat.patch.gz 2640
-MD5 f7cf5631651df4137ae6d25e3641160e files/hesiod-3.0.2-env.patch 896
-MD5 76825e98357376c426f8ca591759d900 ChangeLog 1842
-MD5 0f6611915ec111c0bab2996c29e1292c hesiod-3.0.2-r1.ebuild 1292
diff --git a/net-dns/hesiod/hesiod-3.0.2-r1.ebuild b/net-dns/hesiod/hesiod-3.0.2-r1.ebuild
index c89c3e77fe6c..78cc97261157 100644
--- a/net-dns/hesiod/hesiod-3.0.2-r1.ebuild
+++ b/net-dns/hesiod/hesiod-3.0.2-r1.ebuild
@@ -1,9 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/hesiod/hesiod-3.0.2-r1.ebuild,v 1.4 2004/02/05 03:03:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/hesiod/hesiod-3.0.2-r1.ebuild,v 1.5 2004/02/24 07:46:50 mr_bones_ Exp $
inherit flag-o-matic eutils
-filter-flags -fstack-protector
DESCRIPTION="system which uses existing DNS functionality to provide access to databases of information that changes infrequently"
HOMEPAGE="ftp://athena-dist.mit.edu/pub/ATHENA/hesiod"
@@ -19,6 +18,8 @@ src_unpack() {
unpack ${A}
cd ${S}
+ filter-flags -fstack-protector
+
#Patches stolen from RH
epatch ${FILESDIR}/hesiod-${PV}-redhat.patch.gz
autoconf || die "autoconf failed"
diff --git a/net-dns/hesiod/hesiod-3.0.2.ebuild b/net-dns/hesiod/hesiod-3.0.2.ebuild
index 9d538dd31224..9b181663b44e 100644
--- a/net-dns/hesiod/hesiod-3.0.2.ebuild
+++ b/net-dns/hesiod/hesiod-3.0.2.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/hesiod/hesiod-3.0.2.ebuild,v 1.8 2003/09/07 16:30:26 iggy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/hesiod/hesiod-3.0.2.ebuild,v 1.9 2004/02/24 07:46:50 mr_bones_ Exp $
inherit flag-o-matic
-filter-flags -fstack-protector
S=${WORKDIR}/${P}
DESCRIPTION="Hesiod is a system which uses existing DNS functionality to provide access to databases of information that changes infrequently."
@@ -19,6 +18,9 @@ DEPEND="virtual/glibc"
src_unpack() {
unpack ${A}
+
+ filter-flags -fstack-protector
+
#Patches stolen from RH
cat ${FILESDIR}/hesiod-3.0.2-shlib.patch | patch -d ${S} -p1
cat ${FILESDIR}/hesiod-3.0.2-env.patch | patch -d ${S} -p1