summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-02-24 18:52:27 +0000
committerPeter Volkov <pva@gentoo.org>2008-02-24 18:52:27 +0000
commitd11442b39acdf5cdf128d9caa45fb8d176d5b095 (patch)
treedbcd11371eff88017c5ebaea9da207fdbfe1b233 /net-firewall
parentUnmask linuxwacom. (diff)
downloadhistorical-d11442b39acdf5cdf128d9caa45fb8d176d5b095.tar.gz
historical-d11442b39acdf5cdf128d9caa45fb8d176d5b095.tar.bz2
historical-d11442b39acdf5cdf128d9caa45fb8d176d5b095.zip
Version bump, bug 211191. Thank Vieri <rentorbuy AT yahoo.com> for all work!
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/shorewall-common/ChangeLog7
-rw-r--r--net-firewall/shorewall-common/shorewall-common-4.0.9.ebuild101
-rw-r--r--net-firewall/shorewall-lite/ChangeLog7
-rw-r--r--net-firewall/shorewall-lite/shorewall-lite-4.0.9.ebuild63
-rw-r--r--net-firewall/shorewall-perl/ChangeLog7
-rw-r--r--net-firewall/shorewall-perl/shorewall-perl-4.0.9.ebuild53
-rw-r--r--net-firewall/shorewall-shell/ChangeLog7
-rw-r--r--net-firewall/shorewall-shell/shorewall-shell-4.0.9.ebuild52
8 files changed, 293 insertions, 4 deletions
diff --git a/net-firewall/shorewall-common/ChangeLog b/net-firewall/shorewall-common/ChangeLog
index 3eb6b332a936..e034babf5ca9 100644
--- a/net-firewall/shorewall-common/ChangeLog
+++ b/net-firewall/shorewall-common/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-firewall/shorewall-common
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-common/ChangeLog,v 1.9 2008/01/27 19:19:50 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-common/ChangeLog,v 1.10 2008/02/24 18:46:36 pva Exp $
+
+*shorewall-common-4.0.9 (24 Feb 2008)
+
+ 24 Feb 2008; <pva@gentoo.org> +shorewall-common-4.0.9.ebuild:
+ Version bump, bug 211191. Thank Vieri <rentorbuy AT yahoo.com> for all work!
*shorewall-common-4.0.8 (27 Jan 2008)
diff --git a/net-firewall/shorewall-common/shorewall-common-4.0.9.ebuild b/net-firewall/shorewall-common/shorewall-common-4.0.9.ebuild
new file mode 100644
index 000000000000..dcfcef3b4e9f
--- /dev/null
+++ b/net-firewall/shorewall-common/shorewall-common-4.0.9.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-common/shorewall-common-4.0.9.ebuild,v 1.1 2008/02/24 18:46:36 pva Exp $
+
+inherit eutils
+
+# Choose between experimental, stable and beta:
+#MY_P_TREE="development/4.0" # experimental and beta
+MY_P_TREE="4.0" # stable
+#MY_P_BETA="-RC1" # only beta and RC
+MY_P_BETA="" # stable or experimental
+
+MY_P="${P/-common/}${MY_P_BETA}"
+MY_PN="${PN/-common/}"
+
+MY_P_DOCS="${MY_P/${MY_PN}/${MY_PN}-docs-html}"
+
+DESCRIPTION="Shoreline Firewall is an iptables-based firewall for Linux."
+HOMEPAGE="http://www.shorewall.net/"
+SRC_URI="http://www1.shorewall.net/pub/${MY_PN}/${MY_P_TREE}/${MY_P}/${P}${MY_P_BETA}.tar.bz2
+ doc? ( http://www1.shorewall.net/pub/${MY_PN}/${MY_P_TREE}/${MY_P}/${MY_P_DOCS}.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+DEPEND=">=net-firewall/iptables-1.2.4
+ sys-apps/iproute2
+ ~net-firewall/shorewall-shell-${PV}
+ !<net-firewall/shorewall-4.0"
+
+pkg_setup() {
+ if built_with_use sys-apps/iproute2 minimal; then
+ die "Shorewall requires sys-apps/iproute2 to be built without the \"minimal\" USE flag."
+ fi
+}
+
+src_compile() {
+ einfo "Nothing to compile."
+}
+
+src_install() {
+ keepdir /var/lib/shorewall
+
+ cd "${WORKDIR}/${P}${MY_P_BETA}"
+ PREFIX="${D}" ./install.sh || die "install.sh failed"
+ newinitd "${FILESDIR}"/shorewall.initd shorewall || die "doinitd failed"
+
+ dodoc changelog.txt releasenotes.txt
+ if use doc; then
+ cd "${WORKDIR}/${MY_P_DOCS}"
+ # install documentation
+ dohtml -r *
+ ## dosym Documentation_Index.html "/usr/share/doc/${PF}/html/index.htm"
+ # install samples
+ cp -pR "${S}${MY_P_BETA}/Samples" "${D}/usr/share/doc/${PF}"
+ fi
+}
+
+pkg_postinst() {
+ elog
+ if use doc ; then
+ elog "Documentation is available at /usr/share/doc/${PF}/html."
+ elog "Please read the Release Notes in /usr/share/doc/${PF}."
+ elog "Samples are available at /usr/share/doc/${PF}/Samples."
+ else
+ elog "Documentation is available at http://www.shorewall.net"
+ fi
+ elog "There are man pages for shorewall(8) and for each configuration file."
+ elog
+ elog "Bridging configuration has changed with kernel 2.6.20+."
+ elog "Check the documentation."
+ elog
+ elog "Do not blindly start shorewall, edit the files in /etc/shorewall first"
+ elog "At the very least, you must change 'STARTUP_ENABLED' in shorewall.conf"
+ elog
+ elog "Be aware that version ${MY_P_TREE} differs substantially from previous releases."
+ elog "Information on upgrading is available at:"
+ elog "http://www.shorewall.net/upgrade_issues.htm"
+ elog
+ elog "There is a 'shorewall compile' command to generate scripts to run"
+ elog "on systems with Shorewall Lite installed."
+ elog "Please refer to http://www.shorewall.net/CompiledPrograms.html"
+ elog "It is advised to copy the /usr/share/shorewall/configfiles dir to your"
+ elog "own 'export directories'. However, whenever you upgrade Shorewall you"
+ elog "should check for changes in configfiles and manually update your exports."
+ elog "Alternatively, if you only have one Shorewall-Lite system in your network"
+ elog "then you can use the configfiles dir but set CONFIG_PROTECT appropriately"
+ elog "in /etc/make.conf (man make.conf)."
+ elog
+ elog "Known problems:"
+ elog "http://shorewall.net/pub/${MY_PN}/${MY_P_TREE}/${MY_P}/known_problems.txt"
+ elog
+ elog "Whether upgrading or installing you should run shorewall check,"
+ elog "correct any errors found and run shorewall restart|start."
+ elog
+ elog "${PN} requires a compiler."
+ elog "You can choose to emerge shorewall-shell and/or shorewall-perl."
+ elog "As of ${PV} shorewall-shell is mandatory."
+}
diff --git a/net-firewall/shorewall-lite/ChangeLog b/net-firewall/shorewall-lite/ChangeLog
index 6e7720bb7ba8..5ab6b745ceff 100644
--- a/net-firewall/shorewall-lite/ChangeLog
+++ b/net-firewall/shorewall-lite/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-firewall/shorewall-lite
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-lite/ChangeLog,v 1.27 2008/01/27 19:20:28 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-lite/ChangeLog,v 1.28 2008/02/24 18:52:27 pva Exp $
+
+*shorewall-lite-4.0.9 (24 Feb 2008)
+
+ 24 Feb 2008; <pva@gentoo.org> +shorewall-lite-4.0.9.ebuild:
+ Version bump, bug 211191. Thank Vieri <rentorbuy AT yahoo.com> for all work!
*shorewall-lite-4.0.8 (27 Jan 2008)
diff --git a/net-firewall/shorewall-lite/shorewall-lite-4.0.9.ebuild b/net-firewall/shorewall-lite/shorewall-lite-4.0.9.ebuild
new file mode 100644
index 000000000000..762b6da26475
--- /dev/null
+++ b/net-firewall/shorewall-lite/shorewall-lite-4.0.9.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-lite/shorewall-lite-4.0.9.ebuild,v 1.1 2008/02/24 18:52:27 pva Exp $
+
+# Choose between experimental, stable and beta:
+#MY_P_TREE="development/4.0" # experimental and beta
+MY_P_TREE="4.0" # stable
+#MY_P_BETA="-Beta7" # only beta
+MY_P_BETA="" # stable or experimental
+
+MY_P_DOCS="${P/${PN}/shorewall-docs-html}"
+
+MY_P="shorewall-${PV}"
+
+DESCRIPTION="An iptables-based firewall whose config is handled by a normal Shorewall."
+HOMEPAGE="http://www.shorewall.net/"
+SRC_URI="http://www1.shorewall.net/pub/shorewall/${MY_P_TREE}/${MY_P}${MY_P_BETA}/${P}${MY_P_BETA}.tar.bz2
+ doc? ( http://www1.shorewall.net/pub/shorewall/${MY_P_TREE}/${MY_P}${MY_P_BETA}/${MY_P_DOCS}${MY_P_BETA}.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+DEPEND="net-firewall/iptables
+ sys-apps/iproute2"
+
+src_compile() {
+ einfo "Nothing to compile."
+}
+
+src_install() {
+ keepdir /var/lib/shorewall-lite
+
+ cd "${WORKDIR}/${P}${MY_P_BETA}"
+ PREFIX="${D}" ./install.sh || die "install.sh failed"
+ newinitd "${FILESDIR}/shorewall-lite" shorewall-lite
+
+ dodoc changelog.txt releasenotes.txt
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Documentation is available at http://www.shorewall.net"
+ einfo "There are man pages for shorewall-lite(8) and for each"
+ einfo "configuration file."
+ einfo
+ einfo "You should have already generated a firewall script with"
+ einfo "'shorewall compile' on the administrative Shorewall."
+ einfo "Please refer to"
+ einfo "http://www.shorewall.net/CompiledPrograms.html"
+ einfo
+ einfo "If you intend to use the 2.6 IPSEC Support, you must retrieve the"
+ einfo "kernel patches from http://shorewall.net/pub/shorewall/contrib/IPSEC/"
+ einfo "or install kernel 2.6.16+ as well as a recent Netfilter iptables"
+ einfo "and compile it with support for policy match."
+ einfo
+ einfo "Note that /etc/shorewall-lite/shorewall.conf has been renamed"
+ einfo "to /etc/shorewall-lite/shorewall-lite.conf"
+ einfo
+ einfo "Known problems:"
+ einfo "http://shorewall.net/pub/shorewall/${MY_P_TREE}/${MY_P}${MY_P_BETA}/known_problems.txt"
+}
diff --git a/net-firewall/shorewall-perl/ChangeLog b/net-firewall/shorewall-perl/ChangeLog
index afc89845ada2..002f79141be0 100644
--- a/net-firewall/shorewall-perl/ChangeLog
+++ b/net-firewall/shorewall-perl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-firewall/shorewall-perl
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-perl/ChangeLog,v 1.10 2008/01/27 19:21:00 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-perl/ChangeLog,v 1.11 2008/02/24 18:49:27 pva Exp $
+
+*shorewall-perl-4.0.9 (24 Feb 2008)
+
+ 24 Feb 2008; <pva@gentoo.org> +shorewall-perl-4.0.9.ebuild:
+ Version bump, bug 211191. Thank Vieri <rentorbuy AT yahoo.com> for all work!
*shorewall-perl-4.0.8 (27 Jan 2008)
diff --git a/net-firewall/shorewall-perl/shorewall-perl-4.0.9.ebuild b/net-firewall/shorewall-perl/shorewall-perl-4.0.9.ebuild
new file mode 100644
index 000000000000..614aeb7d223d
--- /dev/null
+++ b/net-firewall/shorewall-perl/shorewall-perl-4.0.9.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-perl/shorewall-perl-4.0.9.ebuild,v 1.1 2008/02/24 18:49:27 pva Exp $
+
+# Choose between experimental, stable and beta:
+#MY_P_TREE="development/4.0" # experimental and beta
+MY_P_TREE="4.0" # stable
+#MY_P_BETA="-Beta7" # only beta
+MY_P_BETA="" # stable or experimental
+
+MY_P="shorewall-${PV}"
+
+DESCRIPTION="Shoreline Firewall Perl-based compiler that allows faster compilation and execution."
+HOMEPAGE="http://www.shorewall.net/"
+SRC_URI="http://www1.shorewall.net/pub/shorewall/${MY_P_TREE}/${MY_P}${MY_P_BETA}/${P}${MY_P_BETA}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="net-firewall/iptables
+ sys-apps/iproute2
+ dev-lang/perl
+ !<net-firewall/shorewall-4.0"
+
+PDEPEND="~net-firewall/shorewall-common-${PV}"
+
+src_compile() {
+ einfo "Nothing to compile."
+}
+
+src_install() {
+ cd "${WORKDIR}/${P}${MY_P_BETA}"
+ PREFIX="${D}" ./install.sh || die "install.sh failed"
+
+ dodoc releasenotes.txt
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Documentation is available at http://www.shorewall.net"
+ einfo
+ einfo "In order to use the Perl compiler you need to add"
+ einfo "SHOREWALL_COMPILER=perl"
+ einfo "to shorewall.conf"
+ einfo
+ einfo "Please read the included release notes for more information."
+ einfo
+ einfo "Known problems:"
+ einfo "http://www1.shorewall.net/pub/shorewall/${MY_P_TREE}/${MY_P}${MY_P_BETA}/known_problems.txt"
+ einfo
+}
diff --git a/net-firewall/shorewall-shell/ChangeLog b/net-firewall/shorewall-shell/ChangeLog
index d942c123f3bc..9360025f4efa 100644
--- a/net-firewall/shorewall-shell/ChangeLog
+++ b/net-firewall/shorewall-shell/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-firewall/shorewall-shell
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-shell/ChangeLog,v 1.8 2008/01/27 19:21:29 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-shell/ChangeLog,v 1.9 2008/02/24 18:45:36 pva Exp $
+
+*shorewall-shell-4.0.9 (24 Feb 2008)
+
+ 24 Feb 2008; <pva@gentoo.org> +shorewall-shell-4.0.9.ebuild:
+ Version bump, bug 211191. Thank Vieri <rentorbuy AT yahoo.com> for all work!
*shorewall-shell-4.0.8 (27 Jan 2008)
diff --git a/net-firewall/shorewall-shell/shorewall-shell-4.0.9.ebuild b/net-firewall/shorewall-shell/shorewall-shell-4.0.9.ebuild
new file mode 100644
index 000000000000..052a73eb3e44
--- /dev/null
+++ b/net-firewall/shorewall-shell/shorewall-shell-4.0.9.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-shell/shorewall-shell-4.0.9.ebuild,v 1.1 2008/02/24 18:45:36 pva Exp $
+
+# Choose between experimental, stable and beta:
+#MY_P_TREE="development/4.0" # experimental and beta
+MY_P_TREE="4.0" # stable
+#MY_P_BETA="-Beta7" # only beta
+MY_P_BETA="" # stable or experimental
+
+MY_P="shorewall-${PV}"
+
+DESCRIPTION="Shoreline Firewall shell-based compiler."
+HOMEPAGE="http://www.shorewall.net/"
+SRC_URI="http://www1.shorewall.net/pub/shorewall/${MY_P_TREE}/${MY_P}${MY_P_BETA}/${P}${MY_P_BETA}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="net-firewall/iptables
+ sys-apps/iproute2
+ !<net-firewall/shorewall-4.0"
+
+PDEPEND="~net-firewall/shorewall-common-${PV}"
+
+src_compile() {
+ einfo "Nothing to compile."
+}
+
+src_install() {
+ cd "${WORKDIR}/${P}${MY_P_BETA}"
+ PREFIX="${D}" ./install.sh || die "install.sh failed"
+
+ dodoc releasenotes.txt
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Documentation is available at http://www.shorewall.net"
+ einfo
+ einfo "In order to use the shell compiler you need to add"
+ einfo "SHOREWALL_COMPILER=shell"
+ einfo "to shorewall.conf"
+ einfo
+ einfo "Please read the included release notes for more information."
+ einfo
+ einfo "Known problems:"
+ einfo "http://www1.shorewall.net/pub/shorewall/${MY_P_TREE}/${MY_P}${MY_P_BETA}/known_problems.txt"
+ einfo
+}