summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2009-02-27 14:21:02 +0000
committerRaúl Porcel <armin76@gentoo.org>2009-02-27 14:21:02 +0000
commita2a8c52dbf14a2abe6884b8c8fb784de04939817 (patch)
treef8d8c2e78051270a799c01d998c230195c6cdc59 /net-ftp/tftp-hpa/tftp-hpa-0.49-r1.ebuild
parentSparc stable, Bug #259936. (diff)
downloadhistorical-a2a8c52dbf14a2abe6884b8c8fb784de04939817.tar.gz
historical-a2a8c52dbf14a2abe6884b8c8fb784de04939817.tar.bz2
historical-a2a8c52dbf14a2abe6884b8c8fb784de04939817.zip
Revbump to add ipv6 USE-flag, bug #253422
Package-Manager: portage-2.1.6.7/cvs/Linux i686
Diffstat (limited to 'net-ftp/tftp-hpa/tftp-hpa-0.49-r1.ebuild')
-rw-r--r--net-ftp/tftp-hpa/tftp-hpa-0.49-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-ftp/tftp-hpa/tftp-hpa-0.49-r1.ebuild b/net-ftp/tftp-hpa/tftp-hpa-0.49-r1.ebuild
new file mode 100644
index 000000000000..f200d8a58ad3
--- /dev/null
+++ b/net-ftp/tftp-hpa/tftp-hpa-0.49-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/tftp-hpa/tftp-hpa-0.49-r1.ebuild,v 1.1 2009/02/27 14:21:02 armin76 Exp $
+
+DESCRIPTION="port of the OpenBSD TFTP server"
+HOMEPAGE="http://www.kernel.org/pub/software/network/tftp/"
+SRC_URI="mirror://kernel/software/network/tftp/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="ipv6 readline selinux tcpd"
+
+DEPEND="readline? ( sys-libs/readline )
+ tcpd? ( sys-apps/tcp-wrappers )
+ selinux? ( sec-policy/selinux-tftpd )
+ !virtual/tftp"
+PROVIDE="virtual/tftp"
+
+src_compile() {
+ econf \
+ $(use_with ipv6) \
+ $(use_with tcpd tcpwrappers) \
+ $(use_with readline) \
+ || die
+ emake || die
+}
+
+src_install() {
+ emake INSTALLROOT="${D}" install || die
+ dodoc README* CHANGES tftpd/sample.rules
+
+ # iputils installs this
+ rm -f "${D}"/usr/share/man/man8/tftpd.8
+
+ newconfd "${FILESDIR}"/in.tftpd.confd-0.44 in.tftpd
+ newinitd "${FILESDIR}"/in.tftpd.rc6 in.tftpd
+}
+
+pkg_postinst() {
+ ewarn "After installation, please ensure you look at"
+ ewarn "/etc/conf.d/in.tftpd and set the correct path"
+ ewarn "for your application."
+}