summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2005-10-04 09:32:49 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2005-10-04 09:32:49 +0000
commitb1b217cb37295c10403e577ef7990e11ac09d631 (patch)
treec2778486d5b87d3e5b9880a356c75f9ee401c06a /net-ftp/weex/weex-2.6.1.5-r1.ebuild
parentAdd dependency on glib. (diff)
downloadhistorical-b1b217cb37295c10403e577ef7990e11ac09d631.tar.gz
historical-b1b217cb37295c10403e577ef7990e11ac09d631.tar.bz2
historical-b1b217cb37295c10403e577ef7990e11ac09d631.zip
Security fix, see bug #107849
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'net-ftp/weex/weex-2.6.1.5-r1.ebuild')
-rw-r--r--net-ftp/weex/weex-2.6.1.5-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-ftp/weex/weex-2.6.1.5-r1.ebuild b/net-ftp/weex/weex-2.6.1.5-r1.ebuild
new file mode 100644
index 000000000000..67814a9fc473
--- /dev/null
+++ b/net-ftp/weex/weex-2.6.1.5-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/weex/weex-2.6.1.5-r1.ebuild,v 1.1 2005/10/04 09:32:49 phosphan Exp $
+
+inherit eutils
+
+DESCRIPTION="Automates maintaining a web page or other FTP archive."
+HOMEPAGE="http://weex.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="nls"
+
+DEPEND="sys-libs/ncurses"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-va_list.patch"
+ epatch "${FILESDIR}/formatstring.patch"
+}
+
+src_compile() {
+ econf $(use_enable nls) || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die
+ dodoc doc/TODO* doc/README* doc/FAQ* doc/sample* doc/ChangeLog* \
+ doc/BUG* doc/THANK*
+}