summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorGustavo Felisberto <humpback@gentoo.org>2004-06-24 16:47:56 +0000
committerGustavo Felisberto <humpback@gentoo.org>2004-06-24 16:47:56 +0000
commitb5eaf187e896bed439046e7674211dda3f9498e8 (patch)
treed25f5f586f8f0b2256ddf157d3e426973c3fe3f6 /net-im
parentFix build with 2.6 headers. Closes bug #54999. (diff)
downloadhistorical-b5eaf187e896bed439046e7674211dda3f9498e8.tar.gz
historical-b5eaf187e896bed439046e7674211dda3f9498e8.tar.bz2
historical-b5eaf187e896bed439046e7674211dda3f9498e8.zip
changed from nofetch to nomirror
Diffstat (limited to 'net-im')
-rw-r--r--net-im/skype/ChangeLog7
-rw-r--r--net-im/skype/Manifest4
-rw-r--r--net-im/skype/skype-0.90.0.4.ebuild27
3 files changed, 17 insertions, 21 deletions
diff --git a/net-im/skype/ChangeLog b/net-im/skype/ChangeLog
index 30009837f55e..c513c4aea031 100644
--- a/net-im/skype/ChangeLog
+++ b/net-im/skype/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/skype
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/skype/ChangeLog,v 1.4 2004/06/24 13:59:24 humpback Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/skype/ChangeLog,v 1.5 2004/06/24 16:47:56 humpback Exp $
+
+ 24 Jun 2004; Gustavo Felisberto <humpback@gentoo.org>;
+ skype-0.90.0.4.ebuild:
+ Changed the make_desktop_entry and made the package nomirror because we can:
+ http://forum.skype.com/bb/viewtopic.php?t=4051
*skype-0.90.0.4 (24 Jun 2004)
diff --git a/net-im/skype/Manifest b/net-im/skype/Manifest
index ce4b25c0985a..639291862ed3 100644
--- a/net-im/skype/Manifest
+++ b/net-im/skype/Manifest
@@ -1,5 +1,5 @@
MD5 f05eba693923cfb1455383da06536323 metadata.xml 492
-MD5 88c6c0c6890174938e1cd06d371b2bd1 ChangeLog 988
-MD5 dc0f30220dc26c47fe759e42840c05c9 skype-0.90.0.4.ebuild 1970
+MD5 5c54eae76c3501c4229e3b53fa7e31d9 ChangeLog 1199
+MD5 563f42580648681315044ec10006d0b7 skype-0.90.0.4.ebuild 1803
MD5 88f7b71eada401aa0cbb0626b83a2d02 files/digest-skype-0.90.0.4 153
MD5 09e9a966baffc32faad3097fd678820e files/sDaemonWrapper 995
diff --git a/net-im/skype/skype-0.90.0.4.ebuild b/net-im/skype/skype-0.90.0.4.ebuild
index 449859b01d2e..82fefa04a338 100644
--- a/net-im/skype/skype-0.90.0.4.ebuild
+++ b/net-im/skype/skype-0.90.0.4.ebuild
@@ -1,16 +1,16 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/skype/skype-0.90.0.4.ebuild,v 1.1 2004/06/24 13:59:24 humpback Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/skype/skype-0.90.0.4.ebuild,v 1.2 2004/06/24 16:47:56 humpback Exp $
inherit eutils
SVER=${PV//./_}
-RESTRICT="fetch"
+RESTRICT="nomirror"
DESCRIPTION="${PN} is a P2P-VoiceIP client."
HOMEPAGE="http://www.${PN}.com/"
SRC_URI="
- qt? ( ${PN}_ver-${SVER}.tar.bz2 )
- !qt? ( ${PN}_ver-${SVER}-staticQT.tar.bz2 )"
+ qt? ( http://download.skype.com/linux/${PN}_ver-${SVER}.tar.bz2 )
+ !qt? ( http://download.skype.com/linux/${PN}_ver-${SVER}-staticQT.tar.bz2 )"
LICENSE="skype-eula"
SLOT="0"
KEYWORDS="~x86"
@@ -19,19 +19,6 @@ DEPEND="qt? ( >=x11-libs/qt-3.2 )
>=sys-libs/glibc-2.2.5"
S="${WORKDIR}/${PN}_ver-${SVER}"
-pkg_nofetch() {
- einfo "Please go to http://www.skype.com/download_linux.html and download"
- if use !qt;
- then
- einfo "the static binary tar.bz2"
- else
- einfo "the dynamic binary tar.bz2"
- fi
- einfo "and copy it to ${DISTDIR}"
- einfo ""
- einfo "Have a look at ${PORTDIR}/licenses/${LICENSE} before running this software"
-}
-
src_unpack() {
if use !qt;
then
@@ -60,7 +47,7 @@ src_install() {
( use arts || use esd ) && doexe skype.bin
insinto /opt/skype
doins call_in.wav
- make_desktop_entry skype "Skype VoIP" ../icons/hicolor/48x48/apps/skype.png "Telephony"
+ make_desktop_entry skype "Skype VoIP" ../icons/hicolor/49x48/apps/skype.png
for SIZE in 16 24 32 48
do
mkdir ${S}/icons/${SIZE}
@@ -74,3 +61,7 @@ src_install() {
dodir /usr/bin/
dosym /opt/skype/skype /usr/bin/skype
}
+
+pkg_postinst() {
+ einfo "Have a look at ${PORTDIR}/licenses/${LICENSE} before running this software"
+}