summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2004-02-28 21:50:03 +0000
committerAlastair Tse <liquidx@gentoo.org>2004-02-28 21:50:03 +0000
commit700cb79a688bf5b710e67afcfb1961a000656f53 (patch)
tree9019746dc8023def8f8613fcdad219f7af7b5cca /net-irc
parentMarked stable on alpha and x86 (diff)
downloadhistorical-700cb79a688bf5b710e67afcfb1961a000656f53.tar.gz
historical-700cb79a688bf5b710e67afcfb1961a000656f53.tar.bz2
historical-700cb79a688bf5b710e67afcfb1961a000656f53.zip
initial commit
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/supybot/ChangeLog10
-rw-r--r--net-irc/supybot/Manifest5
-rw-r--r--net-irc/supybot/files/digest-supybot-0.77.01
-rw-r--r--net-irc/supybot/files/supybot-0.77.0-setup.py.patch19
-rw-r--r--net-irc/supybot/metadata.xml6
-rw-r--r--net-irc/supybot/supybot-0.77.0.ebuild42
6 files changed, 83 insertions, 0 deletions
diff --git a/net-irc/supybot/ChangeLog b/net-irc/supybot/ChangeLog
new file mode 100644
index 000000000000..32276b4f06ef
--- /dev/null
+++ b/net-irc/supybot/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-irc/supybot
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/supybot/ChangeLog,v 1.1 2004/02/28 21:50:03 liquidx Exp $
+
+*supybot-0.77.0 (28 Feb 2004)
+
+ 28 Feb 2004; Alastair Tse <liquidx@gentoo.org> supybot-0.77.0.ebuild:
+ initial ebuild. patch for setup.py thanks to David Grant
+ <david.grant@telus.net> (#42556)
+
diff --git a/net-irc/supybot/Manifest b/net-irc/supybot/Manifest
new file mode 100644
index 000000000000..dcc1110b3b2f
--- /dev/null
+++ b/net-irc/supybot/Manifest
@@ -0,0 +1,5 @@
+MD5 7a9c94ae0be7ceeaceda448edab07f43 ChangeLog 411
+MD5 eccd3e44b1e8fc954692d4faf329cf38 metadata.xml 218
+MD5 e5d24310612caaef6e3b91206aeac494 supybot-0.77.0.ebuild 906
+MD5 67a13f83c4ad67ef8e6e25c06b67cf3e files/digest-supybot-0.77.0 67
+MD5 e723df2ced2db8d65e4b8ed5026d2b2b files/supybot-0.77.0-setup.py.patch 629
diff --git a/net-irc/supybot/files/digest-supybot-0.77.0 b/net-irc/supybot/files/digest-supybot-0.77.0
new file mode 100644
index 000000000000..9573b6d79954
--- /dev/null
+++ b/net-irc/supybot/files/digest-supybot-0.77.0
@@ -0,0 +1 @@
+MD5 6d53a2a9901549d52fecfafb0012134b Supybot-0.77.0.tar.bz2 342323
diff --git a/net-irc/supybot/files/supybot-0.77.0-setup.py.patch b/net-irc/supybot/files/supybot-0.77.0-setup.py.patch
new file mode 100644
index 000000000000..18116c92624b
--- /dev/null
+++ b/net-irc/supybot/files/supybot-0.77.0-setup.py.patch
@@ -0,0 +1,19 @@
+--- setup.py.orig 2004-02-23 03:50:20.555071326 -0500
++++ setup.py 2004-02-23 03:50:32.898341811 -0500
+@@ -46,16 +46,6 @@
+ otherFiles = glob.glob(os.path.join('others', '*.py'))
+ pluginFiles = glob.glob(os.path.join('plugins', '*.py'))
+
+-# This is a terrible hack.
+-previousInstall = os.path.join(get_python_lib(), 'supybot')
+-if os.path.exists(previousInstall):
+- try:
+- shutil.rmtree(previousInstall)
+- except Exception, e:
+- print 'Couldn\'t remove former installation: %s' % e
+- print 'Remove by hand and then run this script.'
+- sys.exit(-1)
+-
+ setup(
+ # Metadata
+ name='supybot',
diff --git a/net-irc/supybot/metadata.xml b/net-irc/supybot/metadata.xml
new file mode 100644
index 000000000000..05e3b5da750c
--- /dev/null
+++ b/net-irc/supybot/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+<maintainer><email>liquidx@gentoo.org</email></maintainer>
+</pkgmetadata>
diff --git a/net-irc/supybot/supybot-0.77.0.ebuild b/net-irc/supybot/supybot-0.77.0.ebuild
new file mode 100644
index 000000000000..8cc8a71c1a15
--- /dev/null
+++ b/net-irc/supybot/supybot-0.77.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/supybot/supybot-0.77.0.ebuild,v 1.1 2004/02/28 21:50:03 liquidx Exp $
+
+inherit distutils
+
+MY_P=${P/s/S}
+
+DESCRIPTION="Python based extensible IRC infobot and channel bot"
+HOMEPAGE="http://supybot.sf.net/"
+SRC_URI="mirror://sourceforge/supybot/${MY_P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.3
+ >=dev-python/pysqlite-0.4.3"
+
+S=${WORKDIR}/${MY_P}
+
+PYTHON_MODNAME="supybot"
+DOCS="ACKS BUGS LICENSE TODO"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}; epatch ${FILESDIR}/${P}-setup.py.patch
+}
+
+src_install() {
+ distutils_src_install
+ dodoc examples/Random.py
+ docinto developers
+ dodoc docs/*
+ docinto plugins
+ dodoc docs/plugins/*
+}
+
+pkg_postinst() {
+ einfo "Use supybot-wizard to create a configuration file"
+}