summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2009-04-28 07:32:07 +0000
committerTorsten Veller <tove@gentoo.org>2009-04-28 07:32:07 +0000
commit35e9a0f2432a53020b48a7676b3abf3ef8884fc1 (patch)
treeb7ede7454838139d75e9f49bc17823578a1278ad /net-libs/liblockfile/liblockfile-1.08.ebuild
parentMinor cleanup and proper keywording (diff)
downloadhistorical-35e9a0f2432a53020b48a7676b3abf3ef8884fc1.tar.gz
historical-35e9a0f2432a53020b48a7676b3abf3ef8884fc1.tar.bz2
historical-35e9a0f2432a53020b48a7676b3abf3ef8884fc1.zip
Version bump. Thanks Peter Alfredsen (#218619)
Package-Manager: portage-2.2_rc31/cvs/Linux i686
Diffstat (limited to 'net-libs/liblockfile/liblockfile-1.08.ebuild')
-rw-r--r--net-libs/liblockfile/liblockfile-1.08.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-libs/liblockfile/liblockfile-1.08.ebuild b/net-libs/liblockfile/liblockfile-1.08.ebuild
new file mode 100644
index 000000000000..1f49b09b99ed
--- /dev/null
+++ b/net-libs/liblockfile/liblockfile-1.08.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/liblockfile/liblockfile-1.08.ebuild,v 1.1 2009/04/28 07:32:07 tove Exp $
+
+EAPI=2
+
+inherit eutils multilib autotools
+
+DESCRIPTION="Implements functions designed to lock the standard mailboxes"
+HOMEPAGE="http://www.debian.org/"
+SRC_URI="mirror://debian/pool/main/libl/${PN}/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-stale_lock.patch
+ epatch "${FILESDIR}"/${PN}-1.06-respectflags.patch
+ epatch "${FILESDIR}"/${PN}-orphan-file.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-mailgroup=mail --enable-shared
+}
+
+src_install() {
+ dodir /usr/{bin,include,$(get_libdir)} /usr/share/man/{man1,man3}
+ emake ROOT="${D}" install || die
+ dodoc README Changelog || die
+}