summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-11-11 13:40:43 +0000
committerPacho Ramos <pacho@gentoo.org>2014-11-11 13:40:43 +0000
commit916578fc9fa800359663d2adc10b54ae47a63d4f (patch)
treee4b2f752c73b1bb6a842c7f1972af502f2087338 /net-libs/libnice/libnice-0.1.8.ebuild
parentVersion bump (now with stable 1.6.x finally, allowing us to move to it sooner... (diff)
downloadhistorical-916578fc9fa800359663d2adc10b54ae47a63d4f.tar.gz
historical-916578fc9fa800359663d2adc10b54ae47a63d4f.tar.bz2
historical-916578fc9fa800359663d2adc10b54ae47a63d4f.zip
Version bump, drop old
Package-Manager: portage-2.2.14/cvs/Linux x86_64 Manifest-Sign-Key: 0xA188FBD4
Diffstat (limited to 'net-libs/libnice/libnice-0.1.8.ebuild')
-rw-r--r--net-libs/libnice/libnice-0.1.8.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-libs/libnice/libnice-0.1.8.ebuild b/net-libs/libnice/libnice-0.1.8.ebuild
new file mode 100644
index 000000000000..1ef6cf34ff15
--- /dev/null
+++ b/net-libs/libnice/libnice-0.1.8.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnice/libnice-0.1.8.ebuild,v 1.1 2014/11/11 13:40:42 pacho Exp $
+
+EAPI=5
+inherit eutils multilib-minimal
+
+DESCRIPTION="An implementation of the Interactice Connectivity Establishment standard (ICE)"
+HOMEPAGE="http://nice.freedesktop.org/wiki/"
+SRC_URI="http://nice.freedesktop.org/releases/${P}.tar.gz"
+
+LICENSE="|| ( MPL-1.1 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="+introspection +upnp"
+
+RDEPEND="
+ >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-1.30.0 )
+ upnp? ( >=net-libs/gupnp-igd-0.2.4:=[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+"
+
+# Many tests fail from time to time, for example:
+# https://bugs.freedesktop.org/show_bug.cgi?id=81691
+RESTRICT="test"
+
+multilib_src_configure() {
+ # gstreamer plugin split off into media-plugins/gst-plugins-libnice
+ ECONF_SOURCE=${S} \
+ econf --disable-static \
+ --without-gstreamer \
+ --without-gstreamer-0.10 \
+ $(use_enable introspection) \
+ $(use_enable upnp gupnp)
+
+ if multilib_is_native_abi; then
+ ln -s {"${S}"/,}docs/reference/libnice/html || die
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files --modules
+}