summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2009-03-10 18:51:15 +0000
committerTony Vroon <chainsaw@gentoo.org>2009-03-10 18:51:15 +0000
commit277dc93078c3929a7c09c90cdd14aab28f727885 (patch)
tree98e87f901f2898911877b0bfc6ca51d5f990caa5 /net-libs/libpri/libpri-1.2.4-r2.ebuild
parentDrop aac use flag, split to faac / faad use flags - ffmpeg has native AAC enc... (diff)
downloadhistorical-277dc93078c3929a7c09c90cdd14aab28f727885.tar.gz
historical-277dc93078c3929a7c09c90cdd14aab28f727885.tar.bz2
historical-277dc93078c3929a7c09c90cdd14aab28f727885.zip
Version bump to 1.4 branch, for use with Asterisk 1.6 which is masked. Patches rebased. BRIstuff failed to build/patch correctly after repeated attempts, so dropped for now.
Package-Manager: portage-2.1.6.7/cvs/Linux x86_64
Diffstat (limited to 'net-libs/libpri/libpri-1.2.4-r2.ebuild')
-rw-r--r--net-libs/libpri/libpri-1.2.4-r2.ebuild22
1 files changed, 8 insertions, 14 deletions
diff --git a/net-libs/libpri/libpri-1.2.4-r2.ebuild b/net-libs/libpri/libpri-1.2.4-r2.ebuild
index 9e1036cacd3e..d712dbff6169 100644
--- a/net-libs/libpri/libpri-1.2.4-r2.ebuild
+++ b/net-libs/libpri/libpri-1.2.4-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libpri/libpri-1.2.4-r2.ebuild,v 1.3 2007/05/01 09:17:01 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libpri/libpri-1.2.4-r2.ebuild,v 1.4 2009/03/10 18:51:15 chainsaw Exp $
inherit eutils
@@ -14,7 +14,6 @@ DESCRIPTION="Primary Rate ISDN (PRI) library"
HOMEPAGE="http://www.asterisk.org/"
SRC_URI="http://ftp.digium.com/pub/libpri/${MY_P}.tar.gz
bri? ( http://www.junghanns.net/downloads/bristuff-${BRI_VERSION}.tar.gz )"
-# bri? ( http://www.netdomination.org/pub/asterisk/libpri-${PV}-bristuff-${BRI_VERSION}.diff.gz )"
S="${WORKDIR}/${MY_P}"
@@ -24,24 +23,20 @@ SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~ppc sparc x86"
-DEPEND="virtual/libc"
-
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PN}-1.2.3-gentoo.diff
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-1.2.3-gentoo.diff"
if use bri; then
einfo "Patching libpri w/ BRI stuff (${BRI_VERSION})"
# fix a small clash in patches
sed -i -e "s:CFLAGS=:CFLAGS+=:" \
- ${S_BRI}/patches/libpri.patch
-# ${WORKDIR}/libpri-${PV}-bristuff-${BRI_VERSION}.diff
+ "${S_BRI}/patches/libpri.patch"
- epatch ${S_BRI}/patches/libpri.patch
-# epatch ${WORKDIR}/libpri-${PV}-bristuff-${BRI_VERSION}.diff
+ epatch "${S_BRI}/patches/libpri.patch"
fi
}
@@ -50,7 +45,6 @@ src_compile() {
}
src_install() {
- make INSTALL_PREFIX=${D} install || die
-
- dodoc ChangeLog README TODO LICENSE
+ make INSTALL_PREFIX="${D}" install || die
+ dodoc ChangeLog README TODO
}