summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-19 01:23:34 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-19 01:23:34 +0000
commit130e9cc2db7e3914e2fd9397f6074487afdaa140 (patch)
tree6dfea93627e58a213bd43c0f7986f1f30bf3bb5d /net-libs/libtorrent/libtorrent-0.10.3-r1.ebuild
parentVersion bump, use external GeoIP version now without patch; add instead a pat... (diff)
downloadhistorical-130e9cc2db7e3914e2fd9397f6074487afdaa140.tar.gz
historical-130e9cc2db7e3914e2fd9397f6074487afdaa140.tar.bz2
historical-130e9cc2db7e3914e2fd9397f6074487afdaa140.zip
Replace -O2 with -O3 on x86 systems running GCC 4.1. Closes bug #151221.
Package-Manager: portage-2.1.2_pre3-r3
Diffstat (limited to 'net-libs/libtorrent/libtorrent-0.10.3-r1.ebuild')
-rw-r--r--net-libs/libtorrent/libtorrent-0.10.3-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-libs/libtorrent/libtorrent-0.10.3-r1.ebuild b/net-libs/libtorrent/libtorrent-0.10.3-r1.ebuild
new file mode 100644
index 000000000000..8798ea4f8ce7
--- /dev/null
+++ b/net-libs/libtorrent/libtorrent-0.10.3-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/libtorrent-0.10.3-r1.ebuild,v 1.1 2006/10/19 01:23:34 flameeyes Exp $
+
+inherit eutils toolchain-funcs flag-o-matic libtool
+
+DESCRIPTION="LibTorrent is a BitTorrent library written in C++ for *nix."
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="debug"
+
+RDEPEND=">=dev-libs/libsigc++-2"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.11"
+
+src_compile() {
+ replace-flags -Os -O2
+
+ if [[ $(tc-arch) = "x86" ]]; then
+ filter-flags -fomit-frame-pointer
+
+ # See bug #151221. It seems only to hit on GCC 4.1 and x86 architecture
+ # it could be safer to fallback to -O1, but with the high use of STL in
+ # rtorrent, that could make it too slow.
+ [[ $(gcc-major-version)$(gcc-minor-version) == "41" ]] && replace-flags -O2 -O3
+ fi
+
+ elibtoolize
+ econf \
+ $(use_enable debug) \
+ --disable-dependency-tracking \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}