summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-04-29 22:46:29 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-04-29 22:46:29 +0000
commit789de7ffa3758c946168c37d8aea491480986835 (patch)
tree021032edbd626069d3f504781b88b85b24a15dea /net-libs/pam_ldap/pam_ldap-178.ebuild
parentStable on sparc wrt #90238, #87264 (diff)
downloadhistorical-789de7ffa3758c946168c37d8aea491480986835.tar.gz
historical-789de7ffa3758c946168c37d8aea491480986835.tar.bz2
historical-789de7ffa3758c946168c37d8aea491480986835.zip
version bump.
Package-Manager: portage-2.0.51.20-r5
Diffstat (limited to 'net-libs/pam_ldap/pam_ldap-178.ebuild')
-rw-r--r--net-libs/pam_ldap/pam_ldap-178.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-libs/pam_ldap/pam_ldap-178.ebuild b/net-libs/pam_ldap/pam_ldap-178.ebuild
new file mode 100644
index 000000000000..5ef0ccc8764b
--- /dev/null
+++ b/net-libs/pam_ldap/pam_ldap-178.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/pam_ldap/pam_ldap-178.ebuild,v 1.1 2005/04/29 22:46:29 robbat2 Exp $
+
+DESCRIPTION="PAM LDAP Module"
+HOMEPAGE="http://www.padl.com/OSS/pam_ldap.html"
+SRC_URI="http://www.padl.com/download/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 LGPL-2 )"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ppc ~hppa ~alpha"
+IUSE="ssl"
+DEPEND=">=sys-libs/glibc-2.1.3
+ >=sys-libs/pam-0.72
+ >=net-nds/openldap-1.2.11"
+
+src_compile() {
+ export WANT_AUTOCONF=2.5
+ aclocal
+ autoconf
+ automake --add-missing
+
+ econf --with-ldap-lib=openldap `use_enable ssl` || die
+ emake || die
+}
+
+src_install() {
+ exeinto /lib/security
+ doexe pam_ldap.so
+
+ dodoc pam.conf ldap.conf ldapns.schema chsh chfn certutil
+ dodoc ChangeLog COPYING.* CVSVersionInfo.txt README AUTHORS ns-pwd-policy.schema
+ docinto pam.d
+ dodoc pam.d/*
+}