summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-11-20 23:02:34 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-11-20 23:02:34 +0000
commit9658cc7258fe6e2bce17954d50992962a5160f51 (patch)
tree69fdeadbbc2a9006fb883f3bf889b21fa3d5bc0f /net-mail/mailman
parentVersion bumped. (diff)
downloadhistorical-9658cc7258fe6e2bce17954d50992962a5160f51.tar.gz
historical-9658cc7258fe6e2bce17954d50992962a5160f51.tar.bz2
historical-9658cc7258fe6e2bce17954d50992962a5160f51.zip
Version bumped.
Diffstat (limited to 'net-mail/mailman')
-rw-r--r--net-mail/mailman/Manifest4
-rw-r--r--net-mail/mailman/mailman-2.1.3.ebuild129
2 files changed, 131 insertions, 2 deletions
diff --git a/net-mail/mailman/Manifest b/net-mail/mailman/Manifest
index 34fc40eba1d0..6b0cdcbbcd18 100644
--- a/net-mail/mailman/Manifest
+++ b/net-mail/mailman/Manifest
@@ -1,10 +1,10 @@
-MD5 f1816735a8a48947df0986e83d4ac7e7 ChangeLog 3057
+MD5 049027dd6b2c92879094ea0886ecd569 ChangeLog 3178
MD5 8d8510cdbf63e66847896f3a6202ebe2 mailman-2.1.1-r2.ebuild 2582
MD5 f076b0db37f7346992b7b230f002d9ad mailman-2.1.1-r3.ebuild 2731
MD5 ae502e68064f32e3641dd529ed3e146d mailman-2.1.2.ebuild 3673
MD5 cd6328101bbc9d0e28ff351c2e664f29 mailman-2.1.2-r1.ebuild 3716
MD5 5721b86fd871bdfab77231abc6e02f68 metadata.xml 161
-MD5 a040098c92c03e177ec1ef2bde1118c5 mailman-2.1.3.ebuild 3744
+MD5 9d1a9d26ad40fc653b9933cb18d84be0 mailman-2.1.3.ebuild 3741
MD5 2bb507c6bb27de07563452f64cdd952e files/README.gentoo 4643
MD5 3163b3164584897610113805a484fd2d files/digest-mailman-2.1.1-r2 63
MD5 3163b3164584897610113805a484fd2d files/digest-mailman-2.1.1-r3 63
diff --git a/net-mail/mailman/mailman-2.1.3.ebuild b/net-mail/mailman/mailman-2.1.3.ebuild
new file mode 100644
index 000000000000..7c2bdd43ea97
--- /dev/null
+++ b/net-mail/mailman/mailman-2.1.3.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mailman/mailman-2.1.3.ebuild,v 1.1 2003/11/20 23:02:28 mholzer Exp $
+
+IUSE="apache2"
+
+DESCRIPTION="A python-based mailing list server with an extensive web interface"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+RESTRICT="nomirror"
+HOMEPAGE="http://www.list.org/"
+
+SLOT="O"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc"
+
+DEPEND=">=dev-lang/python-1.5.2
+ virtual/mta
+ net-www/apache"
+
+INSTALLDIR="/usr/local/mailman"
+APACHEGID="81"
+MAILGID="280"
+
+pkg_setup() {
+ if ! grep -q ^mailman: /etc/group ; then
+ groupadd -g 280 mailman || die "problem adding group mailman"
+ fi
+ if ! grep -q ^mailman: /etc/passwd ; then
+ useradd -u 280 -g mailman -G cron -s /bin/bash \
+ -d ${INSTALLDIR} -c "mailman" mailman
+ fi
+ mkdir -p ${INSTALLDIR}
+ chown mailman.mailman ${INSTALLDIR}
+ chmod 2775 ${INSTALLDIR}
+}
+
+src_compile() {
+ econf \
+ --prefix=${INSTALLDIR} \
+ --with-mail-gid=${MAILGID} \
+ --with-cgi-gid=${APACHEGID} \
+ || die "configure failed"
+
+ make || die "make failed"
+}
+
+src_install () {
+ ID=${D}${INSTALLDIR}
+
+ dodir ${ID}/logs
+ keepdir ${ID}/logs
+
+ dodir ${ID}/spam
+ keepdir ${ID}/spam
+
+ chown -R mailman.mailman ${ID}
+ chmod 2775 ${ID}
+
+ make prefix=${ID} var_prefix=${ID} doinstall || die
+
+ if [ "`use apache2`" ]; then
+ dodir /etc/apache2/conf/modules.d
+ insinto /etc/apache2/conf/modules.d
+ newins ${FILESDIR}/mailman.conf 50_mailman.conf
+ else
+ dodir /etc/apache/conf/addon-modules
+ insinto /etc/apache/conf/addon-modules
+ doins ${FILESDIR}/mailman.conf
+ fi
+
+ dodoc ${FILESDIR}/README.gentoo
+ dodoc ACK* BUGS FAQ NEWS README* TODO UPGRADING INSTALL
+ dodoc contrib/README.check_perms_grsecurity contrib/mm-handler.readme
+ dodoc contrib/virtusertable contrib/mailman.mc
+
+ cp contrib/*.py contrib/majordomo2mailman.pl contrib/auto \
+ contrib/mm-handler* ${D}/usr/local/mailman/bin
+
+ # Save the old config into the new package as CONFIG_PROTECT
+ # doesn't work for this package.
+ if [ -f ${ROOT}/var/mailman/Mailman/mm_cfg.py ]; then
+ cp ${ROOT}/var/mailman/Mailman/mm_cfg.py \
+ ${D}/usr/local/mailman/Mailman/mm_cfg.py
+ einfo "Your old config has been saved as mm_cfg.py"
+ einfo "A new config has been installed as mm_cfg.dist"
+ fi
+ if [ -f ${ROOT}/home/mailman/Mailman/mm_cfg.py ]; then
+ cp ${ROOT}/home/mailman/Mailman/mm_cfg.py \
+ ${D}/usr/local/mailman/Mailman/mm_cfg.py
+ einfo "Your old config has been saved as mm_cfg.py"
+ einfo "A new config has been installed as mm_cfg.py.dist"
+ fi
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/mailman.rc mailman
+ }
+
+pkg_postinst() {
+ cd ${INSTALLDIR}
+ bin/update
+ bin/check_perms -f
+ einfo ""
+ einfo "Please read /usr/share/doc/${PF}/README.gentoo.gz for additional"
+ einfo "Setup information, mailman will NOT run unless you follow"
+ einfo "those instructions!"
+ einfo ""
+ ewarn ""
+ ewarn "The home directory for mailman has been moved from /var/mailman"
+ ewarn "(pre 2.1.1-r2) or /home/mailman (2.1.1-r3) to /usr/local/mailman"
+ ewarn "This should hopefully solve any problems, and this is what the mailman"
+ ewarn "default is. (Any existing config has been saved in the"
+ ewarn "new home directory.)"
+ ewarn ""
+ if [ ! "`use apache2`" ]; then
+ einfo "It appears that you aren't running apache2..."
+ einfo "ebuild /var/db/pkg/net-mail/mailman/mailman-2.1.2-r1.ebuild config"
+ einfo "to add the mailman hooks to your config"
+ fi
+}
+
+pkg_config() {
+ if [ ! "`use apache2`" ]; then
+ einfo "Updating apache config"
+ einfo "added: \"Include conf/addon-modules/mailman.conf\""
+ einfo "to ${ROOT}etc/apache/conf/apache.conf"
+ echo "Include conf/addon-modules/mailman.conf" \
+ >> ${ROOT}etc/apache/conf/apache.conf
+ fi
+}