summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2005-05-28 04:25:42 +0000
committerJoshua Kinard <kumba@gentoo.org>2005-05-28 04:25:42 +0000
commita35cf688405c753c58a04d439da3a932246b41d8 (patch)
tree03f9c01b5b9ae1ad2e788672e5f2f95c042386f5 /net-mail/mhonarc/mhonarc-2.6.11.ebuild
parentVersion bump. (diff)
downloadhistorical-a35cf688405c753c58a04d439da3a932246b41d8.tar.gz
historical-a35cf688405c753c58a04d439da3a932246b41d8.tar.bz2
historical-a35cf688405c753c58a04d439da3a932246b41d8.zip
Version bump and fix to SRC_URI to download the source properly. Removed older 2.6.8 version. Closes bugs #94074 and #93929.
Package-Manager: portage-2.0.51.21
Diffstat (limited to 'net-mail/mhonarc/mhonarc-2.6.11.ebuild')
-rw-r--r--net-mail/mhonarc/mhonarc-2.6.11.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-mail/mhonarc/mhonarc-2.6.11.ebuild b/net-mail/mhonarc/mhonarc-2.6.11.ebuild
new file mode 100644
index 000000000000..40fb5b863ff4
--- /dev/null
+++ b/net-mail/mhonarc/mhonarc-2.6.11.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mhonarc/mhonarc-2.6.11.ebuild,v 1.1 2005/05/28 04:25:42 kumba Exp $
+
+inherit perl-module
+
+IUSE=""
+
+SRC_URI="http://www.mhonarc.org/release/MHonArc/tar/MHonArc-${PV}.tar.bz2"
+RESTRICT="nomirror"
+
+DESCRIPTION="Perl Mail-to-HTML Converter"
+HOMEPAGE="http://www.mhonarc.org/"
+LICENSE="GPL-2"
+CATEGORY="net-mail"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~amd64"
+
+S="${WORKDIR}/${P/mhonarc/MHonArc}"
+
+src_install() {
+ mv ${S}/Makefile ${S}/Makefile.orig
+ sed -e "s:/usr:${D}/usr:g" -e "s:${D}/usr/bin/perl:/usr/bin/perl:g" \
+ ${S}/Makefile.orig > ${S}/Makefile
+ perl-module_src_install
+}