summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2004-12-15 09:47:36 +0000
committerAndrej Kacian <ticho@gentoo.org>2004-12-15 09:47:36 +0000
commit9dbf3efceb34d0152daed6fa7636ed1ab890b5de (patch)
treea8c79c8ddc89b80dd9087b97db9349be290eb97e /net-mail/popick/popick-0.1.ebuild
parenttouch (diff)
downloadhistorical-9dbf3efceb34d0152daed6fa7636ed1ab890b5de.tar.gz
historical-9dbf3efceb34d0152daed6fa7636ed1ab890b5de.tar.bz2
historical-9dbf3efceb34d0152daed6fa7636ed1ab890b5de.zip
Initial import. Closes #73364.
Diffstat (limited to 'net-mail/popick/popick-0.1.ebuild')
-rw-r--r--net-mail/popick/popick-0.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-mail/popick/popick-0.1.ebuild b/net-mail/popick/popick-0.1.ebuild
new file mode 100644
index 000000000000..0390368ef8e2
--- /dev/null
+++ b/net-mail/popick/popick-0.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/popick/popick-0.1.ebuild,v 1.1 2004/12/15 09:47:36 ticho Exp $
+
+inherit eutils
+
+DESCRIPTION="A POP3 mailbox deleter that allows you to interactively specify regular expressions to match the message headers, and delete matching messages."
+HOMEPAGE="http://www.topfx.com"
+SRC_URI="http://www.topfx.com/dist/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-lang/perl
+ dev-perl/Curses-UI
+ dev-perl/Getopt-Long"
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ mv popick.pl popick || die "Renaming popick.pl to popick"
+ sed -i -e 's:/usr/local:/usr:g' $(grep -rl /usr/local *) || die "sed /usr/local failed"
+}
+
+src_compile() {
+ # No compiling needed :)
+ pod2man popick > popick.1 || die "Generating manpage failed"
+}
+
+src_install() {
+ dobin popick
+ doman popick.1
+}