summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPrakash Shetty <crux@gentoo.org>2001-06-30 12:31:34 +0000
committerPrakash Shetty <crux@gentoo.org>2001-06-30 12:31:34 +0000
commit49dda3b58391a14d983d9c8cd3fa77220889a8bc (patch)
tree5725d6cc43f433d5fd1e1a1d7e468972029a2da7 /net-mail/teapop
parentA clone of Pico with more feature and smaller size. (diff)
downloadhistorical-49dda3b58391a14d983d9c8cd3fa77220889a8bc.tar.gz
historical-49dda3b58391a14d983d9c8cd3fa77220889a8bc.tar.bz2
historical-49dda3b58391a14d983d9c8cd3fa77220889a8bc.zip
A POP Server with Maildir,Virtual Domains,Multiple IP's etc Support.
Diffstat (limited to 'net-mail/teapop')
-rw-r--r--net-mail/teapop/files/digest-teapop-0.3.11
-rw-r--r--net-mail/teapop/files/tpop.xinetd10
-rw-r--r--net-mail/teapop/teapop-0.3.1.ebuild36
3 files changed, 47 insertions, 0 deletions
diff --git a/net-mail/teapop/files/digest-teapop-0.3.1 b/net-mail/teapop/files/digest-teapop-0.3.1
new file mode 100644
index 000000000000..38cae68ca33d
--- /dev/null
+++ b/net-mail/teapop/files/digest-teapop-0.3.1
@@ -0,0 +1 @@
+MD5 5b8979ec78a6ab9dbc98f222a8bc6740 teapop-0.3.1.tar.gz
diff --git a/net-mail/teapop/files/tpop.xinetd b/net-mail/teapop/files/tpop.xinetd
new file mode 100644
index 000000000000..cf9d2e90ef12
--- /dev/null
+++ b/net-mail/teapop/files/tpop.xinetd
@@ -0,0 +1,10 @@
+# These lines below will start the TeaPOP - POP Server
+service pop3
+{
+ socket_type = stream
+ protocol = tcp
+ wait = no
+ user = root
+ server = /usr/libexec/teapop
+ server_args = teapop
+}
diff --git a/net-mail/teapop/teapop-0.3.1.ebuild b/net-mail/teapop/teapop-0.3.1.ebuild
new file mode 100644
index 000000000000..6b20336dfb89
--- /dev/null
+++ b/net-mail/teapop/teapop-0.3.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Prakash Shetty (Crux) <ps@gnuos.org>
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="POP Server with support for Maildir,Virtual Domains,Multiple IP's etc"
+SRC_URI="http://ftp.toontown.org/pub/teapop/${A}"
+HOMEPAGE="http://www.toontown.org/teapop/"
+
+DEPEND=">=sys-libs/glibc-2.1.3"
+
+src_compile() {
+
+ cd ${S}
+ try ./configure --prefix=/usr --enable-lock=flock --disable-apop\
+ --enable-homespool=Maildir
+ try make
+
+}
+
+src_install () {
+
+ cd ${S}
+ try make DESTDIR=${D} install
+ dodoc doc/CREDITS doc/ChangeLog doc/INSTALL
+}
+
+pkg_config() {
+ echo "This config script will add tpop lines to your /etc/xinetd.conf."
+ echo "Press control-C to abort, hit Enter to continue."
+ echo
+ read
+ cat ${FILESDIR}/tpop.xinetd >> ${ROOT}etc/xinetd.conf
+ echo "Modifications applied."
+}