summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Knoblich <stkn@gentoo.org>2004-02-18 23:22:06 +0000
committerStefan Knoblich <stkn@gentoo.org>2004-02-18 23:22:06 +0000
commit1689f7bbb8d232dd1dae1567e51ffcb5ff5ed7c7 (patch)
tree4bebe4ebe44094f795cd3ef0d44b7e4448d8672e /net-misc/asterisk-oh323
parentVersion bumped each version to one with the mremap/munmap vulnerability patch... (diff)
downloadhistorical-1689f7bbb8d232dd1dae1567e51ffcb5ff5ed7c7.tar.gz
historical-1689f7bbb8d232dd1dae1567e51ffcb5ff5ed7c7.tar.bz2
historical-1689f7bbb8d232dd1dae1567e51ffcb5ff5ed7c7.zip
initial import
Diffstat (limited to 'net-misc/asterisk-oh323')
-rw-r--r--net-misc/asterisk-oh323/ChangeLog11
-rw-r--r--net-misc/asterisk-oh323/Manifest6
-rw-r--r--net-misc/asterisk-oh323/asterisk-oh323-0.5.9.ebuild37
-rw-r--r--net-misc/asterisk-oh323/files/asterisk-oh323-0.5.9-Makefile.patch36
-rw-r--r--net-misc/asterisk-oh323/files/asterisk-oh323-0.5.9-asterisk-driver-Makefile.patch10
-rw-r--r--net-misc/asterisk-oh323/files/digest-asterisk-oh323-0.5.91
-rw-r--r--net-misc/asterisk-oh323/metadata.xml8
7 files changed, 109 insertions, 0 deletions
diff --git a/net-misc/asterisk-oh323/ChangeLog b/net-misc/asterisk-oh323/ChangeLog
new file mode 100644
index 000000000000..69105a8f3f2a
--- /dev/null
+++ b/net-misc/asterisk-oh323/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-misc/asterisk-oh323
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-oh323/ChangeLog,v 1.1 2004/02/18 23:22:06 stkn Exp $
+
+*asterisk-oh323-0.5.9 (19 Feb 2004)
+
+ 19 Feb 2004; Stefan Knoblich <stkn@gentoo.org> asterisk-oh323-0.5.9.ebuild,
+ metadata.xml, files/asterisk-oh323-0.5.9-Makefile.patch,
+ files/asterisk-oh323-0.5.9-asterisk-driver-Makefile.patch:
+ Initial import. Ebuild submitted by Russell Cloran <russell@rucus.net>
+
diff --git a/net-misc/asterisk-oh323/Manifest b/net-misc/asterisk-oh323/Manifest
new file mode 100644
index 000000000000..ad76955cdb82
--- /dev/null
+++ b/net-misc/asterisk-oh323/Manifest
@@ -0,0 +1,6 @@
+MD5 965a5b086b42a47e54c034f0b632f5b9 asterisk-oh323-0.5.9.ebuild 922
+MD5 de41c503f05f5f99a8635b0e333729a5 metadata.xml 217
+MD5 40d44cd580aafc63d23885373f9301d4 ChangeLog 535
+MD5 4313406e25f5b3bc750c792e1448ce04 files/digest-asterisk-oh323-0.5.9 71
+MD5 d81ba6256f0eadf0479f37fae7451836 files/asterisk-oh323-0.5.9-Makefile.patch 1163
+MD5 ffa52289baeedd9c24e1a9eb21ab721f files/asterisk-oh323-0.5.9-asterisk-driver-Makefile.patch 323
diff --git a/net-misc/asterisk-oh323/asterisk-oh323-0.5.9.ebuild b/net-misc/asterisk-oh323/asterisk-oh323-0.5.9.ebuild
new file mode 100644
index 000000000000..57eceb15d86b
--- /dev/null
+++ b/net-misc/asterisk-oh323/asterisk-oh323-0.5.9.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-oh323/asterisk-oh323-0.5.9.ebuild,v 1.1 2004/02/18 23:22:06 stkn Exp $
+
+IUSE=""
+
+inherit eutils
+
+DESCRIPTION="H.323 Channel plugin for the Asterisk soft PBX"
+HOMEPAGE="http://www.inaccessnetworks.com/projects/asterisk-oh323/"
+SRC_URI="http://www.inaccessnetworks.com/projects/asterisk-oh323/download/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND=">=dev-libs/pwlib-1.5.2-r2
+ >=net-libs/openh323-1.12.2-r2
+ >=net-misc/asterisk-0.5.0"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}-Makefile.patch
+ epatch ${FILESDIR}/${P}-asterisk-driver-Makefile.patch
+}
+
+src_compile() {
+ # NOTRACE=1 is required (atm)
+ # plugin won't work if this isn't set!
+ emake NOTRACE=1 || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}
diff --git a/net-misc/asterisk-oh323/files/asterisk-oh323-0.5.9-Makefile.patch b/net-misc/asterisk-oh323/files/asterisk-oh323-0.5.9-Makefile.patch
new file mode 100644
index 000000000000..715d397fc542
--- /dev/null
+++ b/net-misc/asterisk-oh323/files/asterisk-oh323-0.5.9-Makefile.patch
@@ -0,0 +1,36 @@
+--- Makefile.orig 2004-02-18 22:09:49.000000000 +0100
++++ Makefile 2004-02-18 22:11:11.000000000 +0100
+@@ -44,13 +44,13 @@
+ # Set PWLIBDIR variable to the directory containing the sources of
+ # PWlib library.
+ #
+-PWLIBDIR=/root/src/oh323/pwlib
++PWLIBDIR=/usr/share/pwlib
+
+ #
+ # Set OPENH323LIBDIR variable to the directory containing the sources of
+ # OpenH323 library.
+ #
+-OPENH323DIR=/root/src/oh323/openh323
++OPENH323DIR=/usr/share/openh323
+
+ #
+ # Set ASTERISKSRCDIR variable to the directory where ASTERISK's source files
+@@ -76,7 +76,7 @@
+ # LD_LIBRARY_PATH shell variable, or to the /etc/ld.so.conf
+ # file and run "ldconfig".
+ #
+-OH323WRAPLIBDIR=$(DESTDIR)/usr/local/lib
++OH323WRAPLIBDIR=$(DESTDIR)/usr/lib
+
+ #
+ # Set SSLINCDIR variable to the directory where ssl/crypto
+@@ -158,7 +158,7 @@
+ OPENH323USERFLAGS += P_PTHREADS=1
+ endif
+ OPENH323FLAGS=$(shell make $(OPENH323USERFLAGS) --no-print-directory -s \
+- -C $(OPENH323DIR) \
++ -C $(OPENH323DIR) -f openh323u.mak \
+ PWLIBDIR=$(PWLIBDIR) OPENH323DIR=$(OPENH323DIR) ccflags)
+ CPPFLAGS=$(OPENH323FLAGS) -Wall
+ ASTERISKINCLUDE=-I$(ASTERISKSRCDIR)/include -I../wrapper
diff --git a/net-misc/asterisk-oh323/files/asterisk-oh323-0.5.9-asterisk-driver-Makefile.patch b/net-misc/asterisk-oh323/files/asterisk-oh323-0.5.9-asterisk-driver-Makefile.patch
new file mode 100644
index 000000000000..7f874ed4dab7
--- /dev/null
+++ b/net-misc/asterisk-oh323/files/asterisk-oh323-0.5.9-asterisk-driver-Makefile.patch
@@ -0,0 +1,10 @@
+--- asterisk-driver/Makefile.orig 2003-10-07 14:31:45.000000000 +0200
++++ asterisk-driver/Makefile 2004-02-05 15:51:25.884616624 +0200
+@@ -29,6 +29,7 @@
+ #################################################################################
+
+ TARGET=chan_oh323.so
++OPENH323DIR=/usr
+
+ ifndef SKIP_SUFFIX
+ ifeq ($(WRAPSTAT),1)
diff --git a/net-misc/asterisk-oh323/files/digest-asterisk-oh323-0.5.9 b/net-misc/asterisk-oh323/files/digest-asterisk-oh323-0.5.9
new file mode 100644
index 000000000000..344bcc759a42
--- /dev/null
+++ b/net-misc/asterisk-oh323/files/digest-asterisk-oh323-0.5.9
@@ -0,0 +1 @@
+MD5 bcd262211f0db31181d44fdd286c6ae1 asterisk-oh323-0.5.9.tar.gz 72463
diff --git a/net-misc/asterisk-oh323/metadata.xml b/net-misc/asterisk-oh323/metadata.xml
new file mode 100644
index 000000000000..a3cddc42f9cc
--- /dev/null
+++ b/net-misc/asterisk-oh323/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>voip</herd>
+<maintainer>
+ <email>stkn@gentoo.org</email>
+</maintainer>
+</pkgmetadata>