summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-12-23 10:48:16 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-12-23 10:48:16 +0000
commitd32ced771d08f41a6ecada7f3d8b1bb379823c07 (patch)
tree77d1cfb94e9d8fc0fdc7103b95de28bb211d86de /net-misc/dante/dante-1.1.14-r2.ebuild
parenttake bug #19988, improve on it, and make some things better in general (diff)
downloadhistorical-d32ced771d08f41a6ecada7f3d8b1bb379823c07.tar.gz
historical-d32ced771d08f41a6ecada7f3d8b1bb379823c07.tar.bz2
historical-d32ced771d08f41a6ecada7f3d8b1bb379823c07.zip
take bug #19988, improve on it, and make some things better in general
Diffstat (limited to 'net-misc/dante/dante-1.1.14-r2.ebuild')
-rw-r--r--net-misc/dante/dante-1.1.14-r2.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/net-misc/dante/dante-1.1.14-r2.ebuild b/net-misc/dante/dante-1.1.14-r2.ebuild
new file mode 100644
index 000000000000..894fef2600bc
--- /dev/null
+++ b/net-misc/dante/dante-1.1.14-r2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dante/dante-1.1.14-r2.ebuild,v 1.1 2003/12/23 10:48:10 robbat2 Exp $
+
+inherit gcc fixheadtails
+
+DESCRIPTION="A free socks4,5 and msproxy implemetation"
+HOMEPAGE="http://www.inet.no/dante/"
+SRC_URI="ftp://ftp.inet.no/pub/socks/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ia64"
+IUSE="tcpd debug"
+
+RDEPEND="virtual/glibc
+ sys-libs/pam
+ tcpd? ( sys-apps/tcp-wrappers )"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A} || die "unpack failed"
+ cd ${S} || die "cd failed"
+ epatch ${FILESDIR}/dante-1.1.14-socksify.patch || die "epatch failed"
+ epatch ${FILESDIR}/dante-1.1.14-bindresvport.patch || die "epatch failed"
+ ht_fix_file `find ${S} -name 'configure'`
+}
+
+src_compile() {
+ econf \
+ `use_enable debug` \
+ `use_enable tcpd libwrap` \
+ --with-socks-conf=/etc/socks/socks.conf \
+ --with-sockd-conf=/etc/socks/sockd.conf \
+ ${myconf} \
+ || die "bad ./configure"
+ emake || die "compile problem"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ # bor: comment libdl.so out it seems to work just fine without it
+ sed -i -e 's:libdl\.so::' ${D}/usr/bin/socksify || die 'sed failed'
+
+ # no configuration file by default
+ dodir /etc/socks
+
+ # our init script
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/dante-sockd-init-1.1.14-r2 dante-sockd
+ insinto /etc/conf.d
+ newins ${FILESDIR}/dante-sockd-conf-1.1.14-r2 dante-sockd
+
+ # install documentation
+ dodoc BUGS CREDITS LICENSE NEWS README SUPPORT TODO VERSION
+ docinto txt
+ cd doc
+ dodoc README* *.txt SOCKS4.*
+ docinto example
+ cd ../example
+ dodoc *.conf
+}