summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-07-06 14:20:21 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-07-06 14:20:21 +0000
commit9fbd8c85cfd7db6b314a40f8e26f0e156c4e21cb (patch)
treed91bc530ad97269becfc1c1f3031f63c4348b846 /net-misc/directvnc/directvnc-0.6.1.ebuild
parentnew revision of qt that uses custom CFLAGS for compiling. masked for testing. (diff)
downloadhistorical-9fbd8c85cfd7db6b314a40f8e26f0e156c4e21cb.tar.gz
historical-9fbd8c85cfd7db6b314a40f8e26f0e156c4e21cb.tar.bz2
historical-9fbd8c85cfd7db6b314a40f8e26f0e156c4e21cb.zip
version bump and DirectFB API fix
Diffstat (limited to 'net-misc/directvnc/directvnc-0.6.1.ebuild')
-rw-r--r--net-misc/directvnc/directvnc-0.6.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-misc/directvnc/directvnc-0.6.1.ebuild b/net-misc/directvnc/directvnc-0.6.1.ebuild
new file mode 100644
index 000000000000..a347cb62f30a
--- /dev/null
+++ b/net-misc/directvnc/directvnc-0.6.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/directvnc/directvnc-0.6.1.ebuild,v 1.1 2002/07/06 14:20:21 seemant Exp $
+
+DESCRIPTION="Very thin VNC client for unix framebuffer systems"
+HOMEPAGE="http://adam-lilienthal.de/directvnc"
+LICENSE="GPL-2"
+DEPEND="dev-libs/DirectFB sys-devel/automake sys-devel/autoconf"
+SLOT="0"
+SRC_URI="http://savannah.gnu.org/download/${PN}/${P}.tar.gz"
+
+S=${WORKDIR}/${P}
+
+KEYWORDS="x86"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/src
+
+ #fix src/dfb.c to handle the new API changes in DirectFB
+ cp ${FILESDIR}/dfb.c .
+
+ #fix broken Makefile.am
+ mv Makefile.am Makefile.am.orig
+ sed -e 's/-$(DIRECTFB_LIBS)/$(DIRECTFB_LIBS)/' Makefile.am.orig > Makefile.am
+ cd ..
+ aclocal || die "aclocal failed"
+ autoconf || die "autoconf failed"
+ automake || die "automake failed"
+}
+
+src_compile() {
+ econf || die "./configure failed"
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+}